summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2023-09-27 19:21:46 +0200
committereDgar2023-09-27 19:23:23 +0200
commitb9ba5c9a43d97772f270a2a6fa2bf33b64418c80 (patch)
treefeb59b2156d559d00c504840fede92f63b56701f
parentb77846b4d8e9551340ee606476f7602a8036fd8e (diff)
downloadaur-b9ba5c9a43d97772f270a2a6fa2bf33b64418c80.tar.gz
back to release branch; robuster way for pkgver; finite_element_h_cstdint.patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
-rw-r--r--finite_element_h_cstdint.patch23
3 files changed, 52 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 425c3aaa061a..5aaa80ba4968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fenics-basix-git
- pkgdesc = Interface of FEniCS for ordinary and partial differential equations (C++ from git).
- pkgver = 0.7.0.dev0_r943.b172e62
+ pkgdesc = C++ interface of FEniCS for ordinary and partial differential equations (from git release).
+ pkgver = 0.6.0_r922.36fb8a4
pkgrel = 1
url = https://github.com/FEniCS/basix
arch = i686
@@ -23,7 +23,9 @@ pkgbase = fenics-basix-git
conflicts = basix
replaces = basix
options = !emptydirs
- source = git+https://github.com/FEniCS/basix#branch=main
+ source = git+https://github.com/FEniCS/basix#branch=release
+ source = finite_element_h_cstdint.patch
sha512sums = SKIP
+ sha512sums = b592508f82fd3efa04135440c36d6837d08592d1d8e3f9e31b9b1b7f3871c7c801deeb9b5a7b9740b2104ce72137f27b3f1897ffca39558b3d6469531cd52bd0
pkgname = fenics-basix-git
diff --git a/PKGBUILD b/PKGBUILD
index 84f10d66a7a4..369961abcf94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_base=basix
pkgname=fenics-"${_base}"-git
-pkgdesc="Interface of FEniCS for ordinary and partial differential equations (C++ from git)."
-pkgver=0.7.0.dev0_r943.b172e62
+pkgdesc="C++ interface of FEniCS for ordinary and partial differential equations (from git release)."
+pkgver=0.6.0_r922.36fb8a4
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/FEniCS/${_base}"
@@ -13,8 +13,10 @@ depends=('xtensor' 'xtensor-blas' 'petsc' "blas-openblas")
makedepends=('git' 'boost' 'python-setuptools' "python-numpy" "pybind11" "gcc")
checkdepends=("python-sympy")
options=(!emptydirs)
-source=("git+${url}#branch=main")
-sha512sums=('SKIP')
+source=("git+${url}#branch=release"
+ "finite_element_h_cstdint.patch")
+sha512sums=('SKIP'
+ 'b592508f82fd3efa04135440c36d6837d08592d1d8e3f9e31b9b1b7f3871c7c801deeb9b5a7b9740b2104ce72137f27b3f1897ffca39558b3d6469531cd52bd0')
provides=("${_base}"
"fenics-${_base}")
@@ -97,19 +99,35 @@ export LC_ALL=en_IE.UTF-8
_base_dir="${startdir}"/src/"${_base}"
prepare() {
+ cd "${_base_dir}"
+ patch -Np1 -i ../finite_element_h_cstdint.patch
git -C "${_base_dir}" clean -dfx
}
pkgver() {
cd "${_base_dir}"
- tag="$(grep -m 1 version "${_base_dir}"/pyproject.toml |
- tr -s ' ' | tr -d '"' | tr -d "'" | cut -d' ' -f3 )"
+ # One day, there will be a tag in the repo (or a single
+ # file to analyse) and this will not be needed
+ for i in pyproject.toml setup.cfg setup.py; do
+ # Check if /version/ exists in any of these files
+ if [[ -n $(grep 'version.*=' $i) ]]; then
+ # Get version by removing " , ', spaces and =
+ tag="$(grep -m 1 'version[[:space:]]*=' "${i}" |
+ tr -d '", ' | tr -d "'" | cut -d'=' -f2)"
+ break;
+ fi;
+ done
printf "%s_r%s.%s" \
${tag%%.} \
"$(git rev-list --count HEAD)" \
"$(git rev-parse --short=7 HEAD)"
}
+# # There are no tests
+# check (){
+#
+# }
+
build() {
[ -n "$PETSC_DIR" ] && source /etc/profile.d/petsc.sh
diff --git a/finite_element_h_cstdint.patch b/finite_element_h_cstdint.patch
new file mode 100644
index 000000000000..3d0ef1446f95
--- /dev/null
+++ b/finite_element_h_cstdint.patch
@@ -0,0 +1,23 @@
+From 086461da4b2f83ec842bbe418c8db6dc49bb84c1 Mon Sep 17 00:00:00 2001
+From: Edgar <eDgar>
+Date: Sat, 19 Aug 2023 01:26:28 +0200
+Subject: [PATCH] finite-element.h: #include <cstdint>
+
+---
+ cpp/basix/finite-element.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cpp/basix/finite-element.h b/cpp/basix/finite-element.h
+index 085889a4..37d1faed 100644
+--- a/cpp/basix/finite-element.h
++++ b/cpp/basix/finite-element.h
+@@ -18,6 +18,7 @@
+ #include <string>
+ #include <tuple>
+ #include <vector>
++#include <cstdint>
+
+ /// Basix: FEniCS runtime basis evaluation library
+ namespace basix
+--
+2.41.0