summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreDgar2023-10-16 20:08:03 +0200
committereDgar2023-10-16 20:08:44 +0200
commite8ff757c92297bbc8753bd0610735701599f7876 (patch)
tree0428d62bc2a373160b1e849f369bd4fe21b65dc4
parent796e75a489b36f363d3f8f475bc934bf8b95705d (diff)
downloadaur-e8ff757c92297bbc8753bd0610735701599f7876.tar.gz
0001-add-cstdint-to-finite-element.h.patch
-rw-r--r--0001-add-cstdint-to-finite-element.h.patch (renamed from finite_element_h_cstdint.patch)19
-rw-r--r--PKGBUILD6
2 files changed, 14 insertions, 11 deletions
diff --git a/finite_element_h_cstdint.patch b/0001-add-cstdint-to-finite-element.h.patch
index 3d0ef1446f95..aff8400febeb 100644
--- a/finite_element_h_cstdint.patch
+++ b/0001-add-cstdint-to-finite-element.h.patch
@@ -1,23 +1,26 @@
-From 086461da4b2f83ec842bbe418c8db6dc49bb84c1 Mon Sep 17 00:00:00 2001
-From: Edgar <eDgar>
-Date: Sat, 19 Aug 2023 01:26:28 +0200
-Subject: [PATCH] finite-element.h: #include <cstdint>
+From 40425be69015213c5b402501c5baf87ba0167392 Mon Sep 17 00:00:00 2001
+From: edgar <edgar no reply>
+Date: Mon, 16 Oct 2023 20:02:12 +0200
+Subject: [RFC PATCH] add cstdint to finite-element.h
---
cpp/basix/finite-element.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/cpp/basix/finite-element.h b/cpp/basix/finite-element.h
-index 085889a4..37d1faed 100644
+index c03e1a37..512a2d10 100644
--- a/cpp/basix/finite-element.h
+++ b/cpp/basix/finite-element.h
-@@ -18,6 +18,7 @@
- #include <string>
+@@ -22,6 +22,7 @@
#include <tuple>
+ #include <utility>
#include <vector>
+#include <cstdint>
/// Basix: FEniCS runtime basis evaluation library
namespace basix
+
+base-commit: eebbc524c4afe2bef7f31ce877d2b80830109391
--
-2.41.0
+2.42.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c3fae1f45360..cd946b104734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@ makedepends=("boost" "gcc" "git" "pybind11" "python-build" "python-installer" "p
checkdepends=("python-sympy")
options=(!emptydirs)
source=("git+${url}#branch=main"
- "finite_element_h_cstdint.patch")
+ "0001-add-cstdint-to-finite-element.h.patch")
sha512sums=('SKIP'
- 'b592508f82fd3efa04135440c36d6837d08592d1d8e3f9e31b9b1b7f3871c7c801deeb9b5a7b9740b2104ce72137f27b3f1897ffca39558b3d6469531cd52bd0')
+ '4e7e1223fed54159e6e9dcf20529b0872cf23d95ebe07ba02a088dda26212b51bbdc608b4d4ef5c347c2ebfe029c022049cd01d354294ed191434cd4a8dd20e3')
provides=("${_base}"
"fenics-${_base}")
@@ -100,7 +100,7 @@ _base_dir="${startdir}"/src/"${_base}"
prepare() {
cd "${_base_dir}"
- patch -Np1 -i ../finite_element_h_cstdint.patch
+ patch -Np1 -i ../0001-add-cstdint-to-finite-element.h.patch
git -C "${_base_dir}" clean -dfx
}