summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwen Le Bihan2021-07-25 12:57:38 +0200
committerEwen Le Bihan2021-07-25 12:57:38 +0200
commit6e0ad00b1b1b9d0cf09d56206c8a361327f2bd00 (patch)
treec53330d43ec759fd8370b735d61d4ce4bfadf9db
downloadaur-ffcss.tar.gz
initial release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68335ef689f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ffcss
+ pkgdesc = A CLI interface to apply and configure FirefoxCSS themes
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/ewen-lbh/ffcss
+ arch = x86_64
+ arch = i686
+ license = GPL-3.0
+ makedepends = git
+ makedepends = go>=1.14
+ makedepends = make
+ depends = bash
+ depends = firefox
+ depends = git
+ depends = wget
+ provides = ffcss
+ conflicts = ffcss-git
+ conflicts = ffcss-bin
+ source = ffcss-0.2.0.tar.gz::https://github.com/ewen-lbh/ffcss/archive/v0.2.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = ffcss
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95c207dda424
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ewen Le Bihan <hey@ewen.works>
+pkgname=ffcss
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A CLI interface to apply and configure FirefoxCSS themes"
+arch=('x86_64' 'i686')
+url="https://github.com/ewen-lbh/ffcss"
+license=("GPL-3.0")
+provides=("${pkgname}")
+makedepends=('git' 'go>=1.14' 'make')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+depends=('bash' 'firefox' 'git' 'wget')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ffcss "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p ~/.config/ffcss/themes
+ cp themes/*.yaml ~/.config/ffcss/themes/
+}
+