summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Chin2020-07-03 17:16:30 +0800
committerNathaniel Chin2020-07-03 17:16:30 +0800
commit856f78cfe882217f319bacaa8228b4bd4839cd2e (patch)
tree7dbe1cf0f204a9bd576187abe85c56a4962793a0
parent6ed7ecb53da07029dc6026a505ba89b7268a7bc6 (diff)
downloadaur-856f78cfe882217f319bacaa8228b4bd4839cd2e.tar.gz
Readd svt-av1 support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7258e037e651..414a6254147b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-amd-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)
- pkgver = 4.4.r98264.g548ef7a12b
+ pkgver = 4.4.r98388.g76a3ee996b
pkgrel = 1
url = https://www.ffmpeg.org/
arch = i686
@@ -129,11 +129,13 @@ pkgbase = ffmpeg-amd-full-git
source = 010-ffmpeg-fix-vmaf-model-path.patch
source = 020-ffmpeg-add-svt-hevc-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-hevc-docs-1.4.3.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v1.4.3/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
+ source = 040-ffmpeg-add-svt-av1-0e68b4a34d7baa387b98e2ccaa9beb0c6d41f627.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/0e68b4a34d7baa387b98e2ccaa9beb0c6d41f627/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1.patch
source = LICENSE
sha256sums = SKIP
sha256sums = b6fcef2f4cbb1daa47d17245702fbd67ab3289b6b16f090ab99b9c2669453a02
sha256sums = 878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6
sha256sums = 1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0
+ sha256sums = 5e960b4dab495437082d0838a40a8cae9b67d1cef1ffd57da960afaa2bfd3719
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-amd-full-git
diff --git a/PKGBUILD b/PKGBUILD
index 110a40a97e4f..9528f91787e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
_svt_hevc_ver='1.4.3'
-_svt_av1_ver='c40ee249286f182f29bab717686c300e2912adfe'
+_svt_av1_ver='0e68b4a34d7baa387b98e2ccaa9beb0c6d41f627'
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
-pkgver=4.4.r98264.g548ef7a12b
+pkgver=4.4.r98388.g76a3ee996b
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('i686' 'x86_64')
@@ -47,13 +47,13 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'010-ffmpeg-fix-vmaf-model-path.patch'
"020-ffmpeg-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"030-ffmpeg-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
- #"040-ffmpeg-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch"
+ "040-ffmpeg-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1.patch"
'LICENSE')
sha256sums=('SKIP'
'b6fcef2f4cbb1daa47d17245702fbd67ab3289b6b16f090ab99b9c2669453a02'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
- #'69e0456b56429a422977d24a914e7e167a38397b2ab40aec575eee332b0e739c'
+ '5e960b4dab495437082d0838a40a8cae9b67d1cef1ffd57da960afaa2bfd3719'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
@@ -62,7 +62,7 @@ prepare() {
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-fix-vmaf-model-path.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
- #patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-svt-av1-${_svt_av1_ver}.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-svt-av1-${_svt_av1_ver}.patch"
}
pkgver() {