summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel Chin2023-11-28 12:53:47 +0800
committerNathaniel Chin2023-11-28 12:53:47 +0800
commitc4e2ed5aaa7b7ceea16c20c1e84c0bc37d9e529c (patch)
tree6a8e0e8db79b011abc4d0b3863fe4d738703cc99
parent6d2a3b571a3c17ee685a582d184951bf216b2ee5 (diff)
downloadaur-c4e2ed5aaa7b7ceea16c20c1e84c0bc37d9e529c.tar.gz
Update from upstream
-rw-r--r--.SRCINFO10
-rw-r--r--005-ffmpeg-add-svt-hevc-g6cca5b9.patch97
-rw-r--r--PKGBUILD24
3 files changed, 121 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a02afccc0c1c..660c3ab8db0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-amd-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)
- pkgver = 6.2.r112766.g575efc0406
+ pkgver = 6.2.r112865.g3bca828d39
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -107,16 +107,20 @@ pkgbase = ffmpeg-amd-full-git
depends = zimg
depends = zlib
depends = zvbi
+ depends = libaribcaption
depends = chromaprint-fftw
depends = davs2
depends = flite1
- depends = libklvanc-git
+ depends = libklvanc
depends = librist
+ depends = opencv2
depends = shine
depends = uavs3d-git
depends = vo-amrwbenc
depends = xavs
depends = xavs2
+ depends = xevd
+ depends = xeve
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
@@ -130,12 +134,14 @@ pkgbase = ffmpeg-amd-full-git
provides = ffmpeg-git
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git
+ source = 005-ffmpeg-add-svt-hevc-g6cca5b9.patch
source = 010-ffmpeg-add-svt-hevc-g6cca5b9.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/6cca5b932623d3a1953b165ae6b093ca1325ac44/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-vp9-g43ef8e5.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/43ef8e5e96932421858762392adbbab57c84aebf/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = LICENSE
sha256sums = SKIP
+ sha256sums = 7d7a53ee6826acf44d6729d337f30fa8ebb85011a2793261575b7bad230835cb
sha256sums = e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a
sha256sums = 0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c
sha256sums = 7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1
diff --git a/005-ffmpeg-add-svt-hevc-g6cca5b9.patch b/005-ffmpeg-add-svt-hevc-g6cca5b9.patch
new file mode 100644
index 000000000000..19e1d33aba5d
--- /dev/null
+++ b/005-ffmpeg-add-svt-hevc-g6cca5b9.patch
@@ -0,0 +1,97 @@
+--- a/010-ffmpeg-add-svt-hevc-g6cca5b9.patch
++++ b/010-ffmpeg-add-svt-hevc-g6cca5b9.patch
+@@ -1,36 +1,14 @@
+-From 673e67dfff221da589e28216927fe5efd5b40586 Mon Sep 17 00:00:00 2001
+-From: Jing Sun <jing.a.sun@intel.com>
+-Date: Wed, 21 Nov 2018 11:33:04 +0800
+-Subject: [PATCH] lavc/svt_hevc: add libsvt hevc encoder wrapper
+-
+-Signed-off-by: Zhengxu Huang <zhengxu.huang@intel.com>
+-Signed-off-by: Hassene Tmar <hassene.tmar@intel.com>
+-Signed-off-by: Jun Zhao <jun.zhao@intel.com>
+-Signed-off-by: Jing Sun <jing.a.sun@intel.com>
+-Signed-off-by: Austin Hu <austin.hu@intel.com>
+-Signed-off-by: Christopher Degawa <ccom@randomderp.com>
+-Signed-off-by: Guo Jiansheng <jiansheng.guo@intel.com>
+----
+- configure | 4 +
+- libavcodec/Makefile | 1 +
+- libavcodec/allcodecs.c | 1 +
+- libavcodec/libsvt_hevc.c | 585 +++++++++++++++++++++++++++++++++++++++
+- 4 files changed, 591 insertions(+)
+- create mode 100644 libavcodec/libsvt_hevc.c
+-
+-diff --git a/configure b/configure
+-index c726076da1..c00fcd0294 100755
+ --- a/configure
+ +++ b/configure
+-@@ -291,6 +291,7 @@ External library support:
++@@ -289,6 +289,7 @@ External library support:
+ --enable-libwebp enable WebP encoding via libwebp [no]
+ --enable-libx264 enable H.264 encoding via x264 [no]
+ --enable-libx265 enable HEVC encoding via x265 [no]
+ + --enable-libsvthevc enable HEVC encoding via svt [no]
++ --enable-libxeve enable EVC encoding via libxeve [no]
++ --enable-libxevd enable EVC decoding via libxevd [no]
+ --enable-libxavs enable AVS encoding via xavs [no]
+- --enable-libxavs2 enable AVS2 encoding via xavs2 [no]
+- --enable-libxcb enable X11 grabbing using XCB [autodetect]
+-@@ -1852,6 +1853,7 @@ EXTERNAL_LIBRARY_LIST="
++@@ -1893,6 +1894,7 @@ EXTERNAL_LIBRARY_LIST="
+ libsrt
+ libssh
+ libsvtav1
+@@ -38,7 +16,7 @@ index c726076da1..c00fcd0294 100755
+ libtensorflow
+ libtesseract
+ libtheora
+-@@ -3404,6 +3406,7 @@ vapoursynth_demuxer_deps="vapoursynth"
++@@ -3470,6 +3472,7 @@ vapoursynth_demuxer_deps="vapoursynth"
+ videotoolbox_suggest="coreservices"
+ videotoolbox_deps="corefoundation coremedia corevideo"
+ videotoolbox_encoder_deps="videotoolbox VTCompressionSessionPrepareToEncodeFrames"
+@@ -46,7 +24,7 @@ index c726076da1..c00fcd0294 100755
+
+ # demuxers / muxers
+ ac3_demuxer_select="ac3_parser"
+-@@ -6678,6 +6681,7 @@ enabled libssh && require_pkg_config libssh libssh libssh/sftp.h sftp
++@@ -6828,6 +6831,7 @@ enabled libssh && require_pkg_config libssh "libssh >= 0.6.0" libssh/
+ enabled libspeex && require_pkg_config libspeex speex speex/speex.h speex_decoder_init
+ enabled libsrt && require_pkg_config libsrt "srt >= 1.3.0" srt/srt.h srt_socket
+ enabled libsvtav1 && require_pkg_config libsvtav1 "SvtAv1Enc >= 0.9.0" EbSvtAv1Enc.h svt_av1_enc_init_handle
+@@ -54,30 +32,26 @@ index c726076da1..c00fcd0294 100755
+ enabled libtensorflow && require libtensorflow tensorflow/c/c_api.h TF_Version -ltensorflow
+ enabled libtesseract && require_pkg_config libtesseract tesseract tesseract/capi.h TessBaseAPICreate
+ enabled libtheora && require libtheora theora/theoraenc.h th_info_init -ltheoraenc -ltheoradec -logg
+-diff --git a/libavcodec/Makefile b/libavcodec/Makefile
+-index 1fb963f820..77c9926ea6 100644
+ --- a/libavcodec/Makefile
+ +++ b/libavcodec/Makefile
+-@@ -1126,6 +1126,7 @@ OBJS-$(CONFIG_LIBWEBP_ANIM_ENCODER) += libwebpenc_common.o libwebpenc_anim
++@@ -1147,6 +1147,7 @@ OBJS-$(CONFIG_LIBWEBP_ANIM_ENCODER) += libwebpenc_common.o libwebpenc_anim
+ OBJS-$(CONFIG_LIBX262_ENCODER) += libx264.o
+ OBJS-$(CONFIG_LIBX264_ENCODER) += libx264.o
+ OBJS-$(CONFIG_LIBX265_ENCODER) += libx265.o
+ +OBJS-$(CONFIG_LIBSVT_HEVC_ENCODER) += libsvt_hevc.o
+ OBJS-$(CONFIG_LIBXAVS_ENCODER) += libxavs.o
+ OBJS-$(CONFIG_LIBXAVS2_ENCODER) += libxavs2.o
+- OBJS-$(CONFIG_LIBXVID_ENCODER) += libxvid.o
+-diff --git a/libavcodec/allcodecs.c b/libavcodec/allcodecs.c
+-index ff82423a88..57f085415c 100644
++ OBJS-$(CONFIG_LIBXEVD_DECODER) += libxevd.o
+ --- a/libavcodec/allcodecs.c
+ +++ b/libavcodec/allcodecs.c
+-@@ -812,6 +812,7 @@ extern LIBX264_CONST FFCodec ff_libx264_encoder;
++@@ -821,6 +821,7 @@ extern LIBX264_CONST FFCodec ff_libx264_encoder;
+ #endif
+ extern const FFCodec ff_libx264rgb_encoder;
+ extern FFCodec ff_libx265_encoder;
+ +extern FFCodec ff_libsvt_hevc_encoder;
++ extern const FFCodec ff_libxeve_encoder;
++ extern const FFCodec ff_libxevd_decoder;
+ extern const FFCodec ff_libxavs_encoder;
+- extern const FFCodec ff_libxavs2_encoder;
+- extern const FFCodec ff_libxvid_encoder;
+ diff --git a/libavcodec/libsvt_hevc.c b/libavcodec/libsvt_hevc.c
+ new file mode 100644
+ index 0000000000..739144ca0c
diff --git a/PKGBUILD b/PKGBUILD
index 26689bb1d136..93c175f17af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
-pkgver=6.2.r112766.g575efc0406
+pkgver=6.2.r112865.g3bca828d39
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('x86_64')
@@ -24,8 +24,8 @@ depends=('alsa-lib' 'aom' 'aribb24' 'avisynthplus' 'bzip2' 'celt' 'codec2'
'sndio' 'speex' 'spirv-tools' 'srt' 'svt-av1' 'svt-hevc' 'svt-vp9' 'tesseract'
'twolame' 'v4l-utils' 'vapoursynth' 'vid.stab' 'vmaf' 'vulkan-icd-loader' 'x264'
'x265' 'xvidcore' 'xz' 'zeromq' 'zimg' 'zlib' 'zvbi'
- 'chromaprint-fftw' 'davs2' 'flite1' 'libklvanc-git' 'librist'
- 'shine' 'uavs3d-git' 'vo-amrwbenc' 'xavs' 'xavs2')
+ 'libaribcaption' 'chromaprint-fftw' 'davs2' 'flite1' 'libklvanc' 'librist'
+ 'opencv2' 'shine' 'uavs3d-git' 'vo-amrwbenc' 'xavs' 'xavs2' 'xevd' 'xeve')
makedepends=('git' 'clang' 'amf-headers' 'nasm' 'opencl-headers'
'vulkan-headers' 'decklink-sdk')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
@@ -34,14 +34,16 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
conflicts=('ffmpeg')
_svt_hevc_ver='6cca5b932623d3a1953b165ae6b093ca1325ac44'
_svt_vp9_ver='43ef8e5e96932421858762392adbbab57c84aebf'
-source=('git+https://git.ffmpeg.org/ffmpeg.git'
+source=("git+https://git.ffmpeg.org/ffmpeg.git"
+ "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
#"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
- '040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
- '060-ffmpeg-fix-segfault-with-avisynthplus.patch'
- 'LICENSE')
+ "040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
+ "060-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ "LICENSE")
sha256sums=('SKIP'
+ '7d7a53ee6826acf44d6729d337f30fa8ebb85011a2793261575b7bad230835cb'
'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
#'a164ebdc4d281352bf7ad1b179aae4aeb33f1191c444bed96cb8ab333c046f81'
'0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
@@ -51,6 +53,9 @@ sha256sums=('SKIP'
prepare() {
rm -f ffmpeg/libavcodec/libsvt_{hevc,vp9}.c
+ cp --remove-destination "$(readlink "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch")" \
+ "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
+ patch -Np1 -i "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
#patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
@@ -98,6 +103,7 @@ build() {
--enable-lcms2 \
--enable-libaom \
--enable-libaribb24 \
+ --enable-libaribcaption \
--enable-libass \
--enable-libbluray \
--enable-libbs2b \
@@ -128,7 +134,7 @@ build() {
--enable-libmp3lame \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
- --disable-libopencv \
+ --enable-libopencv \
--enable-libopenh264 \
--enable-libopenjpeg \
--enable-libopenmpt \
@@ -166,6 +172,8 @@ build() {
--enable-libwebp \
--enable-libx264 \
--enable-libx265 \
+ --enable-libxevd \
+ --enable-libxeve \
--enable-libxavs \
--enable-libxavs2 \
--enable-libxcb \