summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-03-21 01:34:29 -0300
committerDaniel Bermond2017-03-21 01:34:29 -0300
commit3e2ed8fa639f069e252360bf4d5844d85f1a2559 (patch)
tree64165ce68c21fc92dae196e688658e174e5a038d
parent0f6dd32413ccd9cd6151eff9dbce74f415b9a00e (diff)
downloadaur-3e2ed8fa639f069e252360bf4d5844d85f1a2559.tar.gz
Removed jni and mediacodec (support in ffmpeg is for android only)
configure script allows jni only if, among other things, the 'target_os' is android. There was a recent upstream git commit that causes configure script to fail with --enable-jni if the requirements are not met. And mediacodec requires jni on configure script, so it fails too. At least, currently they seem to run only on android. mediacodec was already expected to have this behavior. On 'configure' file, notice these (non-consecutive) lines: enabled jni && { [ $target_os = "android" ] ... enabled mediacodec && { enabled jni ... Reference: http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=d839c4716cdcecf3b46d05d0aec8f460cdb4ce23
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD31
2 files changed, 11 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 341c8a22a18c..530f86aee534 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 15 23:11:35 UTC 2017
+# Tue Mar 21 03:57:37 UTC 2017
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (Git version with all possible libs)
- pkgver = N.83945.gd96f6df3a6
+ pkgver = N.84293.g5e3a418b60
pkgrel = 1
url = http://www.ffmpeg.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index aaadebd8b3e6..83f0267edc7a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.83945.gd96f6df3a6
+pkgver=N.84293.g5e3a418b60
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -52,40 +52,29 @@ sha256sums=('SKIP'
pkgver() {
cd "${srcdir}/${pkgname}"
- # Git, tags available
-
- # Method showing version based on FFmpeg Git versioning system
+ # use FFmpeg internal git versioning
printf "%s" "$(git describe --tags --match N | tr '-' '.')"
}
build() {
cd "${srcdir}/${pkgname}"
- # Add x86_64 depends and optdepends to the build if architecture is x86_64
- if [ "$CARCH" = "x86_64" ]; then
+ # set x86_64 specific options
+ if [ "$CARCH" = "x86_64" ]
+ then
_cuda="--enable-cuda"
- _cudainc="-I/opt/cuda/include"
- _cudalib="-L/opt/cuda/lib64"
_cuvid="--enable-cuvid"
_libnpp="--enable-libnpp"
- _intelsdklib="-Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
- else
- _cuda=""
- _cudainc=""
- _cudalib=""
- _cuvid=""
- _libnpp=""
- _intelsdklib=""
+ _cflags="--extra-cflags=-I/opt/cuda/include"
+ _ldflags="--extra-ldflags=-L/opt/cuda/lib64 -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
fi
msg2 "Running ffmpeg configure script. Please wait..."
./configure \
--prefix=/usr \
- --extra-cflags="-I/usr/lib/jvm/$(archlinux-java get)/include \
- -I/usr/lib/jvm/$(archlinux-java get)/include/linux \
- ${_cudainc}" \
- --extra-ldflags="${_cudalib} ${_intelsdklib}" \
+ $_cflags \
+ "$_ldflags" \
\
--enable-rpath \
--enable-gpl \
@@ -104,7 +93,6 @@ build() {
--enable-gmp \
--enable-gnutls \
--enable-iconv \
- --enable-jni \
--enable-ladspa \
--enable-libass \
--enable-libbluray \
@@ -166,7 +154,6 @@ build() {
--enable-libzvbi \
--enable-lzma \
--enable-decklink \
- --enable-mediacodec \
--enable-netcdf \
--enable-openal \
--enable-opencl \