summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2016-12-16 21:38:25 -0200
committerDaniel Bermond2016-12-16 21:38:25 -0200
commit4bbf8aa31abc4ff2a4cf32ad67b77581a1efb926 (patch)
treee9c2dddbebe70adfda7b43ba2d168a99f8d1d8e0
parent10c93380e9b14be2b567681083f82430f6964409 (diff)
downloadaur-4bbf8aa31abc4ff2a4cf32ad67b77581a1efb926.tar.gz
flite dependency changes
Changed flite-fpic to flite1. flite-fpic uses static libraries and flite1 uses shared ones, so flite1 is preferred. It seems that flite is needed only at building time since it's not linked in any binaries and namcap does not complain about it. flite functionality in ffmpeg and ffplay works as expected when deleting flite1 after installing ffmpeg-full-git. Also, the flite detection code on prepare() seems to be not needed since everything works without it. Note: flite (2.x) that is present at [community] repository is not supported by ffmpeg.
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD19
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce3015df4f1c..4d0002543adb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 11 16:36:39 UTC 2016
+# Fri Dec 16 23:38:06 UTC 2016
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (Git version with all possible libs)
- pkgver = N.82833.gedb4f5d
+ pkgver = N.82871.ga5cf600ccb
pkgrel = 1
url = http://www.ffmpeg.org/
arch = i686
@@ -12,6 +12,7 @@ pkgbase = ffmpeg-full-git
makedepends = git
makedepends = yasm
makedepends = opencl-headers
+ makedepends = flite1
makedepends = blackmagic-decklink-sdk
depends = alsa-lib
depends = zlib
@@ -34,7 +35,6 @@ pkgbase = ffmpeg-full-git
depends = libcdio-paranoia
depends = libdc1394
depends = libfdk-aac
- depends = flite-fpic
depends = freetype2
depends = fribidi
depends = libgme
diff --git a/PKGBUILD b/PKGBUILD
index b531ffd6fd96..460476690fcc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
# AUR dependencies
# ----------------
# libilbc kvazaar chromaprint-fftw libbs2b openh264 shine vo-amrwbenc
-# nut-multimedia-git xavs flite-fpic libmfx-git libopenmpt-svn zimg-git
+# nut-multimedia-git xavs libmfx-git libopenmpt-svn zimg-git
# AUR make dependencies
# ---------------------
-# blackmagic-decklink-sdk
+# flite1 blackmagic-decklink-sdk
# AUR optional dependency
# -----------------------
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.82833.gedb4f5d
+pkgver=N.82871.ga5cf600ccb
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -23,8 +23,8 @@ license=('GPL3' 'custom:UNREDISTRIBUTABLE')
depends=(
'alsa-lib' 'zlib' 'bzip2' 'xz' 'libpng' 'chromaprint-fftw' 'fontconfig' 'frei0r-plugins'
'libgcrypt' 'gmp' 'gnutls' 'glibc' 'ladspa' 'libass' 'libbluray' 'libbs2b' 'libcaca' 'celt'
- 'libcdio-paranoia' 'libdc1394' 'libfdk-aac' 'flite-fpic' 'freetype2' 'fribidi' 'libgme'
- 'gsm' 'libiec61883' 'libilbc' 'kvazaar' 'libmodplug' 'lame' 'netcdf' 'nut-multimedia-git'
+ 'libcdio-paranoia' 'libdc1394' 'libfdk-aac' 'freetype2' 'fribidi' 'libgme' 'gsm'
+ 'libiec61883' 'libilbc' 'kvazaar' 'libmodplug' 'lame' 'netcdf' 'nut-multimedia-git'
'opencore-amr' 'opencv' 'openh264' 'openjpeg2' 'libopenmpt-svn' 'opus' 'pulseaudio'
'rubberband' 'rtmpdump' 'schroedinger' 'shine' 'smbclient' 'libavc1394' 'snappy' 'libsoxr'
'speex' 'libssh' 'tesseract' 'libtheora' 'twolame' 'v4l-utils' 'vid.stab' 'vo-amrwbenc'
@@ -35,7 +35,7 @@ depends=(
)
depends_x86_64=('cuda')
optdepends_x86_64=('intel-media-sdk: for Intel QSV support (experimental)')
-makedepends=('git' 'yasm' 'opencl-headers' 'blackmagic-decklink-sdk')
+makedepends=('git' 'yasm' 'opencl-headers' 'flite1' 'blackmagic-decklink-sdk')
provides=(
'ffmpeg' 'qt-faststart' 'ffmpeg-git' 'ffmpeg-full' 'ffmpeg-full-extra' 'ffmpeg-full-nvenc'
'ffmpeg-libfdk_aac' 'libavutil.so' 'libavcodec.so' 'libavformat.so' 'libavdevice.so'
@@ -58,13 +58,6 @@ pkgver() {
printf "%s" "$(git describe --tags --match N | tr '-' '.')"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
-
- # Add the ALSA library to the Flite LDFLAGS variable and enables the discovery of Flite
- sed -i 's/-lflite"/-lflite -lasound"/' configure
-}
-
build() {
cd "${srcdir}/${pkgname}"