summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-04 13:42:04 +0000
committerDaniel Bermond2020-10-04 13:42:04 +0000
commit4e1d217430b050e25d7ad526b5de9d5bff2ed6ce (patch)
treec3ab2e49d3baa25cebc6d57ec9bfc883b19924bd
parent526131e5606eaefe99e4998d048d75d3f0b0c07d (diff)
downloadaur-4e1d217430b050e25d7ad526b5de9d5bff2ed6ce.tar.gz
Bring back smbclient support (fixed by upstream)
smbclient support was previously removed[1] due to a build failure with samba 4.9. It looks like that the recently released samba 4.13 fixed[2][3] the issue and now ffmpeg is building fine with it. References ---------- [1] https://aur.archlinux.org/cgit/aur.git/commit/?h=ffmpeg-full-git&id=861ed49ab870c6fdfb4cad8a2443b49af78f32a5 [2] https://github.com/samba-team/samba/pull/212/ [3] https://github.com/samba-team/samba/commit/1114b02a72ce0c86a5301816560d270ec47f8be3
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffc6f0f5af5e..d18fc5b39051 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 4.4.r99456.g45070eec4c
+ pkgver = 4.4.r99459.g05872c67a4
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -55,6 +55,7 @@ pkgbase = ffmpeg-full-git
depends = librsvg
depends = rubberband
depends = rtmpdump
+ depends = smbclient
depends = snappy
depends = libsoxr
depends = speex
diff --git a/PKGBUILD b/PKGBUILD
index ab0fa4d5114a..6285dd3ec2c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_svt_hevc_ver='ead6fdf7c9ff84511b42fc1658c1654b84d83e4b'
pkgname=ffmpeg-full-git
-pkgver=4.4.r99456.g45070eec4c
+pkgver=4.4.r99459.g05872c67a4
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -17,8 +17,8 @@ depends=(
'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm' 'libiec61883'
'libilbc' 'jack' 'kvazaar' 'lensfun' 'libmodplug' 'lame' 'opencore-amr'
'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c' 'rav1e' 'librsvg' 'rubberband'
- 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh' 'svt-hevc' 'svt-av1'
- 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame' 'v4l-utils'
+ 'rtmpdump' 'smbclient' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh' 'svt-hevc'
+ 'svt-av1' 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame' 'v4l-utils'
'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'libwebp' 'x264' 'x265' 'libxcb'
'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz' 'libmysofa'
'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth' 'vulkan-icd-loader'
@@ -64,13 +64,9 @@ prepare() {
}
pkgver() {
- local _version
- local _revision
- local _shorthash
- _version="$(git -C ffmpeg describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
- _revision="$(git -C ffmpeg describe --tags --match 'N' | awk -F'-' '{ print $2 }')"
- _shorthash="$(git -C ffmpeg rev-parse --short HEAD)"
- printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
+ printf '%s.r%s.g%s' "$(git -C ffmpeg describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')" \
+ "$(git -C ffmpeg describe --tags --match 'N' | awk -F'-' '{ print $2 }')" \
+ "$(git -C ffmpeg rev-parse --short HEAD)"
}
build() {
@@ -145,7 +141,7 @@ build() {
--enable-librubberband \
--enable-librtmp \
--enable-libshine \
- --disable-libsmbclient \
+ --enable-libsmbclient \
--enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \