summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-10-01 10:45:34 -0300
committerDaniel Bermond2023-10-01 10:45:34 -0300
commit96bc2e97bafb3364d1d55d748fc8d065f2528197 (patch)
treebc1d9af32eea8b268c3b51e2a4aeffcad6be2a98
parentb391f9ac63c28c4ed49387e7c0ad60f3d91f1ab5 (diff)
downloadaur-96bc2e97bafb3364d1d55d748fc8d065f2528197.tar.gz
Update ffnvcodec-headers dependency and svt patches
ffmpeg git master currently requires ffnvcodec-headers git master. This is not the first time it happens, so maybe it's better to keep it for the long run to avoid breakages in building.
-rw-r--r--.SRCINFO18
-rw-r--r--040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch4
-rw-r--r--060-ffmpeg-fix-segfault-with-avisynthplus.patch2
-rw-r--r--PKGBUILD28
4 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14a8ce7fd3dc..d2d740e15402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 6.1.r111232.g468615f204
+ pkgver = 6.1.r112250.g6f7bf64dbc
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = ffmpeg-full-git
makedepends = git
makedepends = clang
makedepends = amf-headers
- makedepends = ffnvcodec-headers
+ makedepends = ffnvcodec-headers-git
makedepends = nasm
makedepends = opencl-headers
makedepends = vulkan-headers
@@ -134,18 +134,18 @@ pkgbase = ffmpeg-full-git
provides = ffmpeg-git
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git
- source = 006-ffmpeg-add-svt-vp9-gaaa8140.patch
- source = 010-ffmpeg-add-svt-hevc-geb24a06.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/eb24a06ba4ee4948f219a3246b88439a8090bd37/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
- source = 030-ffmpeg-add-svt-vp9-gaaa8140.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
+ source = 010-ffmpeg-add-svt-hevc-g6cca5b9.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/6cca5b932623d3a1953b165ae6b093ca1325ac44/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
+ source = 020-ffmpeg-add-svt-hevc-docs-g6cca5b9.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/6cca5b932623d3a1953b165ae6b093ca1325ac44/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch
+ source = 030-ffmpeg-add-svt-vp9-g43ef8e5.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/43ef8e5e96932421858762392adbbab57c84aebf/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = LICENSE
sha256sums = SKIP
- sha256sums = b04d0707e14f43df1243a403d74cab434197ece9491d6590523a184e776496ba
sha256sums = e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a
- sha256sums = d8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee
- sha256sums = d1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9
- sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
+ sha256sums = a164ebdc4d281352bf7ad1b179aae4aeb33f1191c444bed96cb8ab333c046f81
+ sha256sums = 0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c
+ sha256sums = 9b94b90a33dc8ac9693d72c825e9c444df914428fce7cca61117146ee8f8c07b
+ sha256sums = 0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-full-git
diff --git a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
index b6eb1d7394b5..3f4605d968ab 100644
--- a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+++ b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avformat.h
+++ b/libavformat/avformat.h
-@@ -1019,6 +1019,10 @@ attribute_deprecated
+@@ -1020,6 +1020,10 @@ attribute_deprecated
int64_t av_stream_get_end_pts(const AVStream *st);
#endif
@@ -13,7 +13,7 @@
/**
--- a/libavformat/utils.c
+++ b/libavformat/utils.c
-@@ -55,6 +55,13 @@ int ff_unlock_avformat(void)
+@@ -56,6 +56,13 @@ int ff_unlock_avformat(void)
return ff_mutex_unlock(&avformat_mutex) ? -1 : 0;
}
diff --git a/060-ffmpeg-fix-segfault-with-avisynthplus.patch b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
index dd58e840eec1..9e2ddb399c9e 100644
--- a/060-ffmpeg-fix-segfault-with-avisynthplus.patch
+++ b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avisynth.c
+++ b/libavformat/avisynth.c
-@@ -141,7 +141,7 @@ static av_cold void avisynth_atexit_handler(void);
+@@ -142,7 +142,7 @@ static av_cold void avisynth_atexit_handler(void);
static av_cold int avisynth_load_library(void)
{
diff --git a/PKGBUILD b/PKGBUILD
index 1c92748de301..0984709adbb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=6.1.r111232.g468615f204
+pkgver=6.1.r112250.g6f7bf64dbc
pkgrel=1
-_svt_hevc_ver='eb24a06ba4ee4948f219a3246b88439a8090bd37'
-_svt_vp9_ver='aaa8140c8cdf6c073eaa6aaa5d003d1535fd0059'
+_svt_hevc_ver='6cca5b932623d3a1953b165ae6b093ca1325ac44'
+_svt_vp9_ver='43ef8e5e96932421858762392adbbab57c84aebf'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -119,35 +119,35 @@ depends=(
'xavs'
'xavs2'
)
-makedepends=('git' 'clang' 'amf-headers' 'ffnvcodec-headers' 'nasm' 'opencl-headers'
+makedepends=('git' 'clang' 'amf-headers' 'ffnvcodec-headers-git' 'nasm' 'opencl-headers'
'vulkan-headers' 'decklink-sdk')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswscale.so' 'libswresample.so'
'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
- "006-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
+ #"006-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
- #"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
+ "020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'LICENSE')
sha256sums=('SKIP'
- 'b04d0707e14f43df1243a403d74cab434197ece9491d6590523a184e776496ba'
'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
- 'd8b91ea5f07d0208cbe0290567083808708014a1953fda322d13cb619349c9ee'
- 'd1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9'
- 'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
+ 'a164ebdc4d281352bf7ad1b179aae4aeb33f1191c444bed96cb8ab333c046f81'
+ '0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
+ '9b94b90a33dc8ac9693d72c825e9c444df914428fce7cca61117146ee8f8c07b'
+ '0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
rm -f ffmpeg/libavcodec/libsvt_{hevc,vp9}.c
- cp --remove-destination "$(readlink "030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch")" \
- "030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
- patch -Np1 -i "006-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
+ #cp --remove-destination "$(readlink "030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch")" \
+ # "030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
+ #patch -Np1 -i "006-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
- #patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"