summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-02 10:59:58 -0300
committerDaniel Bermond2022-11-02 10:59:58 -0300
commitb32253ce4c88833bb3358c5fdb689e00975c2d2e (patch)
tree1a3dda880fdace1cc8fd75cfda3a3ae3f6c31f54
parent4a77bd4f9df8bec81b5f4c1e22d2455cd4957ba9 (diff)
downloadaur-b32253ce4c88833bb3358c5fdb689e00975c2d2e.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO8
-rw-r--r--005-ffmpeg-add-svt-hevc-gb62f72e.patch20
-rw-r--r--040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch4
-rw-r--r--060-ffmpeg-fix-segfault-with-avisynthplus.patch2
-rw-r--r--PKGBUILD11
5 files changed, 36 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd97a3bc7879..7056bab2d24e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 5.2.r108314.gec8be8a913
+ pkgver = 5.2.r108915.g5661c8715c
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -134,16 +134,18 @@ pkgbase = ffmpeg-full-git
provides = ffmpeg-git
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git
+ source = 005-ffmpeg-add-svt-hevc-gb62f72e.patch
source = 010-ffmpeg-add-svt-hevc-gb62f72e.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/b62f72e752243cee4104cfb41dc7ee409d3ac3e9/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-vp9-gd9ef3cc.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/d9ef3cc13159143b9afc776c04f67cdfa6284046/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = LICENSE
sha256sums = SKIP
+ sha256sums = 52c7f9299b9cb3ad47ef580a7732c5a2c6367d406284ad4c5acd430d718b0e5c
sha256sums = 4da3826aa370572273ef9fb4c0bf2c93a840595b07a671a0412ad0dc9ed8d689
sha256sums = e310eedb3dc88c8ad6ffcd6cb6bde1f593ded330ea99b0356724c9d22bcfde4c
- sha256sums = 2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c
- sha256sums = b1d68f626168f2409a4b0987acf5b208e7ced2ddab49b11990a10f458d377e9a
+ sha256sums = 3f4d677da3efdc3d2a1cbd36257d626b7e4c05d685ed82bd1a7e2eb7e3ac6ee4
+ sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-full-git
diff --git a/005-ffmpeg-add-svt-hevc-gb62f72e.patch b/005-ffmpeg-add-svt-hevc-gb62f72e.patch
new file mode 100644
index 000000000000..382979931105
--- /dev/null
+++ b/005-ffmpeg-add-svt-hevc-gb62f72e.patch
@@ -0,0 +1,20 @@
+--- a/010-ffmpeg-add-svt-hevc-gb62f72e.patch
++++ b/010-ffmpeg-add-svt-hevc-gb62f72e.patch
+@@ -46,14 +46,14 @@ index 5a167613a4..9897fcaf4d 100755
+ libxavs_encoder_deps="libxavs"
+ libxavs2_encoder_deps="libxavs2"
+ libxvid_encoder_deps="libxvid"
+-@@ -6686,6 +6689,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
++@@ -6757,6 +6757,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
+ check_lib mmal interface/mmal/mmal.h mmal_port_connect -lmmal_core -lmmal_util -lmmal_vc_client -lbcm_host; } ||
+ die "ERROR: mmal not found" &&
+ check_func_headers interface/mmal/mmal.h "MMAL_PARAMETER_VIDEO_MAX_NUM_CALLBACKS"; }
+ +enabled libsvthevc && require_pkg_config libsvthevc SvtHevcEnc EbApi.h EbInitHandle
+- enabled openal && { { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
++ enabled openal && { check_pkg_config openal "openal >= 1.1" "AL/al.h" alGetError ||
++ { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
+ check_lib openal 'AL/al.h' alGetError "${al_extralibs}" && break; done } ||
+- die "ERROR: openal not found"; } &&
+ diff --git a/libavcodec/Makefile b/libavcodec/Makefile
+ index 3b8f7b5e01..bfd6535345 100644
+ --- a/libavcodec/Makefile
diff --git a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
index 83fd707e65d0..a556c9771353 100644
--- a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+++ b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
@@ -1,8 +1,8 @@
--- a/libavformat/avformat.h
+++ b/libavformat/avformat.h
-@@ -1128,6 +1128,10 @@ struct AVCodecParserContext *av_stream_get_parser(const AVStream *s);
- */
+@@ -1131,6 +1131,10 @@ attribute_deprecated
int64_t av_stream_get_end_pts(const AVStream *st);
+ #endif
+// Chromium: We use the internal field first_dts vvv
+int64_t av_stream_get_first_dts(const AVStream *st);
diff --git a/060-ffmpeg-fix-segfault-with-avisynthplus.patch b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
index 2404112a4236..dd58e840eec1 100644
--- a/060-ffmpeg-fix-segfault-with-avisynthplus.patch
+++ b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avisynth.c
+++ b/libavformat/avisynth.c
-@@ -127,7 +127,7 @@ static av_cold void avisynth_atexit_handler(void);
+@@ -141,7 +141,7 @@ static av_cold void avisynth_atexit_handler(void);
static av_cold int avisynth_load_library(void)
{
diff --git a/PKGBUILD b/PKGBUILD
index 3f79e74afc0d..65979a558925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=5.2.r108314.gec8be8a913
+pkgver=5.2.r108915.g5661c8715c
pkgrel=1
_svt_hevc_ver='b62f72e752243cee4104cfb41dc7ee409d3ac3e9'
_svt_vp9_ver='d9ef3cc13159143b9afc776c04f67cdfa6284046'
@@ -126,6 +126,7 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
+ "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
#"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
@@ -133,14 +134,18 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'LICENSE')
sha256sums=('SKIP'
+ '52c7f9299b9cb3ad47ef580a7732c5a2c6367d406284ad4c5acd430d718b0e5c'
'4da3826aa370572273ef9fb4c0bf2c93a840595b07a671a0412ad0dc9ed8d689'
'e310eedb3dc88c8ad6ffcd6cb6bde1f593ded330ea99b0356724c9d22bcfde4c'
- '2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c'
- 'b1d68f626168f2409a4b0987acf5b208e7ced2ddab49b11990a10f458d377e9a'
+ '3f4d677da3efdc3d2a1cbd36257d626b7e4c05d685ed82bd1a7e2eb7e3ac6ee4'
+ 'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
rm -f ffmpeg/libavcodec/libsvt_{hevc,vp9}.c
+ cp --remove-destination "$(readlink "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch")" \
+ "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
+ patch -Np1 -i "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
#patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"