summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-05-05 11:19:37 -0300
committerDaniel Bermond2024-05-05 11:19:37 -0300
commitb3a4e9720f1846077b7e33bd1e69e2ef0695d747 (patch)
tree34009d1d4dfec128185d0cc0e2d5ea14571a7985
parent56516d7653dc27078117f2b9d0f0a5a0bfeb1de1 (diff)
downloadaur-b3a4e9720f1846077b7e33bd1e69e2ef0695d747.tar.gz
Use environment variables to set the needed compiler flags
This will prevent the compiler flags '-I' and '-L' to be shown in the ffmpeg version string. This is likely an unneeded information to be present there.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6983ac52ae1..57168d7501c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
pkgver = 7.1.r115045.g86e418ffd7
- pkgrel = 1
+ pkgrel = 2
url = https://www.ffmpeg.org/
arch = x86_64
license = LicenseRef-nonfree-and-unredistributable
diff --git a/PKGBUILD b/PKGBUILD
index 4ce5009810ca..ab6529f2cc4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ffmpeg-full-git
pkgver=7.1.r115045.g86e418ffd7
-pkgrel=1
+pkgrel=2
_svt_hevc_ver='ed80959ebb5586aa7763c91a397d44be1798587c'
_svt_vp9_ver='3b9a3fa43da4cc5fe60c7d22afe2be15341392ea'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
@@ -182,12 +182,12 @@ build() {
cd ffmpeg
printf '%s\n' ' -> Running ffmpeg configure script...'
+ export CFLAGS+=' -I/opt/cuda/include -I/usr/include/tensorflow'
+ export LDFLAGS+=' -L/opt/cuda/lib64'
export PKG_CONFIG_PATH="/opt/intel/openvino/runtime/lib/intel64/pkgconfig${PKG_CONFIG_PATH:+":${PKG_CONFIG_PATH}"}"
./configure \
--prefix='/usr' \
- --extra-cflags='-I/opt/cuda/include -I/usr/include/tensorflow' \
- --extra-ldflags='-L/opt/cuda/lib64' \
--enable-lto \
\
--disable-rpath \