summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-05-05 11:22:05 -0300
committerDaniel Bermond2024-05-05 11:22:05 -0300
commitb5fbc150ad2f97a7f48613745f9ec3b58eb16505 (patch)
tree05fadc0020f13f94fdfb1a10496f14ee375e7bca
parentb3a4e9720f1846077b7e33bd1e69e2ef0695d747 (diff)
downloadaur-b5fbc150ad2f97a7f48613745f9ec3b58eb16505.tar.gz
Disable tensorflow due to upstream problem
We have just added tensorflow again, as the repository package was fixed, allowing to properly use it here again. Unfortunately, there is a tensorflow upstream issue[1] that prevents applications to startup when they are linked to both ffmpeg and protobuf. We better remove tensorflow again to not break client applications, until this is fixed by upstream. References ---------- [1] https://github.com/tensorflow/tensorflow/issues/59081#issuecomment-2093988476
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57168d7501c5..a100ceb49eae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 7.1.r115045.g86e418ffd7
- pkgrel = 2
+ pkgver = 7.1.r115075.gf8a613d6a8
+ pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
license = LicenseRef-nonfree-and-unredistributable
@@ -104,7 +104,6 @@ pkgbase = ffmpeg-full-git
depends = svt-av1
depends = svt-hevc
depends = svt-vp9
- depends = tensorflow
depends = tesseract
depends = twolame
depends = v4l-utils
diff --git a/PKGBUILD b/PKGBUILD
index ab6529f2cc4f..4b33e296fffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=7.1.r115045.g86e418ffd7
-pkgrel=2
+pkgver=7.1.r115075.gf8a613d6a8
+pkgrel=1
_svt_hevc_ver='ed80959ebb5586aa7763c91a397d44be1798587c'
_svt_vp9_ver='3b9a3fa43da4cc5fe60c7d22afe2be15341392ea'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
@@ -101,7 +101,6 @@ depends=(
'svt-av1'
'svt-hevc'
'svt-vp9'
- 'tensorflow'
'tesseract'
'twolame'
'v4l-utils'
@@ -182,7 +181,7 @@ build() {
cd ffmpeg
printf '%s\n' ' -> Running ffmpeg configure script...'
- export CFLAGS+=' -I/opt/cuda/include -I/usr/include/tensorflow'
+ export CFLAGS+=' -I/opt/cuda/include'
export LDFLAGS+=' -L/opt/cuda/lib64'
export PKG_CONFIG_PATH="/opt/intel/openvino/runtime/lib/intel64/pkgconfig${PKG_CONFIG_PATH:+":${PKG_CONFIG_PATH}"}"
@@ -271,7 +270,7 @@ build() {
--enable-libsvtav1 \
--enable-libsvthevc \
--enable-libsvtvp9 \
- --enable-libtensorflow \
+ --disable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \
--disable-libtls \