summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-31 18:42:29 -0300
committerDaniel Bermond2017-05-31 18:42:29 -0300
commitb9b807373f6da7dc4e7571f945633f279a0792fa (patch)
tree4ac8bb35260181e332fd4905225b91ee81436f86
parent7cee101802c4c04e58e394ce7c3fc7d1573b54ad (diff)
downloadaur-b9b807373f6da7dc4e7571f945633f279a0792fa.tar.gz
cuda_sdk: fix build in systems with nvidia-{340,304}xx-utils
Note that both nvidia-340xx-utils and nvidia-304xx-utils provides nvidia-utils.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32796a71d25b..bef0bf6d9563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed May 31 03:14:59 UTC 2017
+# Wed May 31 21:39:15 UTC 2017
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (Git version with all possible libs)
pkgver = N.86313.g87bddba43b
- pkgrel = 2
+ pkgrel = 3
url = http://www.ffmpeg.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b02c38855b15..d0e652456c2a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ffmpeg-full-git
pkgver=N.86313.g87bddba43b
-pkgrel=2
+pkgrel=3
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
url="http://www.ffmpeg.org/"
@@ -66,7 +66,16 @@ build() {
_cuvid="--enable-cuvid"
_libnpp="--enable-libnpp"
_cflags="--extra-cflags=-I/opt/cuda/include"
- _ldflags="--extra-ldflags=-L/opt/cuda/lib64 -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
+
+ # '-L/usr/lib/nvidia' (for cuda_sdk) needs to be enabled only on
+ # systems with nvidia-340xx-utils or nvidia-304xx-utils
+ if pacman -Qqs '^nvidia-340xx-utils$' | grep -q '^nvidia-340xx-utils$' ||
+ pacman -Qqs '^nvidia-304xx-utils$' | grep -q '^nvidia-304xx-utils$'
+ then
+ _nvidia_340xx_ldflags="-L/usr/lib/nvidia"
+ fi
+ _ldflags="--extra-ldflags=-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
+ _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
fi
msg2 "Running ffmpeg configure script. Please wait..."