summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-13 08:54:00 -0300
committerDaniel Bermond2022-11-13 08:54:00 -0300
commitbc964fd1f3802c966dc672b195ba510a208792b7 (patch)
tree53302b606b8968ecf72c6e5cd8ab762d7db157d4
parentb32253ce4c88833bb3358c5fdb689e00975c2d2e (diff)
downloadaur-bc964fd1f3802c966dc672b195ba510a208792b7.tar.gz
Fix svt-hevc. Enable av1_nvenc with ffnvcodec-headers-git.
References ---------- https://git.videolan.org/?p=ffmpeg.git;a=commit;h=5c288a44ad16087c3d3a7563490cb634790e751f
-rw-r--r--.SRCINFO12
-rw-r--r--005-ffmpeg-add-svt-hevc-g7771d7c.patch21
-rw-r--r--005-ffmpeg-add-svt-hevc-gb62f72e.patch20
-rw-r--r--PKGBUILD10
4 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7056bab2d24e..4d72c1fe44d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 5.2.r108915.g5661c8715c
+ pkgver = 5.2.r109078.g2d25f33a7e
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = ffmpeg-full-git
makedepends = git
makedepends = clang
makedepends = amf-headers
- makedepends = ffnvcodec-headers
+ makedepends = ffnvcodec-headers-git
makedepends = nasm
makedepends = opencl-headers
makedepends = vulkan-headers
@@ -134,15 +134,15 @@ pkgbase = ffmpeg-full-git
provides = ffmpeg-git
conflicts = ffmpeg
source = git+https://git.ffmpeg.org/ffmpeg.git
- source = 005-ffmpeg-add-svt-hevc-gb62f72e.patch
- source = 010-ffmpeg-add-svt-hevc-gb62f72e.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/b62f72e752243cee4104cfb41dc7ee409d3ac3e9/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
+ source = 005-ffmpeg-add-svt-hevc-g7771d7c.patch
+ source = 010-ffmpeg-add-svt-hevc-g7771d7c.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/7771d7c1ec60cf21d84894260a4b14e9034c7156/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch
source = 030-ffmpeg-add-svt-vp9-gd9ef3cc.patch::https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/d9ef3cc13159143b9afc776c04f67cdfa6284046/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = LICENSE
sha256sums = SKIP
- sha256sums = 52c7f9299b9cb3ad47ef580a7732c5a2c6367d406284ad4c5acd430d718b0e5c
- sha256sums = 4da3826aa370572273ef9fb4c0bf2c93a840595b07a671a0412ad0dc9ed8d689
+ sha256sums = 797fd82276b9c31267412105d663eca9c3dcef6d823b228487a14b70565b8563
+ sha256sums = e9ae5d753169f56bbc7fe53615398032f985caaeae6b89bd952c4e4bc9ec8531
sha256sums = e310eedb3dc88c8ad6ffcd6cb6bde1f593ded330ea99b0356724c9d22bcfde4c
sha256sums = 3f4d677da3efdc3d2a1cbd36257d626b7e4c05d685ed82bd1a7e2eb7e3ac6ee4
sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
diff --git a/005-ffmpeg-add-svt-hevc-g7771d7c.patch b/005-ffmpeg-add-svt-hevc-g7771d7c.patch
new file mode 100644
index 000000000000..85f16fdd2433
--- /dev/null
+++ b/005-ffmpeg-add-svt-hevc-g7771d7c.patch
@@ -0,0 +1,21 @@
+--- a/010-ffmpeg-add-svt-hevc-g7771d7c.patch
++++ b/010-ffmpeg-add-svt-hevc-g7771d7c.patch
+@@ -38,15 +38,15 @@ index 0f3042b8a7..655eaf6848 100755
+ libtensorflow
+ libtesseract
+ libtheora
+-@@ -3399,6 +3401,7 @@ libx264_encoder_select="atsc_a53"
+- libx264rgb_encoder_deps="libx264"
++@@ -3400,6 +3405,7 @@ libx264rgb_encoder_deps="libx264"
+ libx264rgb_encoder_select="libx264_encoder"
+ libx265_encoder_deps="libx265"
++ libx265_encoder_select="atsc_a53"
+ +libsvt_hevc_encoder_deps="libsvthevc"
+ libxavs_encoder_deps="libxavs"
+ libxavs2_encoder_deps="libxavs2"
+ libxvid_encoder_deps="libxvid"
+-@@ -6680,6 +6683,7 @@ enabled libssh && require_pkg_config libssh libssh libssh/sftp.h sftp
++@@ -6681,6 +6687,7 @@ enabled libssh && require_pkg_config libssh libssh libssh/sftp.h sftp
+ enabled libspeex && require_pkg_config libspeex speex speex/speex.h speex_decoder_init
+ enabled libsrt && require_pkg_config libsrt "srt >= 1.3.0" srt/srt.h srt_socket
+ enabled libsvtav1 && require_pkg_config libsvtav1 "SvtAv1Enc >= 0.9.0" EbSvtAv1Enc.h svt_av1_enc_init_handle
diff --git a/005-ffmpeg-add-svt-hevc-gb62f72e.patch b/005-ffmpeg-add-svt-hevc-gb62f72e.patch
deleted file mode 100644
index 382979931105..000000000000
--- a/005-ffmpeg-add-svt-hevc-gb62f72e.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/010-ffmpeg-add-svt-hevc-gb62f72e.patch
-+++ b/010-ffmpeg-add-svt-hevc-gb62f72e.patch
-@@ -46,14 +46,14 @@ index 5a167613a4..9897fcaf4d 100755
- libxavs_encoder_deps="libxavs"
- libxavs2_encoder_deps="libxavs2"
- libxvid_encoder_deps="libxvid"
--@@ -6686,6 +6689,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
-+@@ -6757,6 +6757,7 @@ enabled mmal && { check_lib mmal interface/mmal/mmal.h mmal_port_co
- check_lib mmal interface/mmal/mmal.h mmal_port_connect -lmmal_core -lmmal_util -lmmal_vc_client -lbcm_host; } ||
- die "ERROR: mmal not found" &&
- check_func_headers interface/mmal/mmal.h "MMAL_PARAMETER_VIDEO_MAX_NUM_CALLBACKS"; }
- +enabled libsvthevc && require_pkg_config libsvthevc SvtHevcEnc EbApi.h EbInitHandle
-- enabled openal && { { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
-+ enabled openal && { check_pkg_config openal "openal >= 1.1" "AL/al.h" alGetError ||
-+ { for al_extralibs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
- check_lib openal 'AL/al.h' alGetError "${al_extralibs}" && break; done } ||
-- die "ERROR: openal not found"; } &&
- diff --git a/libavcodec/Makefile b/libavcodec/Makefile
- index 3b8f7b5e01..bfd6535345 100644
- --- a/libavcodec/Makefile
diff --git a/PKGBUILD b/PKGBUILD
index 65979a558925..92a862da3330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=5.2.r108915.g5661c8715c
+pkgver=5.2.r109078.g2d25f33a7e
pkgrel=1
-_svt_hevc_ver='b62f72e752243cee4104cfb41dc7ee409d3ac3e9'
+_svt_hevc_ver='7771d7c1ec60cf21d84894260a4b14e9034c7156'
_svt_vp9_ver='d9ef3cc13159143b9afc776c04f67cdfa6284046'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -119,7 +119,7 @@ depends=(
'xavs'
'xavs2'
)
-makedepends=('git' 'clang' 'amf-headers' 'ffnvcodec-headers' 'nasm' 'opencl-headers'
+makedepends=('git' 'clang' 'amf-headers' 'ffnvcodec-headers-git' 'nasm' 'opencl-headers'
'vulkan-headers' 'decklink-sdk')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswscale.so' 'libswresample.so'
@@ -134,8 +134,8 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'LICENSE')
sha256sums=('SKIP'
- '52c7f9299b9cb3ad47ef580a7732c5a2c6367d406284ad4c5acd430d718b0e5c'
- '4da3826aa370572273ef9fb4c0bf2c93a840595b07a671a0412ad0dc9ed8d689'
+ '797fd82276b9c31267412105d663eca9c3dcef6d823b228487a14b70565b8563'
+ 'e9ae5d753169f56bbc7fe53615398032f985caaeae6b89bd952c4e4bc9ec8531'
'e310eedb3dc88c8ad6ffcd6cb6bde1f593ded330ea99b0356724c9d22bcfde4c'
'3f4d677da3efdc3d2a1cbd36257d626b7e4c05d685ed82bd1a7e2eb7e3ac6ee4'
'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'