summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-31 18:54:16 -0300
committerDaniel Bermond2017-05-31 18:54:16 -0300
commitcd8c211c6df609410fb71b4db21ec1a85d411678 (patch)
tree5d04426a3481559e91218e47d43925ba93c09767
parentb9b807373f6da7dc4e7571f945633f279a0792fa (diff)
downloadaur-cd8c211c6df609410fb71b4db21ec1a85d411678.tar.gz
Fix build if package is installing cuda for the first time
When installing cuda for the first time, the cuda binaries appear on PATH only after the user do a relogin. As a consequence, the cuda binaries will not be available if cuda is being installed for the first time as a dependency of ffmpeg-full-git. This can be fixed by strictly specifying the full path of nvcc. Reference: ---------- https://git.archlinux.org/svntogit/community.git/tree/trunk/cuda.install?h=packages/cuda
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bef0bf6d9563..031976d84f18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed May 31 21:39:15 UTC 2017
+# Wed May 31 21:54:07 UTC 2017
pkgbase = ffmpeg-full-git
pkgdesc = Record, convert and stream audio and video (Git version with all possible libs)
pkgver = N.86313.g87bddba43b
- pkgrel = 3
+ pkgrel = 4
url = http://www.ffmpeg.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d0e652456c2a..4a62a2136545 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ffmpeg-full-git
pkgver=N.86313.g87bddba43b
-pkgrel=3
+pkgrel=4
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
url="http://www.ffmpeg.org/"
@@ -76,6 +76,10 @@ build() {
fi
_ldflags="--extra-ldflags=-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
_ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
+
+ # strictly specifying nvcc path is needed if package is installing
+ # cuda for the first time
+ sed -i 's/^nvcc_default=.*/nvcc_default=\"\/opt\/cuda\/bin\/nvcc\"/' configure
fi
msg2 "Running ffmpeg configure script. Please wait..."