summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-05-10 17:14:23 -0300
committerDaniel Bermond2022-05-10 17:14:23 -0300
commitd42dae7d62a134352bee23ed2e526f5a198a2f70 (patch)
tree65474714bfc75c93a601046a2219dfce8b598e1d
parentd120c1939814e38696b7fedafb8e60a5c91d1379 (diff)
downloadaur-d42dae7d62a134352bee23ed2e526f5a198a2f70.tar.gz
Refresh chromium patch
Update the chromium patch[1] to match the latest ffmpeg git master changes[2]. AVStream does not have the 'AVStreamInternal* internal' field anymore, and AVStreamInternal struct does not exist anymore either. The equivalent is now FFStream, and it should now be accessed by 'FFStream* ffstream(AVStream*)'. References ---------- [1] https://chromium.googlesource.com/chromium/third_party/ffmpeg/+/95aab0fd83619408995720ce53d7a74790580220%5E%21/ [2] https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/40bdd8cc05d9c98a18cf2b1c2a00c8a5a7b38113
-rw-r--r--.SRCINFO4
-rw-r--r--040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch29
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86cd51673fdf..d8cba39bf0c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-full-git
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)
- pkgver = 5.1.r106675.gf2724d2b69
+ pkgver = 5.1.r106894.g260d7d5a6c
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -135,7 +135,7 @@ pkgbase = ffmpeg-full-git
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = LICENSE
sha256sums = SKIP
- sha256sums = 91973c465f01446a999f278f0c2a3763304994dba1ac35de0e4c72f12f39409e
+ sha256sums = 2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c
sha256sums = 0d6b53940a81ebaf4e6b1a2208a178eb8a824d6a3d8e863bf9c4c7e0060d88ec
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
diff --git a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
index fb5589800d3d..83fd707e65d0 100644
--- a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+++ b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
@@ -1,19 +1,6 @@
-From 95aab0fd83619408995720ce53d7a74790580220 Mon Sep 17 00:00:00 2001
-From: "liberato@chromium.org" <liberato@chromium.org>
-Date: Wed, 7 Jul 2021 19:01:22 -0700
-Subject: [PATCH] Add av_stream_get_first_dts for Chromium
-
-[foutrelis: adjust for new FFStream struct replacing AVStreamInternal]
----
- libavformat/avformat.h | 4 ++++
- libavformat/utils.c | 7 +++++++
- 2 files changed, 11 insertions(+)
-
-diff --git a/libavformat/avformat.h b/libavformat/avformat.h
-index cd7b0d941c..b4a6dce885 100644
--- a/libavformat/avformat.h
+++ b/libavformat/avformat.h
-@@ -1010,6 +1010,10 @@ struct AVCodecParserContext *av_stream_get_parser(const AVStream *s);
+@@ -1128,6 +1128,10 @@ struct AVCodecParserContext *av_stream_get_parser(const AVStream *s);
*/
int64_t av_stream_get_end_pts(const AVStream *st);
@@ -24,21 +11,19 @@ index cd7b0d941c..b4a6dce885 100644
#define AV_PROGRAM_RUNNING 1
/**
-diff --git a/libavformat/utils.c b/libavformat/utils.c
-index de7580c32d..0ef0fe530e 100644
--- a/libavformat/utils.c
+++ b/libavformat/utils.c
-@@ -121,6 +121,13 @@ int64_t av_stream_get_end_pts(const AVStream *st)
- return AV_NOPTS_VALUE;
+@@ -55,6 +55,13 @@ int ff_unlock_avformat(void)
+ return ff_mutex_unlock(&avformat_mutex) ? -1 : 0;
}
+// Chromium: We use the internal field first_dts vvv
+int64_t av_stream_get_first_dts(const AVStream *st)
+{
-+ return cffstream(st)->first_dts;
++ return ffstream(st)->first_dts;
+}
+// Chromium: We use the internal field first_dts ^^^
+
- struct AVCodecParserContext *av_stream_get_parser(const AVStream *st)
- {
- return st->internal->parser;
+ /* an arbitrarily chosen "sane" max packet size -- 50M */
+ #define SANE_CHUNK_SIZE (50000000)
+
diff --git a/PKGBUILD b/PKGBUILD
index 921af4289427..c4ba3668adbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=5.1.r106675.gf2724d2b69
+pkgver=5.1.r106894.g260d7d5a6c
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac; git version)'
arch=('x86_64')
@@ -20,7 +20,7 @@ depends=(
'v4l-utils' 'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'libwebp' 'x264' 'x265'
'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
- 'vulkan-icd-loader' 'libxv' 'libx11' 'libxext' 'zlib' 'cuda'
+ 'vulkan-icd-loader' 'libxv' 'libx11' 'libxext' 'zlib' 'cuda'
'libomxil-bellagio' 'libdrm' 'intel-media-sdk' 'libva' 'libvdpau'
# AUR:
'chromaprint-fftw' 'davs2' 'flite1' 'libklvanc-git' 'openh264'
@@ -48,7 +48,7 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'LICENSE')
sha256sums=('SKIP'
- '91973c465f01446a999f278f0c2a3763304994dba1ac35de0e4c72f12f39409e'
+ '2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c'
'0d6b53940a81ebaf4e6b1a2208a178eb8a824d6a3d8e863bf9c4c7e0060d88ec'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')