summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorepitron2017-02-22 02:10:09 -0500
committerepitron2017-02-22 02:10:09 -0500
commit19b099058cc879c6abf1b5493588c7caa7223aed (patch)
treee0b08b6414d2255e96fa41c5d14c6c3da2f35a3a
parent885a83515ae37933795eb0b49144e4663725975c (diff)
downloadaur-19b099058cc879c6abf1b5493588c7caa7223aed.tar.gz
Forked from ffmpeg-git and updated to build support for Intel QSV
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10fb72015707..eb4709fd574b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Jul 10 10:54:05 UTC 2016
-pkgbase = ffmpeg-git
- pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 3.2.r80954.gd4c8e93
+pkgbase = ffmpeg-qsv-git
+ pkgdesc = Complete solution to record, convert and stream audio and video (git version, with Intel Quick Sync Video hardware acceleration)
+ pkgver = 3.3.r83607.gc9e3952b82
pkgrel = 1
url = http://ffmpeg.org/
arch = i686
@@ -51,6 +49,7 @@ pkgbase = ffmpeg-git
depends = libx264.so
depends = libx265.so
depends = libfdk-aac
+ depends = intel-media-sdk
optdepends = ladspa: LADSPA filters
provides = ffmpeg
provides = libavcodec.so
@@ -64,8 +63,8 @@ pkgbase = ffmpeg-git
provides = libswscale.so
conflicts = ffmpeg
conflicts = ffmpeg-full-git
- source = ffmpeg-git::git://source.ffmpeg.org/ffmpeg.git
+ source = ffmpeg-qsv-git::git://source.ffmpeg.org/ffmpeg.git
md5sums = SKIP
-pkgname = ffmpeg-git
+pkgname = ffmpeg-qsv-git
diff --git a/PKGBUILD b/PKGBUILD
index 8f3d69490975..9d3390be6b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Kamran Mackey <kamranm1200@gmail.com>
+# Maintainer: epitron <chris@ill-logic.com>
+# Contributor: Kamran Mackey <kamranm1200@gmail.com>
# Contributor: richteer <richteer at lastprime.net>
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
-pkgname=ffmpeg-git
-pkgver=3.2.r80954.gd4c8e93
+pkgname=ffmpeg-qsv-git
+pkgver=3.3.r83607.gc9e3952b82
pkgrel=1
-pkgdesc="Complete solution to record, convert and stream audio and video (git version)"
+pkgdesc="Complete solution to record, convert and stream audio and video (git version, with Intel Quick Sync Video hardware acceleration)"
arch=('i686' 'x86_64')
license=('GPL3' 'Non-free')
url="http://ffmpeg.org/"
@@ -14,12 +15,13 @@ depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
'v4l-utils' 'xvidcore' 'zlib' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
- 'libvpx.so' 'libx264.so' 'libx265.so' 'libfdk-aac')
+ 'libvpx.so' 'libx264.so' 'libx265.so' 'libfdk-aac'
+ 'intel-media-sdk')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm' 'git')
optdepends=('ladspa: LADSPA filters')
provides=('ffmpeg' 'libavcodec.so' 'libavdevice.so' 'libavfilter.so'
'libavformat.so' 'libavresample.so' 'libavutil.so' 'libpostproc.so'
- 'libswresample.so' 'libswscale.so')
+ 'libswresample.so' 'libswscale.so')
conflicts=('ffmpeg' 'ffmpeg-full-git')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git')
md5sums=('SKIP')
@@ -35,10 +37,12 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
+ PKG_CONFIG_PATH=/opt/intel/mediasdk/lib/pkgconfig/ \
./configure --prefix=/usr \
--disable-debug \
--disable-static \
- --enable-avisynth \
+ --enable-libmfx \
+ --enable-avisynth \
--enable-avresample \
--enable-fontconfig \
--enable-gnutls \