summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Suchan2024-03-02 22:50:45 +0000
committerRoland Suchan2024-03-02 22:50:45 +0000
commitf5c87dd4fad5d9b0364ba6b740a18cd1e066055e (patch)
tree0e6f3514e4338adaebebb2d78bdb5ea6c38ecc46
parenta38ad5ff70a9363151249b19809108a264d2843f (diff)
downloadaur-ffmpeg2.1.tar.gz
version 2.1-1
-rw-r--r--0024-fix-gcc13-binutils.patch18
-rw-r--r--PKGBUILD2
2 files changed, 10 insertions, 10 deletions
diff --git a/0024-fix-gcc13-binutils.patch b/0024-fix-gcc13-binutils.patch
index fd2fcd5792a2..9ea41d210365 100644
--- a/0024-fix-gcc13-binutils.patch
+++ b/0024-fix-gcc13-binutils.patch
@@ -1,8 +1,7 @@
-diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
-index 6298f5e..ca7e2df 100644
---- a/libavcodec/x86/mathops.h
-+++ b/libavcodec/x86/mathops.h
-@@ -35,12 +35,20 @@
+diff --git a/libavcodec/x86/mathops.h d/libavcodec/x86/mathops.h
+--- a/libavcodec/x86/mathops.h 2013-10-28 00:58:06.000000000 +0000
++++ d/libavcodec/x86/mathops.h 2024-02-27 21:23:40.090967590 +0000
+@@ -33,12 +33,20 @@
static av_always_inline av_const int MULL(int a, int b, unsigned shift)
{
int rt, dummy;
@@ -20,11 +19,11 @@ index 6298f5e..ca7e2df 100644
+ "shrdl %4, %%edx, %%eax \n\t"
+ :"=a"(rt), "=d"(dummy)
+ :"a"(a), "rm"(b), "c"((uint8_t)shift)
-+ );
++ );
return rt;
}
-@@ -113,19 +121,31 @@ __asm__ volatile(\
+@@ -108,19 +116,31 @@
// avoid +32 for shift optimization (gcc should do that ...)
#define NEG_SSR32 NEG_SSR32
static inline int32_t NEG_SSR32( int32_t a, int8_t s){
@@ -38,7 +37,7 @@ index 6298f5e..ca7e2df 100644
+ __asm__ ("sarl %1, %0\n\t"
+ : "+r" (a)
+ : "c" ((uint8_t)(-s))
-+ );
++ );
return a;
}
@@ -54,6 +53,7 @@ index 6298f5e..ca7e2df 100644
+ __asm__ ("shrl %1, %0\n\t"
+ : "+r" (a)
+ : "c" ((uint8_t)(-s))
-+ );
++ );
return a;
}
+
diff --git a/PKGBUILD b/PKGBUILD
index ea69fa227ace..a87fc1bfdc82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.gz"
'0024-fix-gcc13-binutils.patch'
)
md5sums=('6dc14b2521eb956b2d3799717d6b0ed1'
- '356415b3f340cb812c7453bfcd745528'
+ 'aaace471c8fde060fa8bd3ef29bd88d4'
)
options=('debug' '!lto')