summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTjaart van der Walt2016-03-11 09:59:18 -0600
committerTjaart van der Walt2016-03-11 09:59:18 -0600
commita69861368fd37043a774de13c1b9c2d7a71d31f3 (patch)
treefabd0f1374ce66091a0649ae32e7430edb3dd8e1
downloadaur-a69861368fd37043a774de13c1b9c2d7a71d31f3.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ef85b1e3433
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fgallery
+ pkgdesc = a modern, minimalist javascript photo gallery
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = https://www.thregr.org/~wavexx/software/fgallery/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fbida
+ depends = imagemagick
+ depends = lcms
+ depends = perl>=5.14
+ depends = perl-json
+ depends = perl-image-exiftool
+ depends = zip
+ optdepends = pngcrush
+ optdepends = p7zip
+ source = git+https://github.com/wavexx/fgallery.git
+ sha256sums = SKIP
+
+pkgname = fgallery
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a91344f539f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tjaart van der Walt <archlinux@tjaart.co.za>
+
+# TODO: There are more optional dependencies we should add: jpegoptim facedetect
+
+pkgname=fgallery
+pkgver=1.8.1
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc='a modern, minimalist javascript photo gallery'
+url='https://www.thregr.org/~wavexx/software/fgallery/'
+license=('GPL')
+depends=('fbida' 'imagemagick' 'lcms' 'perl>=5.14' 'perl-json' 'perl-image-exiftool' 'zip')
+optdepends=('pngcrush' 'p7zip')
+source=('git+https://github.com/wavexx/fgallery.git')
+sha256sums=('SKIP')
+
+package() {
+ # Copy the source to /opt/fgallery
+ cp -r ${srcdir} ${pkgdir}/opt
+ mkdir -p ${pkgdir}/usr/bin/
+
+ # Add a shortcut to fgallery in /usr/bin
+ echo "/opt/fgallery/fgallery \$@" > ${pkgdir}/usr/bin/fgallery
+ chmod 755 ${pkgdir}/usr/bin/fgallery
+
+ # Add a shortcut to the fcaption util in /usr/bin
+ echo "/opt/fgallery/utils/fcaption" > ${pkgdir}/usr/bin/fcaption
+ chmod 755 ${pkgdir}/usr/bin/fcaption
+}
+