summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTjaart van der Walt2016-05-22 11:37:13 -0500
committerTjaart van der Walt2016-05-22 11:37:13 -0500
commitefdb2beb84886c7135bf44b48306e9fdb3ed9799 (patch)
treeff2944aaa1a219fd6344d34919c89dcb46b24d7f
parenta69861368fd37043a774de13c1b9c2d7a71d31f3 (diff)
downloadaur-efdb2beb84886c7135bf44b48306e9fdb3ed9799.tar.gz
install released version instead of HEAD
Also added some user defined var to make it easier to customize the build
-rw-r--r--PKGBUILD40
1 files changed, 26 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a91344f539f..6141c470aa8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,39 @@
pkgname=fgallery
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='a modern, minimalist javascript photo gallery'
url='https://www.thregr.org/~wavexx/software/fgallery/'
license=('GPL')
depends=('fbida' 'imagemagick' 'lcms' 'perl>=5.14' 'perl-json' 'perl-image-exiftool' 'zip')
optdepends=('pngcrush' 'p7zip')
-source=('git+https://github.com/wavexx/fgallery.git')
-sha256sums=('SKIP')
+source=("https://github.com/wavexx/fgallery/archive/fgallery-${pkgver}.tar.gz")
+sha256sums=('7cdabf21aa76e33f37902ace0d12e2a338a3a96edb37cd88b28ce7af34ef57e1')
+
+destdir="/opt/fgallery"
+bindir="/usr/local/bin"
+mandir="/usr/local/man"
package() {
- # Copy the source to /opt/fgallery
- cp -r ${srcdir} ${pkgdir}/opt
- mkdir -p ${pkgdir}/usr/bin/
-
- # Add a shortcut to fgallery in /usr/bin
- echo "/opt/fgallery/fgallery \$@" > ${pkgdir}/usr/bin/fgallery
- chmod 755 ${pkgdir}/usr/bin/fgallery
-
- # Add a shortcut to the fcaption util in /usr/bin
- echo "/opt/fgallery/utils/fcaption" > ${pkgdir}/usr/bin/fcaption
- chmod 755 ${pkgdir}/usr/bin/fcaption
+ # make desired dirs
+ mkdir -p ${pkgdir}${destdir}
+ mkdir -p ${pkgdir}${bindir}
+
+ # Copy the source to destdir
+ cp -r ${srcdir}/fgallery-fgallery-${pkgver}/* ${pkgdir}${destdir}
+
+ # Add a shortcut to fgallery in bin dir
+ echo "${destdir}/fgallery \$@" > ${pkgdir}${bindir}/fgallery
+ chmod 755 ${pkgdir}${bindir}/fgallery
+
+ # Add a shortcut to the fcaption util in /usr/local/bin
+ echo "${destdir}/utils/fcaption" > ${pkgdir}${bindir}/fcaption
+ chmod 755 ${pkgdir}${bindir}/fcaption
+
+
+ # # Copy the fgallery manpage
+ # mkdir -p ${pkgdir}${mandir}
+ # cp ${srcdir}/fgallery.1 ${pkgdir}${mandir}/man.1/fgallery.1
}