summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2022-12-04 11:22:17 +0100
committerMattia Borda2022-12-04 11:22:17 +0100
commit9d82d41fa4b9fe6147addf63e146217fe570705b (patch)
tree38c87041730e1fdd9739db9157e2a6acd0a36287
downloadaur-file-roller-gtk4.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD35
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0da040869484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = file-roller-gtk4
+ pkgdesc = WIP GTK4 port of the File Roller archive utility
+ pkgver = 44.alpha
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/FileRoller
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ groups = gnome
+ license = GPL2
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = yelp-tools
+ depends = libadwaita
+ depends = libarchive
+ depends = libportal-gtk4
+ depends = libnautilus-extension
+ optdepends = p7zip: 7z, arj, exe and encrypted zip files support
+ optdepends = unrar: better RAR archive support
+ optdepends = unace: ACE archive support
+ optdepends = lrzip: lrzip archive support
+ optdepends = squashfs-tools: squashfs image support
+ provides = file-roller
+ conflicts = file-roller
+ source = git+https://gitlab.gnome.org/GNOME/file-roller.git#branch=wip/gtk4
+ b2sums = SKIP
+
+pkgname = file-roller-gtk4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd88cd26809c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+
+pkgname=file-roller-gtk4
+pkgver=44.alpha
+pkgrel=1
+pkgdesc="WIP GTK4 port of the File Roller archive utility"
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch=(i686 x86_64 armv7h aarch64)
+license=(GPL2)
+depends=(libadwaita libarchive libportal-gtk4 libnautilus-extension)
+makedepends=(git meson yelp-tools)
+checkdepends=(appstream-glib)
+optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
+ 'unrar: better RAR archive support'
+ 'unace: ACE archive support'
+ 'lrzip: lrzip archive support'
+ 'squashfs-tools: squashfs image support')
+conflicts=(${pkgname%-gtk4})
+provides=(${pkgname%-gtk4})
+groups=(gnome)
+source=("git+https://gitlab.gnome.org/GNOME/${pkgname%-gtk4}.git#branch=wip/gtk4")
+b2sums=('SKIP')
+
+build() {
+ arch-meson ${pkgname%-gtk4} build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}