summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2016-05-02 18:51:36 +0200
committermax.bra2016-05-02 18:51:36 +0200
commit0c4ffb3b4de9213ae2d024753fee8d9caf240650 (patch)
tree6feae4865b6df52db4bae04737d02d62e5b4aed9
parent4359a6b1bb9b0451406998b393d5de18ab92ab33 (diff)
downloadaur-0c4ffb3b4de9213ae2d024753fee8d9caf240650.tar.gz
v. 4.7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--filebot-arch.sh10
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 444d531ee0d0..8ab42c63dc57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Mar 13 12:28:01 UTC 2016
+# Mon May 2 16:51:36 UTC 2016
pkgbase = filebot
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums
- pkgver = 4.6.1
- pkgrel = 2
+ pkgver = 4.7
+ pkgrel = 1
url = http://filebot.sourceforge.net/
arch = any
license = GPL
@@ -13,12 +13,12 @@ pkgbase = filebot
optdepends = libzen: Support for additional subtitle search engines (Sublight)
optdepends = libmediainfo: Episode naming / Sublight usage
optdepends = java-p7zip-binding: Extract archives
- source = http://downloads.sourceforge.net/project/filebot/filebot/FileBot_4.6.1/FileBot_4.6.1-portable.zip
+ source = http://downloads.sourceforge.net/project/filebot/filebot/FileBot_4.7/FileBot_4.7-portable.zip
source = filebot-arch.sh
source = filebot.svg
source = filebot.desktop
- md5sums = 29845bf89eeeab2c6e7c6669ea034876
- md5sums = f9469bf391160033df1a7961fd732141
+ md5sums = 5bccdb98a0052f628aed38f857122656
+ md5sums = 1820bf0b4dc22bb8b96ff519ff1cd29d
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/PKGBUILD b/PKGBUILD
index 5ff25c3ed882..2de1f53f1e5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Nathan Owe <ndowens04 at gmail>
pkgname=filebot
-pkgver=4.6.1
-pkgrel=2
+pkgver=4.7
+pkgrel=1
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums"
arch=('any')
url="http://filebot.sourceforge.net/"
@@ -14,8 +14,8 @@ license=('GPL')
depends=('java-runtime>=8' 'fontconfig' 'chromaprint')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/FileBot_$pkgver/FileBot_$pkgver-portable.zip
$pkgname-arch.sh $pkgname.svg $pkgname.desktop)
-md5sums=('29845bf89eeeab2c6e7c6669ea034876'
- 'f9469bf391160033df1a7961fd732141'
+md5sums=('5bccdb98a0052f628aed38f857122656'
+ '1820bf0b4dc22bb8b96ff519ff1cd29d'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
#noextract=(FileBot_$pkgver.jar)
diff --git a/filebot-arch.sh b/filebot-arch.sh
index 9b8f2e649d2f..e48d1725ade7 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -4,9 +4,11 @@
export LANG="en_US.UTF-8"
export LC_ALL="en_US.UTF-8"
-# FileBot settings
+
+# choose extractor
+EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
+# EXTRACTOR="SevenZipExecutable" # use the 7z executable
# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
-# EXTRACTOR="SevenZipExecutable" # use the 7z executable
-EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
-java $JAVA_OPTS -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Dfile.encoding="UTF-8" -Djava.net.useSystemProxies=true -Dsun.net.client.defaultConnectTimeout=10000 -Dsun.net.client.defaultReadTimeout=60000 -Djna.nosys=true -Dapplication.deployment=aur -Dapplication.update=skip -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.filebot -Djava.io.tmpdir=/tmp/.filebot -Djna.library.path=/usr/share/java -jar /usr/share/java/filebot/filebot.jar "$@"
+# start filebot
+java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djava.net.useSystemProxies=false -Djna.nosys=true -Dapplication.deployment=portable -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Duser.home=$HOME/.config/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java $JAVA_OPTS -jar /usr/share/java/filebot/filebot.jar "$@"