summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2018-08-29 16:38:34 +0200
committermax.bra2018-08-29 16:38:34 +0200
commit468ee37187be3151f484d6adc4d6b49cd0311e8d (patch)
tree750ce7066dcc0ca1100def0930c4d0388181c6ee
parent0822d9c90486c1102737c03e10d7c48dfdedf707 (diff)
downloadaur-468ee37187be3151f484d6adc4d6b49cd0311e8d.tar.gz
v. 4.8.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD39
-rw-r--r--filebot-arch.sh4
3 files changed, 29 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f28d63dcaf08..cfafe0f054e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = filebot
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums.
- pkgver = 4.8.1
+ pkgver = 4.8.4
pkgrel = 1
url = https://github.com/filebot/filebot
install = filebot.install
arch = i686
arch = x86_64
- arch = arm
- arch = armv6h
+ arch = aarch64
+ arch = armv7l
arch = armv7h
license = GPL
makedepends = unzip
@@ -21,13 +21,11 @@ pkgbase = filebot
optdepends = java-p7zip-binding: Extract archives
optdepends = gvfs: gvfs backends
source = filebot::git+https://github.com/filebot/filebot.git
- source = https://github.com/java-native-access/jna/archive/4.5.1.tar.gz
source = filebot-arch.sh
source = filebot.svg
source = filebot.desktop
md5sums = SKIP
- md5sums = 3cf5c206ba2246386af2e9248fa6f035
- md5sums = 38c3f0029e094043cfca147981d41081
+ md5sums = fa7b8d4b811f5d9e0d27cffbb20dc0ee
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/PKGBUILD b/PKGBUILD
index a90b85c2c180..13c6a26818b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,29 @@
# Contributor: Nathan Owe <ndowens04 at gmail>
pkgname=filebot
-pkgver=4.8.1
+pkgver=4.8.4
pkgrel=1
-_jnaver=4.5.1
-_fixedcommit=0761faded4cfacbb4005a5842d8b89ce0a36f811
+_jnaver=4.5.2
+_fixedcommit=b9572f4501ba9d5af9d445a792fa902274f37679
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums."
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'aarch64' 'armv7l' 'armv7h')
url="https://github.com/filebot/filebot"
license=('GPL')
install=$pkgname.install
depends=('java-runtime>=9' 'fontconfig' 'chromaprint')
makedepends=('unzip' 'apache-ivy' 'jdk>=9')
-[[ $CARCH == "i686" ]] && _intarch=x86
-[[ $CARCH == "x86_64" ]] && _intarch=x86-64
-[[ $CARCH == "arm" ]] && _intarch=arm
-[[ $CARCH == "armv6h" ]] && _intarch=arm
-[[ $CARCH == "armv7h" ]] && _intarch=arm
+[[ $CARCH == "i686" ]] && _intarch=i686
+[[ $CARCH == "x86_64" ]] && _intarch=x86_64
+[[ $CARCH == "armv7l" ]] && _intarch=armv7l
+[[ $CARCH == "armv7h" ]] && _intarch=armv7l
source=("${pkgname}::git+https://github.com/filebot/filebot.git"
- https://github.com/java-native-access/jna/archive/$_jnaver.tar.gz
+ #https://github.com/java-native-access/jna/archive/$_jnaver.tar.gz
$pkgname-arch.sh $pkgname.svg $pkgname.desktop)
md5sums=('SKIP'
- '3cf5c206ba2246386af2e9248fa6f035'
- '38c3f0029e094043cfca147981d41081'
+ 'fa7b8d4b811f5d9e0d27cffbb20dc0ee'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
@@ -45,8 +43,10 @@ prepare() {
cd "$srcdir/$pkgname/"
git checkout $_fixedcommit
sed -i -E 's/release="([^"]*)"/target="\1" source="\1"/' build.xml
+ sed -i -E 's/-portable.tar.xz/-portable.tar.gz/' build.xml
sed -i -E 's/jre.version: 10/jre.version: 9/' app.properties
sed -i -E 's/jvm.version: 10/jvm.version: 9/' app.properties
+ sed -i -E 's/tar.compression: xz/tar.compression: gzip/' app.properties
cat <<EOT >> app.properties
url.data: https://app.filebot.net/data
@@ -58,19 +58,24 @@ apikey.acoustid: 0B3qZnQc
apikey.anidb: filebot
apikey.opensubtitles: FileBot
EOT
- cd "$srcdir/jna-$_jnaver/lib/native/"
- unzip linux-$_intarch.jar 2>&1 >/dev/null
+ #cd "$srcdir/jna-$_jnaver/lib/native/"
+ #unzip linux-$_intarch.jar 2>&1 >/dev/null
}
build() {
cd $pkgname
ant resolve
- ant fatjar
+ ant jar
+ ant tar
+ cd dist
+ mkdir portable
+ tar -xf FileBot_$pkgver-portable.tar.gz -C ./portable
}
package() {
- install -Dm644 $pkgname/dist/FileBot_$pkgver.jar "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
- install -Dm644 jna-$_jnaver/lib/native/libjnidispatch.so "$pkgdir/usr/share/java/$pkgname/libjnidispatch.so"
+ install -Dm644 $pkgname/dist/portable/lib/Linux-$_intarch/libjnidispatch.so "$pkgdir/usr/share/java/$pkgname/libjnidispatch.so"
+ cp -dpr --no-preserve=ownership $pkgname/dist/portable/jar/* "$pkgdir/usr/share/java/$pkgname/"
+
install -Dm755 $pkgname-arch.sh "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.svg "$pkgdir/usr/share/pixmaps/$pkgname.svg"
install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
diff --git a/filebot-arch.sh b/filebot-arch.sh
index 65cbecba2a95..cbf8ac3c708d 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -5,6 +5,8 @@ export LANG="en_US.UTF-8"
export LC_ALL="en_US.UTF-8"
APP_ROOT=/usr/share/java/filebot
+cd $APP_ROOT
+
# add APP_ROOT to LD_LIBRARY_PATH
if [ ! -z "$LD_LIBRARY_PATH" ]; then
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$APP_ROOT"
@@ -18,5 +20,5 @@ EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
# start filebot
-java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"
+java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=AUR -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java/filebot $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"