summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2018-03-22 20:34:43 +0100
committermax.bra2018-03-22 20:34:43 +0100
commit52ee44370e169f07b17ffac4669f3580b5df3928 (patch)
tree87036d921be129ab28ec8cb812922c8c3f955579
parent7a31a36542149a6c57785186e90a5d3b76e8cd70 (diff)
downloadaur-52ee44370e169f07b17ffac4669f3580b5df3928.tar.gz
v. 4.8.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
-rw-r--r--filebot-arch.sh2
3 files changed, 30 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e74f97d988b..46befdfb1bfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = filebot
pkgdesc = The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums.
- pkgver = 4.7.9
+ pkgver = 4.8.0
pkgrel = 1
url = http://filebot.sourceforge.net/
install = filebot.install
@@ -11,21 +11,22 @@ pkgbase = filebot
arch = armv7h
license = GPL
makedepends = unzip
- depends = java-runtime>=8
+ makedepends = apache-ivy
+ depends = java-runtime>=9
depends = fontconfig
depends = chromaprint
optdepends = libzen: Support for additional subtitle search engines (Sublight)
optdepends = libmediainfo: Episode naming / Sublight usage
optdepends = java-p7zip-binding: Extract archives
optdepends = gvfs: gvfs backends
- source = http://downloads.sourceforge.net/project/filebot/filebot/FileBot_4.7.9/FileBot_4.7.9-portable.tar.xz
- source = https://github.com/java-native-access/jna/archive/4.3.0.tar.gz
+ source = filebot::git+https://github.com/filebot/filebot.git
+ source = https://github.com/java-native-access/jna/archive/4.5.1.tar.gz
source = filebot-arch.sh
source = filebot.svg
source = filebot.desktop
- md5sums = 961dbdb7d6c62c133952df2f9f427d96
- md5sums = 2de8ba99fc91809935e6c2ab02f49a82
- md5sums = d94b4245dd3b226872f05fd2bf75bd1c
+ md5sums = SKIP
+ md5sums = 3cf5c206ba2246386af2e9248fa6f035
+ md5sums = 81b701ce1a1b52226f432aa86c6e1386
md5sums = 04f46be047049448dba3f0de29fe192d
md5sums = f37edd0bba7570904d28ab1681c7a7f3
diff --git a/PKGBUILD b/PKGBUILD
index 962f0e7f13fa..2c8297954437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: max.bra <max dot bra at alice dot it>
+# Contributor: apodim
# Contributor: said
# Contributor: Kaurin <milos dot kaurin at gmail>
# Contributor: Nathan Owe <ndowens04 at gmail>
pkgname=filebot
-pkgver=4.7.9
+pkgver=4.8.0
pkgrel=1
-_jnaver=4.3.0
+_jnaver=4.5.1
pkgdesc="The ultimate tool to rename TV/anime shows, download subtitles, and validate checksums."
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://filebot.sourceforge.net/"
license=('GPL')
install=$pkgname.install
-depends=('java-runtime>=8' 'fontconfig' 'chromaprint')
-makedepends=('unzip')
+depends=('java-runtime>=9' 'fontconfig' 'chromaprint')
+makedepends=('unzip' 'apache-ivy')
[[ $CARCH == "i686" ]] && _intarch=x86
[[ $CARCH == "x86_64" ]] && _intarch=x86-64
@@ -21,13 +22,13 @@ makedepends=('unzip')
[[ $CARCH == "armv6h" ]] && _intarch=arm
[[ $CARCH == "armv7h" ]] && _intarch=arm
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/FileBot_$pkgver/FileBot_$pkgver-portable.tar.xz
+source=("${pkgname}::git+https://github.com/filebot/filebot.git"
https://github.com/java-native-access/jna/archive/$_jnaver.tar.gz
$pkgname-arch.sh $pkgname.svg $pkgname.desktop)
-md5sums=('961dbdb7d6c62c133952df2f9f427d96'
- '2de8ba99fc91809935e6c2ab02f49a82'
- 'd94b4245dd3b226872f05fd2bf75bd1c'
+md5sums=('SKIP'
+ '3cf5c206ba2246386af2e9248fa6f035'
+ '81b701ce1a1b52226f432aa86c6e1386'
'04f46be047049448dba3f0de29fe192d'
'f37edd0bba7570904d28ab1681c7a7f3')
@@ -38,17 +39,23 @@ optdepends=('libzen: Support for additional subtitle search engines (Sublight)'
#noextract=($(for i in ${source[@]}; do basename $i; done))
-build() {
- /bin/true
-}
-
prepare() {
- cd jna-$_jnaver/lib/native/
+ cd "$srcdir/$pkgname/"
+ sed -i -E 's/release="([^"]*)"/target="\1" source="\1"/' build.xml
+ sed -i -E 's/jre.version: 10/jre.version: 9/' app.properties
+ sed -i -E 's/jvm.version: 10/jvm.version: 9/' app.properties
+ cd "$srcdir/jna-$_jnaver/lib/native/"
unzip linux-$_intarch.jar 2>&1 >/dev/null
}
+build() {
+ cd $pkgname
+ ant resolve
+ ant fatjar
+}
+
package() {
- install -Dm644 FileBot.jar "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
+ install -Dm644 $pkgname/dist/FileBot_$pkgver.jar "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
install -Dm644 jna-$_jnaver/lib/native/libjnidispatch.so "$pkgdir/usr/share/java/$pkgname/libjnidispatch.so"
install -Dm755 $pkgname-arch.sh "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.svg "$pkgdir/usr/share/pixmaps/$pkgname.svg"
diff --git a/filebot-arch.sh b/filebot-arch.sh
index 5a7c42d18956..7abac07c6c9f 100644
--- a/filebot-arch.sh
+++ b/filebot-arch.sh
@@ -18,5 +18,5 @@ EXTRACTOR="ApacheVFS" # use Apache Commons VFS2 with junrar plugin
# EXTRACTOR="SevenZipNativeBindings" # use the lib7-Zip-JBinding.so native library
# start filebot
-java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=portable -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java $JAVA_OPTS -jar /usr/share/java/filebot/filebot.jar "$@"
+java -Dunixfs=false -DuseGVFS=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=false -Dapplication.deployment=portable -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Djna.nosys=false -Djna.nounpack=true -Dnet.filebot.Archive.extractor="$EXTRACTOR" -Dnet.filebot.AcoustID.fpcalc="fpcalc" -Dapplication.dir=$HOME/.config/filebot -Djava.io.tmpdir=/tmp/filebot -Dapplication.update=skip -Djna.library.path=/usr/share/java $JAVA_OPTS -cp /usr/share/java/filebot/filebot.jar net.filebot.Main "$@"