summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiao Junxuan2022-01-24 00:35:12 +0800
committerLiao Junxuan2022-01-24 00:36:32 +0800
commit8fa753d13186df7658ba55b3680c4c2be3d73d94 (patch)
tree708ae26ecd1421aa1f61cf73de9a0e583ef7e44c
parentcf6f1c28988db38c00c738c954fce72684919934 (diff)
downloadaur-find-cursor.tar.gz
update to 1.8
-rw-r--r--.SRCINFO11
-rw-r--r--0001-specify-the-libraries-after-source-files.patch35
-rw-r--r--PKGBUILD16
3 files changed, 54 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2d735dd8d8d..7c490fc256d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = find-cursor
pkgdesc = Simple XLib program to highlight the cursor position in X11
- pkgver = 1.7
+ pkgver = 1.8
pkgrel = 1
url = https://github.com/arp242/find-cursor
arch = x86_64
license = MIT
depends = libx11
+ depends = libxext
depends = libxcomposite
- depends = libxdamage
depends = libxrender
- source = https://github.com/arp242/find-cursor/archive/refs/tags/v1.7.tar.gz
- sha256sums = 4ee50e5bedae92eec6b0f88a0dc1a6e9b783d2c34207b9b08e50dc7af069d610
+ depends = libxdamage
+ source = find-cursor-1.8.tar.gz::https://github.com/arp242/find-cursor/archive/refs/tags/v1.8.tar.gz
+ source = 0001-specify-the-libraries-after-source-files.patch
+ sha256sums = 2718ba5c65fe9b6a5a6e02989eba4ebacce1b9536e82896ac67f25203d7554bb
+ sha256sums = 4bd02c0073d1e67af2ae5be6d2b6e7ac5376ea825ff97bfe0f7c4a792de6e766
pkgname = find-cursor
diff --git a/0001-specify-the-libraries-after-source-files.patch b/0001-specify-the-libraries-after-source-files.patch
new file mode 100644
index 000000000000..6c71ac540252
--- /dev/null
+++ b/0001-specify-the-libraries-after-source-files.patch
@@ -0,0 +1,35 @@
+From 11ad767bd4c646efa89665519d335c69ba13d6a5 Mon Sep 17 00:00:00 2001
+From: Liao Junxuan <mikeljx at 126 dot com>
+Date: Mon, 24 Jan 2022 00:16:43 +0800
+Subject: [PATCH] specify the libraries after source files
+
+otherwise if the linker links the libraries "`--as-needed`",
+they won't be linked at all.
+
+---
+ Makefile | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 573ca62..004cf88 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,12 +3,13 @@ PREFIX ?= /usr/local
+ NAME ?= find-cursor
+
+ CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wpedantic -Os
+-LDFLAGS += -L/usr/lib -lX11 -lXext -lXfixes
++LDFLAGS += -L/usr/lib
++LIBS += -lX11 -lXext -lXfixes
+
+ .PHONY: all clean install uninstall
+
+ all:
+- ${CC} ${CFLAGS} ${LDFLAGS} -o ${NAME} *.c
++ ${CC} ${CFLAGS} ${LDFLAGS} -o ${NAME} *.c ${LIBS}
+
+ clean:
+ rm -f ${NAME}
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 29e05e1aec88..b3fa70b4fd3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,21 @@
+# Maintainer: Liao Junxuan <mikeljx at 126 dot com>
pkgname=find-cursor
-pkgver=1.7
+pkgver=1.8
pkgrel=1
pkgdesc="Simple XLib program to highlight the cursor position in X11"
arch=('x86_64')
url="https://github.com/arp242/find-cursor"
license=('MIT')
-depends=(libx11 libxcomposite libxdamage libxrender)
-source=("https://github.com/arp242/find-cursor/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('4ee50e5bedae92eec6b0f88a0dc1a6e9b783d2c34207b9b08e50dc7af069d610')
+depends=(libx11 libxext libxcomposite libxrender libxdamage)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ 0001-specify-the-libraries-after-source-files.patch)
+sha256sums=('2718ba5c65fe9b6a5a6e02989eba4ebacce1b9536e82896ac67f25203d7554bb'
+ '4bd02c0073d1e67af2ae5be6d2b6e7ac5376ea825ff97bfe0f7c4a792de6e766')
+
+prepare() {
+ cd "$srcdir/find-cursor-$pkgver"
+ patch --strip=1 -i "$srcdir"/0001-specify-the-libraries-after-source-files.patch
+}
build() {
cd "$srcdir/find-cursor-$pkgver"