summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Bukowski2017-03-29 10:59:06 +0200
committerBenjamin Bukowski2017-03-29 10:59:06 +0200
commit66587f4417fc06fef777522c76aff9b963494503 (patch)
treeafbc91dcc91b4aa368abd8c032321c96127edb7a
parent4bfb4f58b388a08b2134d55fdfcdae2a9851efb2 (diff)
downloadaur-66587f4417fc06fef777522c76aff9b963494503.tar.gz
* Updated to version 2.5.7.27050
* Using system directories
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD89
-rw-r--r--default.password6
-rw-r--r--firebird-superserver.install18
-rw-r--r--firebird-sysusers.conf1
-rw-r--r--firebird-tmpfiles.conf1
-rw-r--r--firebird.service (renamed from firebird-systemd.service)3
7 files changed, 72 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33db5042882e..3d10cf9daedb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 1 07:57:00 UTC 2016
+# Wed Mar 29 08:57:46 UTC 2017
pkgbase = firebird-superserver
pkgdesc = A open source SQL relational database management system (RDMS)
- pkgver = 2.5.6.27020
+ pkgver = 2.5.7.27050
pkgrel = 1
url = http://www.firebirdsql.org/
install = firebird-superserver.install
@@ -12,16 +12,20 @@ pkgbase = firebird-superserver
license = custom:IDPL
depends = icu
depends = libedit
- provides = libfbclient=2.5.6.27020
+ provides = libfbclient=2.5.7.27050
conflicts = firebird-classicserver
conflicts = libfbclient
options = !makeflags
- source = http://downloads.sourceforge.net/firebird/Firebird-2.5.6.27020-0.tar.bz2
+ source = http://downloads.sourceforge.net/firebird/Firebird-2.5.7.27050-0.tar.bz2
+ source = default.password
source = firebird-tmpfiles.conf
- source = firebird-systemd.service
- md5sums = 5514798d5dca8c3525525c61cf35283e
- md5sums = 98eff99fd8d195a45c251610d67bd473
- md5sums = ee9068e9bfdfa01e9dc79c72d1bfcdd8
+ source = firebird-sysusers.conf
+ source = firebird.service
+ md5sums = fb34241e96f9707604bf6cd78357d5a2
+ md5sums = ee601f52f1ba2481fe1f05b25d000bb8
+ md5sums = 79a1416e307e4dfb99640311b8defe07
+ md5sums = a43ab472f4d95e48ac21910bb33a5e86
+ md5sums = a830324550a9009150839386cd70f2bc
pkgname = firebird-superserver
diff --git a/PKGBUILD b/PKGBUILD
index c033878d660a..6523f617b3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,57 @@
-# Maintainer: Benjamin Bukowski <benjamin.bukowski@gmail.com>
+# Maintainer: Benjamin Bukowski <bbukowski@posteo.de>
pkgname=firebird-superserver
-pkgver=2.5.6.27020
+pkgver=2.5.7.27050
pkgrel=1
pkgdesc="A open source SQL relational database management system (RDMS)"
arch=('i686' 'x86_64')
url="http://www.firebirdsql.org/"
license=('custom:IPL' 'custom:IDPL')
-provides=("libfbclient=${pkgver}")
depends=('icu' 'libedit')
+provides=("libfbclient=${pkgver}")
conflicts=('firebird-classicserver' 'libfbclient')
options=('!makeflags')
install=firebird-superserver.install
source=("http://downloads.sourceforge.net/firebird/Firebird-$pkgver-0.tar.bz2"
+ 'default.password'
'firebird-tmpfiles.conf'
- 'firebird-systemd.service')
-md5sums=('5514798d5dca8c3525525c61cf35283e'
- '98eff99fd8d195a45c251610d67bd473'
- 'ee9068e9bfdfa01e9dc79c72d1bfcdd8')
+ 'firebird-sysusers.conf'
+ 'firebird.service')
+
+md5sums=('fb34241e96f9707604bf6cd78357d5a2'
+ 'ee601f52f1ba2481fe1f05b25d000bb8'
+ '79a1416e307e4dfb99640311b8defe07'
+ 'a43ab472f4d95e48ac21910bb33a5e86'
+ 'a830324550a9009150839386cd70f2bc')
build() {
cd $srcdir/Firebird-$pkgver-0
-
- ./autogen.sh --prefix=/opt/firebird --libdir=/usr/lib --includedir=/usr/include \
- --enable-superserver --with-system-icu --with-system-editline
- make CXXFLAGS='-std=gnu++98 -flifetime-dse=1'
+ ./autogen.sh \
+ --prefix=/usr \
+ --with-fbbin=/usr/bin \
+ --with-fbconf=/etc/firebird \
+ --with-fbdoc=/usr/share/doc/firebird \
+ --with-fbglock=/run/firebird \
+ --with-fbhelp=/usr/share/doc/firebird/help \
+ --with-fbinclude=/usr/include/firebird \
+ --with-fblib=/usr/lib \
+ --with-fblock=/run/firebird \
+ --with-fblog=/var/log/ \
+ --with-fbmsg=/var/lib/firebird/system \
+ --with-fbplugins=/usr/lib/firebird/plugins \
+ --with-fbsbin=/usr/lib/firebird/bin \
+ --with-fbudf=/usr/lib/firebird/UDF \
+ --with-fbsecure-db=/var/lib/firebird/system \
+ --with-fbintl=/usr/lib/firebird/intl \
+ --without-fbmisc \
+ --without-fbsample \
+ --without-fbsample-db \
+ --enable-superserver \
+ --with-system-icu \
+ --with-system-editline
+
+ CXXFLAGS+=' -std=gnu++98 -flifetime-dse=1' make
}
package() {
@@ -37,37 +63,22 @@ package() {
cp -av gen/buildroot/* $pkgdir/
- install -Dm644 $srcdir/firebird-systemd.service $pkgdir/usr/lib/systemd/system/firebird.service
install -Dm644 $srcdir/firebird-tmpfiles.conf $pkgdir/usr/lib/tmpfiles.d/firebird.conf
- install -Dm644 $pkgdir/opt/firebird/IPLicense.txt $pkgdir/usr/share/licenses/IPLicense.txt
- install -Dm644 $pkgdir/opt/firebird/IDPLicense.txt $pkgdir/usr/share/licenses/IDPLicense.txt
- touch $pkgdir/opt/firebird/{fb_guard,firebird.log}
+ install -Dm644 $srcdir/firebird-sysusers.conf $pkgdir/usr/lib/sysusers.d/firebird.conf
+ install -Dm644 $srcdir/firebird.service $pkgdir/usr/lib/systemd/system/firebird.service
+ install -Dm440 $srcdir/default.password $pkgdir/var/lib/firebird/system/SYSDBA.password
+ install -Dm644 $pkgdir/etc/firebird/I{,D}PLicense.txt -t $pkgdir/usr/share/licenses/${pkgname}
- rm $pkgdir/opt/firebird/I{,D}PLicense.txt
-
- cat << EOT > $pkgdir/opt/firebird/SYSDBA.password
-# This is the default password
-# You should change this password at the earliest oportunity
-# Your password can be changed to a more suitable one using the
-# /opt/firebird/bin/gsec utility
-ISC_USER=SYSDBA
-ISC_PASSWD=masterkey
-EOT
-
- if [ -x $pkgdir/opt/firebird/bin/fbmgr.bin ]; then
- cat > $pkgdir/opt/firebird/bin/fbmgr << EOT
-#!/bin/sh
-FIREBIRD=/opt/firebird
-export FIREBIRD
-exec /opt/firebird/bin/fbmgr.bin \$@
-EOT
- fi
+ # Remove unused files and dirs
+ rm $pkgdir/etc/firebird/I{,D}PLicense.txt
+ rm $pkgdir/etc/firebird/README
+ rm $pkgdir/etc/firebird/WhatsNew
+ rm -rf $pkgdir/var/log
+ rm -rf $pkgdir/run
- chmod u=rw,go= $pkgdir/opt/firebird/{fb_guard,firebird.log,security2.fdb}
- chmod -R ugo-w $pkgdir/opt/firebird/examples
- chmod u=r,go= $pkgdir/opt/firebird/SYSDBA.password
- chmod ugo+x $pkgdir/opt/firebird/bin/fbmgr
+ chmod -R ugo-w $pkgdir/usr/share/doc/firebird
+ chmod -R o= $pkgdir/var/lib/firebird
+ chown -R 184:184 $pkgdir/var/lib/firebird
}
-
# vim:set ts=2 sw=2 et:
diff --git a/default.password b/default.password
new file mode 100644
index 000000000000..11934074d7fb
--- /dev/null
+++ b/default.password
@@ -0,0 +1,6 @@
+# This is the default password
+# You should change this password at the earliest oportunity
+# Your password can be changed to a more suitable one using the
+# /usr/bin/gsec utility
+ISC_USER=SYSDBA
+ISC_PASSWD=masterkey
diff --git a/firebird-superserver.install b/firebird-superserver.install
index da132686650d..539d8d06320b 100644
--- a/firebird-superserver.install
+++ b/firebird-superserver.install
@@ -1,16 +1,6 @@
post_install() {
- echo ">>> Check /opt/firebird/SYSDBA.password for default login credentials!"
+ echo ">>> Check /usr/lib/firebird/SYSDBA.password for default login credentials!"
echo ">>> You should change this password at the earliest opportunity!"
-
- # Add firebird user/group
- getent group firebird &> /dev/null || groupadd -g 184 -r firebird
- getent passwd firebird &> /dev/null || useradd -u 184 -r -M -d /opt/firebird -s /bin/false -c "Firebird Database Owner" -g firebird firebird
-
- chown firebird.firebird opt/firebird/{fb_guard,firebird.log,security2.fdb,examples/empbuild/*.fdb}
-
- if [ -x /usr/bin/systemd-tmpfiles ]; then
- systemd-tmpfiles --create firebird.conf
- fi
}
post_upgrade() {
@@ -22,10 +12,4 @@ post_upgrade() {
fi
}
-post_remove() {
- # Remove firebird user/group
- getent passwd firebird &> /dev/null && userdel firebird &> /dev/null
- getent group firebird &> /dev/null && groupdel firebird &> /dev/null || true
-}
-
# vim:set ts=2 sw=2 et:
diff --git a/firebird-sysusers.conf b/firebird-sysusers.conf
new file mode 100644
index 000000000000..d2d7f96b22e7
--- /dev/null
+++ b/firebird-sysusers.conf
@@ -0,0 +1 @@
+u firebird 184 "Firebird Database Owner" /var/lib/firebird
diff --git a/firebird-tmpfiles.conf b/firebird-tmpfiles.conf
index 3da0dab1a232..8a01513f0ef5 100644
--- a/firebird-tmpfiles.conf
+++ b/firebird-tmpfiles.conf
@@ -1,2 +1,3 @@
d /run/firebird 0755 firebird firebird -
d /tmp/firebird 0770 firebird firebird -
+d /var/log/firebird 0770 firebird firebird -
diff --git a/firebird-systemd.service b/firebird.service
index e7d95e0fd9dc..4e928c1428ec 100644
--- a/firebird-systemd.service
+++ b/firebird.service
@@ -7,8 +7,7 @@ User=firebird
Group=firebird
Type=forking
PIDFile=/run/firebird/default.pid
-Environment=FIREBIRD=/opt/firebird/
-ExecStart=/opt/firebird/bin/fbguard -pidfile /run/firebird/default.pid -daemon -forever
+ExecStart=/usr/lib/firebird/bin/fbguard -pidfile /run/firebird/default.pid -daemon -forever
SyslogIdentifier=firebird
[Install]