summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Bukowski2018-08-20 11:46:13 +0200
committerBenjamin Bukowski2018-08-20 11:46:13 +0200
commitf04f2487e7ae3737aea61762309830bc2eb74455 (patch)
tree352c3b3902c088cff36bb569e0a5974fde555a9c
parent28ea57643cb3766f9d4456e2092f982a15f6e1c8 (diff)
downloadaur-f04f2487e7ae3737aea61762309830bc2eb74455.tar.gz
Fix missing libio.h
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--firebird-libio.patch13
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c635dbe6a86a..5d7bde73a48f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 21 12:59:04 UTC 2018
+# Mon Aug 20 09:45:23 UTC 2018
pkgbase = firebird-superserver
pkgdesc = A open source SQL relational database management system (RDMS)
pkgver = 2.5.8.27089
- pkgrel = 2
+ pkgrel = 3
url = http://www.firebirdsql.org/
install = firebird-superserver.install
arch = i686
@@ -23,6 +23,7 @@ pkgbase = firebird-superserver
source = firebird.service
source = firebird-icu60.patch
source = firebird-gcc6.patch
+ source = firebird-libio.patch
md5sums = 38862a3da39cf91f4f2366fb510f18a6
md5sums = ee601f52f1ba2481fe1f05b25d000bb8
md5sums = 79a1416e307e4dfb99640311b8defe07
@@ -30,6 +31,7 @@ pkgbase = firebird-superserver
md5sums = 90b4631c9bff99aab08511b3a184593e
md5sums = 70197fc801f9c66a6a1d7710e0c63718
md5sums = 9ab88cfcda674f9d28850a4f86f23741
+ md5sums = 8e7cac6da439c8798dccf6d4b4e457db
pkgname = firebird-superserver
diff --git a/PKGBUILD b/PKGBUILD
index 58009bb9b61d..5d7c3e233862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=firebird-superserver
_pkgver=2.5.8
pkgver=$_pkgver.27089
-pkgrel=2
+pkgrel=3
pkgdesc="A open source SQL relational database management system (RDMS)"
arch=('i686' 'x86_64')
url="http://www.firebirdsql.org/"
@@ -19,7 +19,8 @@ source=("https://github.com/FirebirdSQL/firebird/releases/download/R${_pkgver//.
'firebird-sysusers.conf'
'firebird.service'
'firebird-icu60.patch'
- 'firebird-gcc6.patch')
+ 'firebird-gcc6.patch'
+ 'firebird-libio.patch')
md5sums=('38862a3da39cf91f4f2366fb510f18a6'
'ee601f52f1ba2481fe1f05b25d000bb8'
@@ -27,12 +28,14 @@ md5sums=('38862a3da39cf91f4f2366fb510f18a6'
'a43ab472f4d95e48ac21910bb33a5e86'
'90b4631c9bff99aab08511b3a184593e'
'70197fc801f9c66a6a1d7710e0c63718'
- '9ab88cfcda674f9d28850a4f86f23741')
+ '9ab88cfcda674f9d28850a4f86f23741'
+ '8e7cac6da439c8798dccf6d4b4e457db')
prepare() {
cd $srcdir/Firebird-$pkgver-0
patch -Np1 -i ../firebird-icu60.patch
patch -Np1 -i ../firebird-gcc6.patch
+ patch -Np1 -i ../firebird-libio.patch
}
build() {
diff --git a/firebird-libio.patch b/firebird-libio.patch
new file mode 100644
index 000000000000..e54cb6aa43c7
--- /dev/null
+++ b/firebird-libio.patch
@@ -0,0 +1,13 @@
+--- a/src/jrd/perf.h 2018-01-05
++++ b/src/jrd/perf.h 2018-08-20
+@@ -31,10 +31,6 @@
+ #ifndef JRD_PERF_H
+ #define JRD_PERF_H
+
+-#ifdef LINUX
+-#include <libio.h>
+-#endif
+-
+ #ifdef HAVE_TIMES
+ #include <sys/types.h>
+ #include <sys/times.h>