summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Bukowski2017-05-04 18:27:42 +0200
committerBenjamin Bukowski2017-05-04 18:27:42 +0200
commitf2d15645b8627ce802621e9ffaa02bb1858e47b3 (patch)
tree106e0dee1f5b43c5dc70cc9bfa7e4387f2943382
parentd6134c17a8da38ca66f5a1ec29d464267580d323 (diff)
downloadaur-f2d15645b8627ce802621e9ffaa02bb1858e47b3.tar.gz
Fix build with newer icu version
Using 2 patches from extra/libfbclient package in order to compile with gcc6.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--firebird-c++11.patch16
-rw-r--r--firebird-c++14.patch30
4 files changed, 68 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c0280f5864e..5bcfff454078 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Mar 30 13:29:55 UTC 2017
+# Thu May 4 16:26:17 UTC 2017
pkgbase = firebird-superserver
pkgdesc = A open source SQL relational database management system (RDMS)
pkgver = 2.5.7.27050
- pkgrel = 3
+ pkgrel = 4
url = http://www.firebirdsql.org/
install = firebird-superserver.install
arch = i686
@@ -21,11 +21,15 @@ pkgbase = firebird-superserver
source = firebird-tmpfiles.conf
source = firebird-sysusers.conf
source = firebird.service
+ source = firebird-c++11.patch
+ source = firebird-c++14.patch
md5sums = fb34241e96f9707604bf6cd78357d5a2
md5sums = ee601f52f1ba2481fe1f05b25d000bb8
md5sums = 79a1416e307e4dfb99640311b8defe07
md5sums = a43ab472f4d95e48ac21910bb33a5e86
md5sums = bd75e6d2afcbc000e3593b1a66ea4ef7
+ md5sums = 5094347a8298143ca147edd49b552fe9
+ md5sums = a02710203cee81b4f48b7bdca3b1b33f
pkgname = firebird-superserver
diff --git a/PKGBUILD b/PKGBUILD
index 49948d0d36d3..bc88dc4c68f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Benjamin Bukowski <bbukowski@posteo.de>
pkgname=firebird-superserver
pkgver=2.5.7.27050
-pkgrel=3
+pkgrel=4
pkgdesc="A open source SQL relational database management system (RDMS)"
arch=('i686' 'x86_64')
url="http://www.firebirdsql.org/"
@@ -16,13 +16,23 @@ source=("http://downloads.sourceforge.net/firebird/Firebird-$pkgver-0.tar.bz2"
'default.password'
'firebird-tmpfiles.conf'
'firebird-sysusers.conf'
- 'firebird.service')
+ 'firebird.service'
+ 'firebird-c++11.patch'
+ 'firebird-c++14.patch')
md5sums=('fb34241e96f9707604bf6cd78357d5a2'
'ee601f52f1ba2481fe1f05b25d000bb8'
'79a1416e307e4dfb99640311b8defe07'
'a43ab472f4d95e48ac21910bb33a5e86'
- 'bd75e6d2afcbc000e3593b1a66ea4ef7')
+ 'bd75e6d2afcbc000e3593b1a66ea4ef7'
+ '5094347a8298143ca147edd49b552fe9'
+ 'a02710203cee81b4f48b7bdca3b1b33f')
+
+prepare() {
+ cd $srcdir/Firebird-$pkgver-0
+ patch -Np1 -i ../firebird-c++11.patch
+ patch -Np0 -i ../firebird-c++14.patch
+}
build() {
cd $srcdir/Firebird-$pkgver-0
@@ -38,7 +48,7 @@ build() {
--with-fblib=/usr/lib \
--with-fblock=/run/firebird \
--with-fblog=/var/log/ \
- --with-fbmsg=/var/lib/firebird/system \
+ --with-fbmsg=/usr/lib/firebird/msg \
--with-fbplugins=/usr/lib/firebird/plugins \
--with-fbsbin=/usr/lib/firebird/bin \
--with-fbudf=/usr/lib/firebird/UDF \
@@ -51,7 +61,7 @@ build() {
--with-system-icu \
--with-system-editline
- CXXFLAGS+=' -std=gnu++98 -flifetime-dse=1' make
+ CXXFLAGS+=' -flifetime-dse=1' make
}
package() {
@@ -79,8 +89,7 @@ package() {
mv $pkgdir/usr/bin/isql{,-fb}
chmod -R ugo-w $pkgdir/usr/share/doc/firebird
- chmod 755 $pkgdir/var/lib/firebird{,/system}
- chmod 444 $pkgdir/var/lib/firebird/system/*.msg
+ chmod -R o= $pkgdir/var/lib/firebird
chown -R 184:184 $pkgdir/var/lib/firebird
}
diff --git a/firebird-c++11.patch b/firebird-c++11.patch
new file mode 100644
index 000000000000..00de488eafb4
--- /dev/null
+++ b/firebird-c++11.patch
@@ -0,0 +1,16 @@
+# -*- Mode: Diff -*-
+--- firebird/src/dudley/exe.epp
++++ firebird/src/dudley/exe.epp
+@@ -2884,9 +2884,9 @@
+ blr_parameter, 0, 0, 0,
+ blr_parameter, 0, 1, 0,
+ blr_parameter, 1, 0, 0,
+- blr_end,
+- blr_end,
+- blr_end,
++ SCHAR(blr_end),
++ SCHAR(blr_end),
++ SCHAR(blr_end),
+ blr_eoc
+ };
+ static FB_API_HANDLE req_handle;
diff --git a/firebird-c++14.patch b/firebird-c++14.patch
new file mode 100644
index 000000000000..d978cef23b86
--- /dev/null
+++ b/firebird-c++14.patch
@@ -0,0 +1,30 @@
+--- src/common/classes/alloc.cpp
++++ src/common/classes/alloc.cpp
+@@ -2121,3 +2121,11 @@
+ {
+ Firebird::MemoryPool::globalFree(mem);
+ }
++void operator delete(void* mem, size_t) throw()
++{
++ Firebird::MemoryPool::globalFree(mem);
++}
++void operator delete[](void* mem, size_t) throw()
++{
++ Firebird::MemoryPool::globalFree(mem);
++}
+--- src/common/classes/alloc.h
++++ src/common/classes/alloc.h
+@@ -491,13 +491,6 @@
+
+ inline static MemoryPool* getDefaultMemoryPool() { return Firebird::MemoryPool::processMemoryPool; }
+
+-// Global versions of operators new and delete
+-void* operator new(size_t s) THROW_BAD_ALLOC;
+-void* operator new[](size_t s) THROW_BAD_ALLOC;
+-
+-void operator delete(void* mem) throw();
+-void operator delete[](void* mem) throw();
+-
+ #ifdef DEBUG_GDS_ALLOC
+ inline void* operator new(size_t s, Firebird::MemoryPool& pool, const char* file, int line)
+ {