summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2017-04-02 16:15:24 -0600
committerJohn D Jones III2017-04-02 16:15:24 -0600
commit58beba97976f45029103de2b417519ffd1578a13 (patch)
treed96eb02b7a08d8f1d62132e7a6df773b88a2fb3b
parent8e237580883d97cd8ddd1648caccf9d3e69c3d86 (diff)
downloadaur-58beba97976f45029103de2b417519ffd1578a13.tar.gz
Implement all of ArchangeGabriel's advice
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD63
2 files changed, 60 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a39f1c747122..a10db4113022 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Mar 20 14:16:22 UTC 2017
+# Sun Apr 2 22:14:31 UTC 2017
pkgbase = firefox-developer
pkgdesc = Standalone web browser from mozilla.org, developer build
- pkgver = 54.0a2
+ pkgver = 54.0a2.20170402
pkgrel = 1
url = http://www.mozilla.org/firefox/developer
arch = i686
@@ -19,12 +19,21 @@ pkgbase = firefox-developer
depends = sqlite3
depends = dbus-glib
optdepends = pulseaudio: audio/video playback
- source = https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-.tar.bz2
+ optdepends = ffmpeg: h.264 video
+ optdepends = hunspell: spell checking
+ optdepends = hyphen: hyphenation
source = firefox-developer.desktop
source = vendor.js
- sha512sums = SKIP
sha512sums = 9075e0d67e4dc153dcf514f3aa2b2415ce8b39275eedbf02a3cd122949b95bf4af9dad358516145decf445d1a903d52a634f4eeeb44bb67864de02e646a76631
sha512sums = bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010
+ source_i686 = https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-i686.tar.bz2
+ source_i686 = https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-i686.tar.bz2.asc
+ sha512sums_i686 = SKIP
+ sha512sums_i686 = SKIP
+ source_x86_64 = https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-x86_64.tar.bz2
+ source_x86_64 = https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora/firefox-54.0a2.en-US.linux-x86_64.tar.bz2.asc
+ sha512sums_x86_64 = SKIP
+ sha512sums_x86_64 = SKIP
pkgname = firefox-developer
diff --git a/PKGBUILD b/PKGBUILD
index a77d132c5ca6..9a17ecf85b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,62 @@
# Maintainer: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Thanks to ArchangeGabriel for tons of advice
+
_name=firefox
_channel=developer
+_version='54.0a2'
+_file="${_name}-${_version}.en-US.linux"
+_srcurl="https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora"
pkgname="${_name}-${_channel}"
pkgdesc='Standalone web browser from mozilla.org, developer build'
url='http://www.mozilla.org/firefox/developer'
-pkgver=54.0a2
+pkgver=54.0a2.20170402
pkgrel=1
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
-_file="${_name}-${pkgver}.en-US.linux-${CARCH}"
-_srcurl="https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-aurora"
-source=("${_srcurl}/${_file}.tar.bz2" "firefox-$_channel.desktop" "vendor.js")
-sha512sums=('SKIP'
- '9075e0d67e4dc153dcf514f3aa2b2415ce8b39275eedbf02a3cd122949b95bf4af9dad358516145decf445d1a903d52a634f4eeeb44bb67864de02e646a76631'
- 'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010')
+source=("${_name}-${_channel}.desktop" "vendor.js")
+source_i686=("${_srcurl}/${_file}-i686.tar.bz2"{,.asc})
+source_x86_64=("${_srcurl}/${_file}-x86_64.tar.bz2"{,.asc})
+sha512sums=(
+ '9075e0d67e4dc153dcf514f3aa2b2415ce8b39275eedbf02a3cd122949b95bf4af9dad358516145decf445d1a903d52a634f4eeeb44bb67864de02e646a76631'
+ 'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010'
+)
+sha512sums_i686=('SKIP' 'SKIP')
+sha512sums_x86_64=('SKIP' 'SKIP')
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla’s GnuPG release key
+
+pkgver() {
+ echo "${_version}.$(curl -s ${_srcurl}/${_name}-${_version}.en-US.linux-${CARCH}.txt | head -n1 | cut -c -8)"
+}
+
depends=('alsa-lib' 'libxt' 'libnotify' 'mime-types' 'nss' 'gtk3' 'sqlite3' 'dbus-glib')
-optdepends=('pulseaudio: audio/video playback')
+optdepends=(
+ 'pulseaudio: audio/video playback'
+ 'ffmpeg: h.264 video'
+ 'hunspell: spell checking'
+ 'hyphen: hyphenation'
+)
package() {
- install -d $pkgdir/{usr/{bin,share/{applications,pixmaps}},opt}
- cp -r firefox $pkgdir/opt/firefox-$_channel
-
- ln -s /opt/firefox-$_channel/firefox $pkgdir/usr/bin/firefox-$_channel
- install -m644 $srcdir/firefox-$_channel.desktop $pkgdir/usr/share/applications/
- install -m644 $srcdir/firefox/browser/icons/mozicon128.png $pkgdir/usr/share/pixmaps/$pkgname-icon.png
- ls
- install -Dm644 $srcdir/vendor.js $pkgdir/opt/firefox-$_channel/browser/defaults/preferences/vendor.js
+ OPT_PATH="opt/${_pkgname}"
+ install -d $pkgdir/{usr/{bin,share/{applications,pixmaps}},opt}
+ cp -r firefox $pkgdir/${OPT_PATH}
+
+ ln -s ${OPT_PATH}/firefox $pkgdir/usr/bin/{$_name}-${_channel}
+ # Icons
+ SRC_LOC="${srcdir}"/${_name}/browser
+ DEST_LOC="${pkgdir}"/usr/share/icons/hicolor
+ for i in 16 32 48
+ do
+ install -Dm644 "${SRC_LOC}"/chrome/icons/default/default${i}.png "${DEST_LOC}"/${i}x${i}/apps/${_pkgname}.png
+ done
+ install -m644 $srcdir/firefox/browser/icons/mozicon128.png $pkgdir/usr/share/pixmaps/$pkgname-icon.png
+
+ install -m644 $srcdir/${_name}-${_channel}.desktop $pkgdir/usr/share/applications/
+ install -Dm644 $srcdir/vendor.js $pkgdir/opt/firefox-$_channel/browser/defaults/preferences/vendor.js
+ # Use system-provided dictionaries
+ rm -rf "${pkgdir}"/${OPT_PATH}/{dictionaries,hyphenation}
+ ln -sf /usr/share/hunspell "${pkgdir}"/${OPT_PATH}/dictionaries
+ ln -sf /usr/share/hyphen "${pkgdir}"/${OPT_PATH}/hyphenation
}