summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2015-06-23 19:14:11 +0300
committerAlex Talker2015-06-23 19:22:39 +0300
commitd21b32a29793bd9135d2964c833bb0a346af7f8e (patch)
tree9f4d4e70407c4ebfb3d772f63200a1d497ed075e
downloadaur-firefox-developer-hg.tar.gz
Initial import
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD125
-rw-r--r--firefox-install-dir.patch12
-rw-r--r--firefox.desktop121
-rw-r--r--firefox.install13
-rw-r--r--mozconfig39
-rw-r--r--rhbz-966424.patch14
7 files changed, 379 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f042e6b3c4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = firefox-developer-hg
+ pkgdesc = Lastest developer edition of firefox browser built from the trunk code
+ pkgver = 247837.446133410f9b
+ pkgrel = 1
+ url = https://www.mozilla.org/firefox/
+ install = firefox.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = unzip
+ makedepends = zip
+ makedepends = diffutils
+ makedepends = python2
+ makedepends = yasm
+ makedepends = mesa
+ makedepends = imake
+ makedepends = xorg-server-xvfb
+ makedepends = libpulse
+ makedepends = gst-plugins-base-libs
+ makedepends = inetutils
+ makedepends = mercurial
+ depends = gtk2
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = libvpx
+ depends = icu
+ depends = libevent
+ depends = nss
+ depends = hunspell
+ depends = sqlite
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = gst-plugins-good: h.264 video
+ optdepends = gst-libav: h.264 video
+ conflicts = firefox
+ source = hg+https://hg.mozilla.org/releases/mozilla-aurora/
+ source = mozconfig
+ source = firefox.desktop
+ source = firefox-install-dir.patch
+ source = rhbz-966424.patch
+ sha256sums = SKIP
+ sha256sums = 2120f3420990cf718d69ab757d7a5eea5992fa6dbd870c1d8f81033d7d673f5f
+ sha256sums = d2a7610393ba259c35e3227b92e02ec91095a95189f56ac93ccdf6732772719c
+ sha256sums = d86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd
+ sha256sums = 4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961
+
+pkgname = firefox-developer-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0053630f112f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,125 @@
+# $Id$
+# Maintainer: Naoki Kawakami <nkawakami atto parallels dotto com>
+# Contributor: Alex Talker
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jakub Schmidtke <sjakub@gmail.com>
+
+pkgname=firefox-developer-hg
+pkgver=247837.446133410f9b
+pkgrel=1
+pkgdesc="Lastest developer edition of firefox browser built from the trunk code"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL' 'LGPL')
+url="https://www.mozilla.org/firefox/"
+conflicts=('firefox')
+depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
+ 'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
+ 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite')
+makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake'
+ 'xorg-server-xvfb' 'libpulse' 'gst-plugins-base-libs'
+ 'inetutils' 'mercurial')
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'gst-plugins-good: h.264 video'
+ 'gst-libav: h.264 video')
+install=firefox.install
+#options=('!emptydirs' '!makeflags')
+ccache=false
+if $ccache; then
+ options=('ccache')
+fi
+source=('hg+https://hg.mozilla.org/releases/mozilla-aurora/'
+ 'mozconfig'
+ 'firefox.desktop'
+ 'firefox-install-dir.patch'
+ 'rhbz-966424.patch')
+sha256sums=('SKIP'
+ '2120f3420990cf718d69ab757d7a5eea5992fa6dbd870c1d8f81033d7d673f5f'
+ 'd2a7610393ba259c35e3227b92e02ec91095a95189f56ac93ccdf6732772719c'
+ 'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
+ '4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961')
+_pgo=1 # set to 0 to disable
+
+pkgver() {
+ cd mozilla-aurora
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+prepare() {
+ cd mozilla-aurora
+
+ cp ../mozconfig .mozconfig
+ patch -Np1 -i ../firefox-install-dir.patch
+
+ # https://bugs.archlinux.org/task/41689
+ patch -Np2 -i ../rhbz-966424.patch
+
+# [[ -d "$srcdir/path" ]] || mkdir "$srcdir/path"
+
+ # WebRTC build tries to execute "python" and expects Python 2
+# [[ -L "$srcdir/path/python" ]] || ln -s /usr/bin/python2 "$srcdir/path/python"
+
+ # configure script misdetects the preprocessor without an optimization level
+ # https://bugs.archlinux.org/task/34644
+# sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
+
+
+}
+
+build() {
+ cd mozilla-aurora
+
+ export PATH="$srcdir/path:$PATH"
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/firefox"
+ export PYTHON="/usr/bin/python2"
+ export MOZ_MAKE_FLAGS="$MAKEFLAGS"
+ unset CPPFLAGS
+
+# PGO will result in double compilation
+# http://en.wikipedia.org/wiki/Profile-guided_optimization
+# https://developer.mozilla.org/en/docs/Building_with_Profile-Guided_Optimization
+ # Do PGO
+# xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
+# make -f client.mk build MOZ_PGO=1
+# make -f client.mk build
+ if [[ $CARCH = x86_64 ]] && [[ $_pgo = 1 ]]; then
+ msg2 'PGO build is selected'
+ xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
+ make -f client.mk profiledbuild
+ else
+ msg2 'Non-PGO build is selected or your architecture is not x86_64'
+ make -f client.mk build
+ fi
+
+}
+
+package() {
+ cd mozilla-aurora
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
+
+# install -Dm644 ../vendor.js "$pkgdir/usr/lib/firefox/browser/defaults/preferences/vendor.js"
+
+ for i in 16 32 48; do
+ install -Dm644 browser/branding/unofficial/default$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
+ done
+ install -Dm644 browser/branding/unofficial/content/icon64.png \
+ "$pkgdir/usr/share/icons/hicolor/64x64/apps/firefox.png"
+ install -Dm644 browser/branding/unofficial/mozicon128.png \
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/firefox.png"
+ install -Dm644 browser/branding/unofficial/content/about-logo.png \
+ "$pkgdir/usr/share/icons/hicolor/192x192/apps/firefox.png"
+ install -Dm644 browser/branding/unofficial/content/about-logo@2x.png \
+ "$pkgdir/usr/share/icons/hicolor/384x384/apps/firefox.png"
+
+ install -Dm644 ../firefox.desktop \
+ "$pkgdir/usr/share/applications/firefox.desktop"
+
+ # Use system-provided dictionaries
+ rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
+ ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
+ ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
+
+ #workaround for now
+ #https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ ln -sf firefox "$pkgdir/usr/lib/firefox/firefox-bin"
+}
diff --git a/firefox-install-dir.patch b/firefox-install-dir.patch
new file mode 100644
index 000000000000..51fe4ba0a855
--- /dev/null
+++ b/firefox-install-dir.patch
@@ -0,0 +1,12 @@
+diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/mozilla-release/config/baseconfig.mk
+--- mozilla-release/config/baseconfig.mk.orig 2014-04-22 15:38:52.948165295 +0200
++++ mozilla-release/config/baseconfig.mk 2014-04-22 15:42:20.387481673 +0200
+@@ -4,7 +4,7 @@
+ # whether a normal build is happening or whether the check is running.
+ includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+ idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+ ifndef TOP_DIST
+ TOP_DIST = dist
diff --git a/firefox.desktop b/firefox.desktop
new file mode 100644
index 000000000000..d156ecf6962d
--- /dev/null
+++ b/firefox.desktop
@@ -0,0 +1,121 @@
+[Desktop Entry]
+Name=Firefox
+Name[bn]=ফায়ারফক্স
+Name[eo]=Fajrovulpo
+Name[fi]=Firefox
+Name[pa]=ਫਾਇਰਫੋਕਸ
+Name[tg]=Рӯбоҳи оташин
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+Comment=Browse the World Wide Web
+Comment[ar]=تصفح الشبكة العنكبوتية العالمية
+Comment[ast]=Restola pela Rede
+Comment[bn]=ইন্টারনেট ব্রাউজ করুন
+Comment[ca]=Navegueu per la web
+Comment[cs]=Prohlížení stránek World Wide Webu
+Comment[da]=Surf på internettet
+Comment[de]=Im Internet surfen
+Comment[el]=Μπορείτε να περιηγηθείτε στο διαδίκτυο (Web)
+Comment[es]=Navegue por la web
+Comment[et]=Lehitse veebi
+Comment[fa]=صفحات شبکه جهانی اینترنت را مرور نمایید
+Comment[fi]=Selaa Internetin WWW-sivuja
+Comment[fr]=Naviguer sur le Web
+Comment[gl]=Navegar pola rede
+Comment[he]=גלישה ברחבי האינטרנט
+Comment[hr]=Pretražite web
+Comment[hu]=A világháló böngészése
+Comment[it]=Esplora il web
+Comment[ja]=ウェブを閲覧します
+Comment[ko]=웹을 돌아 다닙니다
+Comment[ku]=Li torê bigere
+Comment[lt]=Naršykite internete
+Comment[nb]=Surf på nettet
+Comment[nl]=Verken het internet
+Comment[nn]=Surf på nettet
+Comment[no]=Surf på nettet
+Comment[pl]=Przeglądanie stron WWW
+Comment[pt]=Navegue na Internet
+Comment[pt_BR]=Navegue na Internet
+Comment[ro]=Navigați pe Internet
+Comment[ru]=Доступ в Интернет
+Comment[sk]=Prehliadanie internetu
+Comment[sl]=Brskajte po spletu
+Comment[sv]=Surfa på webben
+Comment[ug]=دۇنيادىكى توربەتلەرنى كۆرگىلى بولىدۇ
+Comment[uk]=Перегляд сторінок Інтернету
+Comment[vi]=Để duyệt các trang web
+Comment[zh_CN]=浏览互联网
+Comment[zh_TW]=瀏覽網際網路
+Exec=/usr/lib/firefox/firefox %u
+Icon=firefox
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
+StartupNotify=true
+Categories=Network;WebBrowser;
diff --git a/firefox.install b/firefox.install
new file mode 100644
index 000000000000..1a1f4b16b5d2
--- /dev/null
+++ b/firefox.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
diff --git a/mozconfig b/mozconfig
new file mode 100644
index 000000000000..cf4939659e55
--- /dev/null
+++ b/mozconfig
@@ -0,0 +1,39 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+
+#ac_add_options --enable-official-branding
+
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+#ac_add_options --with-system-png
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --with-system-icu
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-cairo
+ac_add_options --enable-system-pixman
+
+# Features
+ac_add_options --enable-startup-notification
+ac_add_options --enable-pulseaudio
+ac_add_options --enable-gstreamer=1.0
+
+ac_add_options --enable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --disable-installer
+ac_add_options --disable-debug-symbols
+
+# PGO
+#mk_add_options PROFILE_GEN_SCRIPT='EXTRA_TEST_ARGS=10 $(MAKE) -C $(MOZ_OBJDIR) pgo-profile-run'
+# Fix clobber issue
+mk_add_options AUTOCLOBBER=1
+
+# vim:set ft=sh:
diff --git a/rhbz-966424.patch b/rhbz-966424.patch
new file mode 100644
index 000000000000..7579d090f8cc
--- /dev/null
+++ b/rhbz-966424.patch
@@ -0,0 +1,14 @@
+diff -up firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm.966424 firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm
+--- firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm.966424 2014-10-14 08:12:14.358697255 +0200
++++ firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm 2014-10-14 08:17:59.962181908 +0200
+@@ -174,7 +174,9 @@ this.checkCert =
+ }
+
+ function isBuiltinToken(tokenName) {
+- return tokenName == "Builtin Object Token";
++ return tokenName == "Builtin Object Token" ||
++ tokenName == "Default Trust" ||
++ tokenName == "System Trust";
+ }
+
+ /**