summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Dorbais2015-06-20 10:31:36 +0200
committerPierre Dorbais2015-06-20 10:31:36 +0200
commit0c69bfe90d121d23620b9ce66f1ecc21e5b90553 (patch)
treed7c78c7079fee2c86a2cba814977877025c0086b
downloadaur-firefox-extension-smoothwheel.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82e7b18b1a7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = firefox-extension-smoothwheel
+ pkgdesc = Scrolls the page smoothly when scrolling the mouse wheel
+ pkgver = 0.45.8.20130519.3
+ pkgrel = 1
+ url = http://smoothwheel.mozdev.org/
+ arch = any
+ license = GPLv2
+ source = https://addons.cdn.mozilla.net/storage/public-staging/357/smoothwheel-0.45.8.20130519.3-sm+fx+tb.xpi
+ md5sums = 2b83ad98f8add58d9ba125bf13adf539
+
+pkgname = firefox-extension-smoothwheel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c43e19202611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Pierre Dorbais <pierre at dorbais dot fr>
+
+pkgname=firefox-extension-smoothwheel
+pkgver=0.45.8.20130519.3
+_addons_file=357
+pkgrel=1
+pkgdesc="Scrolls the page smoothly when scrolling the mouse wheel"
+arch=('any')
+url="http://smoothwheel.mozdev.org/"
+license=('GPLv2')
+source=("https://addons.cdn.mozilla.net/storage/public-staging/${_addons_file}/smoothwheel-${pkgver}-sm+fx+tb.xpi")
+md5sums=('2b83ad98f8add58d9ba125bf13adf539')
+
+package() {
+ cd $srcdir
+ local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ [ -n ${emid} ] || return 1
+ install -d $dstdir
+ cp -R * $dstdir
+ rm $dstdir/*.xpi
+ find $pkgdir -type d -exec chmod 0755 {} \;
+ find $pkgdir -type f -exec chmod 0644 {} \;
+}