summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2019-07-25 03:36:22 +0200
committerBjörn Bidar2019-07-25 03:38:25 +0200
commit6853811dedb3d0bf28d352479f5aafa25460d038 (patch)
tree6d1bfbce90f68d1aad1a37c5e6696d6a5951f44c
parent8bc15f7911f8712cb0f090226bdaa8a708ab03c6 (diff)
downloadaur-6853811dedb3d0bf28d352479f5aafa25460d038.tar.gz
upkg
- new upstream release - sync desktop file with arch - add patch to fix MOZILLA#1530052
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch56
-rw-r--r--PKGBUILD9
-rw-r--r--firefox.desktop1
4 files changed, 68 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 382b6e3367a4..c90e204e96e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jul 11 08:02:01 UTC 2019
+# Thu Jul 25 01:34:09 UTC 2019
pkgbase = firefox-kde-opensuse
pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
pkgver = 68.0
@@ -80,9 +80,10 @@ pkgbase = firefox-kde-opensuse
source = mozilla-1516081.patch
source = pgo.patch
source = 7002_system_av1_support.patch
+ source = 0001-Use-remoting-name-for-GDK-application-names.patch
md5sums = SKIP
md5sums = f758e064e1463b90878790124f398197
- md5sums = 14e0f6237a79b85e60256f4808163160
+ md5sums = b5f16f03db295778f0123a4e1dd93772
md5sums = 5cee310a9040ccc5abcf29742b84aeb8
md5sums = 05bb69d25fb3572c618e3adf1ee7b670
md5sums = d7ce23a18da21c05cd756766e177834f
@@ -98,6 +99,7 @@ pkgbase = firefox-kde-opensuse
md5sums = 79d27c8896913c7d87b148240995ab69
md5sums = f867ae41a722630cc5567e2dcc51676d
md5sums = df439e02304d302009c320a540f01dbe
+ md5sums = 0ffabb81dd8a5fe98bb8afe47d6541d3
pkgname = firefox-kde-opensuse
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
new file mode 100644
index 000000000000..8cc378636c19
--- /dev/null
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -0,0 +1,56 @@
+From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
+Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Mon, 25 Mar 2019 20:30:11 +0100
+Subject: [PATCH] Use remoting name for GDK application names
+
+---
+ toolkit/xre/nsAppRunner.cpp | 6 +-----
+ widget/gtk/nsAppShell.cpp | 7 +++----
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+index 0b808ef215f06..28911c0ffeaec 100644
+--- a/toolkit/xre/nsAppRunner.cpp
++++ b/toolkit/xre/nsAppRunner.cpp
+@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+ // consistently.
+
+ // Set program name to the one defined in application.ini.
+- {
+- nsAutoCString program(gAppData->name);
+- ToLowerCase(program);
+- g_set_prgname(program.get());
+- }
++ g_set_prgname(gAppData->remotingName);
+
+ // Initialize GTK here for splash.
+
+diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
+index 0686ff814916b..ae4a4ea55f420 100644
+--- a/widget/gtk/nsAppShell.cpp
++++ b/widget/gtk/nsAppShell.cpp
+@@ -24,6 +24,7 @@
+ # include "WakeLockListener.h"
+ #endif
+ #include "gfxPlatform.h"
++#include "nsAppRunner.h"
+ #include "ScreenHelperGTK.h"
+ #include "HeadlessScreenHelper.h"
+ #include "mozilla/widget/ScreenManager.h"
+@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
+ // option when program uses gdk_set_program_class().
+ //
+ // See https://bugzilla.gnome.org/show_bug.cgi?id=747634
+- nsAutoString brandName;
+- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
+- if (!brandName.IsEmpty()) {
+- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
++ if (gAppData) {
++ gdk_set_program_class(gAppData->remotingName);
+ }
+ }
+
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 28c09c078cb2..324de4fab8b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,6 +77,8 @@ source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
pgo.patch
# use sytem av1
7002_system_av1_support.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ 0001-Use-remoting-name-for-GDK-application-names.patch
)
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -122,6 +124,8 @@ prepare() {
patch -Np1 -i "$srcdir"/2001_system_graphite2_support.patch
patch -Np1 -i "$srcdir"/7002_system_av1_support.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ patch -Np1 -i "$srcdir"/0001-Use-remoting-name-for-GDK-application-names.patch
if [[ $_pgo ]] ; then
# https://bugzilla.mozilla.org/show_bug.cgi?id=1516803
@@ -218,7 +222,7 @@ END
}
md5sums=('SKIP'
'f758e064e1463b90878790124f398197'
- '14e0f6237a79b85e60256f4808163160'
+ 'b5f16f03db295778f0123a4e1dd93772'
'5cee310a9040ccc5abcf29742b84aeb8'
'05bb69d25fb3572c618e3adf1ee7b670'
'd7ce23a18da21c05cd756766e177834f'
@@ -233,4 +237,5 @@ md5sums=('SKIP'
'becf6bf9ceb6008401832c855ccadff9'
'79d27c8896913c7d87b148240995ab69'
'f867ae41a722630cc5567e2dcc51676d'
- 'df439e02304d302009c320a540f01dbe')
+ 'df439e02304d302009c320a540f01dbe'
+ '0ffabb81dd8a5fe98bb8afe47d6541d3')
diff --git a/firefox.desktop b/firefox.desktop
index dba01f23a2ca..14f423c86607 100644
--- a/firefox.desktop
+++ b/firefox.desktop
@@ -89,6 +89,7 @@ Terminal=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
StartupNotify=true
+StartupWMClass=firefox
Categories=Network;WebBrowser;
Keywords=web;browser;internet;
Actions=new-window;new-private-window;