summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2019-12-11 23:32:21 +0100
committerBjörn Bidar2019-12-11 23:33:57 +0100
commitf049ac6b7075f4e6d2bdb783dfbe1a0a08ccf864 (patch)
treef018956edc90e72a60995d0467c27adc723f5c91
parent944048a195ea4d485d06c4821e5521865151f466 (diff)
downloadaur-f049ac6b7075f4e6d2bdb783dfbe1a0a08ccf864.tar.gz
urel
- Updated patch to workaround issue GCC/Clang6 not supporting class-temporary#6.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--workaround_dom_indexdb_actorsparent_allignment.patch62
3 files changed, 62 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f728a7afb627..ad00240ce4c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 5 22:06:06 UTC 2019
+# Wed Dec 11 22:33:46 UTC 2019
pkgbase = firefox-kde-opensuse
pkgdesc = Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE
pkgver = 71.0
- pkgrel = 1
+ pkgrel = 2
url = https://build.opensuse.org/package/show/mozilla:Factory/MozillaFirefox
arch = i686
arch = x86_64
@@ -99,7 +99,7 @@ pkgbase = firefox-kde-opensuse
md5sums = d87270bfe02ea30e2fde3fcae5daf18d
md5sums = 0ffabb81dd8a5fe98bb8afe47d6541d3
md5sums = 3016656551d00f4f22dc2eaccc71ee14
- md5sums = f4a8a7f7480c74556ffb8fea3c5fe51a
+ md5sums = 58fb2ea7e65f05c0d1149c8c3fbecf4d
pkgname = firefox-kde-opensuse
diff --git a/PKGBUILD b/PKGBUILD
index 2cfebce11111..86472fdda4ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _pgo=true
_pkgname=firefox
pkgname=$_pkgname-kde-opensuse
pkgver=71.0
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org with OpenSUSE patch, integrate better with KDE"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
@@ -251,4 +251,4 @@ md5sums=('SKIP'
'd87270bfe02ea30e2fde3fcae5daf18d'
'0ffabb81dd8a5fe98bb8afe47d6541d3'
'3016656551d00f4f22dc2eaccc71ee14'
- 'f4a8a7f7480c74556ffb8fea3c5fe51a')
+ '58fb2ea7e65f05c0d1149c8c3fbecf4d')
diff --git a/workaround_dom_indexdb_actorsparent_allignment.patch b/workaround_dom_indexdb_actorsparent_allignment.patch
index e651efce0e13..c403e294a5ae 100644
--- a/workaround_dom_indexdb_actorsparent_allignment.patch
+++ b/workaround_dom_indexdb_actorsparent_allignment.patch
@@ -9,7 +9,7 @@ Bugs:
diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
--- a/dom/indexedDB/ActorsParent.cpp
+++ b/dom/indexedDB/ActorsParent.cpp
-@@ -24311,11 +24311,11 @@
+@@ -24311,11 +24311,11 @@ nsresult ObjectStoreAddOrPutRequestOp::D
// if we allow overwrite or not. By not allowing overwrite we raise
// detectable errors rather than corrupting data.
DatabaseConnection::CachedStatement stmt;
@@ -25,7 +25,59 @@ diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
NS_LITERAL_CSTRING("INTO object_data "
"(object_store_id, key, file_ids, data) "
"VALUES (:") +
-@@ -26076,9 +26076,6 @@
+@@ -25869,11 +25869,8 @@ void Cursor::OpenOp::PrepareIndexKeyCond
+ }
+ }
+
+- const auto& comparisonChar =
+- isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<");
+-
+ mCursor->mContinueToQuery =
+- aQueryStart + NS_LITERAL_CSTRING(" AND sort_column ") + comparisonChar +
++ aQueryStart + NS_LITERAL_CSTRING(" AND sort_column ") + (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) +
+ NS_LITERAL_CSTRING("= :") + kStmtParamNameCurrentKey;
+
+ switch (mCursor->mDirection) {
+@@ -25881,11 +25878,11 @@ void Cursor::OpenOp::PrepareIndexKeyCond
+ case IDBCursor::PREV:
+ mCursor->mContinueQuery =
+ aQueryStart + NS_LITERAL_CSTRING(" AND sort_column ") +
+- comparisonChar + NS_LITERAL_CSTRING("= :") +
++ (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) + NS_LITERAL_CSTRING("= :") +
+ kStmtParamNameCurrentKey + NS_LITERAL_CSTRING(" AND ( sort_column ") +
+- comparisonChar + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey +
++ (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey +
+ NS_LITERAL_CSTRING(" OR ") + aObjectDataKeyPrefix +
+- NS_LITERAL_CSTRING("object_data_key ") + comparisonChar +
++ NS_LITERAL_CSTRING("object_data_key ") + (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) +
+ NS_LITERAL_CSTRING(" :") + kStmtParamNameObjectStorePosition +
+ NS_LITERAL_CSTRING(" ) ");
+
+@@ -25896,12 +25893,12 @@ void Cursor::OpenOp::PrepareIndexKeyCond
+ "(sort_column == :") +
+ kStmtParamNameCurrentKey + NS_LITERAL_CSTRING(" AND ") +
+ aObjectDataKeyPrefix + NS_LITERAL_CSTRING("object_data_key ") +
+- comparisonChar + NS_LITERAL_CSTRING("= :") +
++ (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) + NS_LITERAL_CSTRING("= :") +
+ kStmtParamNameObjectStorePosition +
+ NS_LITERAL_CSTRING(
+ ") OR "
+ "sort_column ") +
+- comparisonChar + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey +
++ (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey +
+ NS_LITERAL_CSTRING(")");
+ break;
+
+@@ -25909,7 +25906,7 @@ void Cursor::OpenOp::PrepareIndexKeyCond
+ case IDBCursor::PREV_UNIQUE:
+ mCursor->mContinueQuery =
+ aQueryStart + NS_LITERAL_CSTRING(" AND sort_column ") +
+- comparisonChar + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey;
++ (isIncreasingOrder ? NS_LITERAL_CSTRING(">") : NS_LITERAL_CSTRING("<")) + NS_LITERAL_CSTRING(" :") + kStmtParamNameCurrentKey;
+ break;
+
+ default:
+@@ -26076,9 +26073,6 @@ nsresult Cursor::OpenOp::DoIndexDatabase
const bool usingKeyRange = mOptionalKeyRange.isSome();
@@ -35,7 +87,7 @@ diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
NS_NAMED_LITERAL_CSTRING(sortColumn, "sort_column");
-@@ -26099,7 +26096,9 @@
+@@ -26099,7 +26093,9 @@ nsresult Cursor::OpenOp::DoIndexDatabase
"object_data.file_ids, "
"object_data.data "
"FROM ") +
@@ -46,7 +98,7 @@ diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
NS_LITERAL_CSTRING(
" AS index_table "
"JOIN object_data "
-@@ -26198,9 +26197,6 @@
+@@ -26198,9 +26194,6 @@ nsresult Cursor::OpenOp::DoIndexKeyDatab
const bool usingKeyRange = mOptionalKeyRange.isSome();
@@ -56,7 +108,7 @@ diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
NS_NAMED_LITERAL_CSTRING(sortColumn, "sort_column");
-@@ -26218,7 +26214,10 @@
+@@ -26218,7 +26211,10 @@ nsresult Cursor::OpenOp::DoIndexKeyDatab
NS_LITERAL_CSTRING(
"object_data_key "
" FROM ") +