summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2023-04-18 05:16:31 +0000
committerJan Alexander Steffens (heftig)2023-04-22 01:30:46 +0000
commitabb99a638e140828736906829d5f9e0f07d726ff (patch)
tree577f335895d50690a4154aaf131cc304b9b2748a
parent608d6b9bb337f0ab26a91dfc9e5c5738ac8d643f (diff)
downloadaur-abb99a638e140828736906829d5f9e0f07d726ff.tar.gz
114.0a1+20230418.1+hdccf044ce33a-1: add patch for 1828315
-rw-r--r--.SRCINFO5
-rw-r--r--D175709.diff48
-rw-r--r--PKGBUILD16
3 files changed, 61 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8e26f927cae..b283cac99d28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-nightly
pkgdesc = Development version of the popular Firefox web browser
- pkgver = 114.0a1+20230416.1+hc061ec6c908e
+ pkgver = 114.0a1+20230418.1+hdccf044ce33a
pkgrel = 1
url = https://www.mozilla.org/firefox/channel/#nightly
arch = x86_64
@@ -53,14 +53,17 @@ pkgbase = firefox-nightly
source = firefox-nightly.desktop
source = identity-icons-brand.svg
source = firefox-install-dir.patch
+ source = D175709.diff
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
sha256sums = SKIP
sha256sums = 7d90a9abacb5cc9870a31323ef31e361f620538c56609001d6d9e789b99b5e97
sha256sums = a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9
sha256sums = c80937969086550237b0e89a02330d438ce17c3764e43cc5d030cb21c2abce5f
+ sha256sums = b5e899806b36fbc9c3667d4b73680306f88d33db2c9ad88af028da182f961901
b2sums = SKIP
b2sums = 3a7c8c5123349ea777ddb8f2f219f6048ce1f213b0a65edaad1fab42380be4e7b5cd27e4667f43786efeb13be827174936c3282607276f167b6eee0fd530af2a
b2sums = 63a8dd9d8910f9efb353bed452d8b4b2a2da435857ccee083fc0c557f8c4c1339ca593b463db320f70387a1b63f1a79e709e9d12c69520993e26d85a3d742e34
b2sums = f76eb72c326f347991133c004b252ed2e037e72a7a436012fb1495668d2b9194d836765b58b01ba0bd9f5c4b888ee5ee715bdb458823a2a7822f1b299f4d1948
+ b2sums = e7efe39b80383f9d3bc7e81c2bebc0b9c8d3c965465a30bf109c360f205e08a4da7b987d10764ec011d3fa3408fd0a1e0703ecf7ca33c662af29ded7a1245836
pkgname = firefox-nightly
diff --git a/D175709.diff b/D175709.diff
new file mode 100644
index 000000000000..1afa89814b5d
--- /dev/null
+++ b/D175709.diff
@@ -0,0 +1,48 @@
+diff --git a/toolkit/xre/glxtest/glxtest.cpp b/toolkit/xre/glxtest/glxtest.cpp
+--- a/toolkit/xre/glxtest/glxtest.cpp
++++ b/toolkit/xre/glxtest/glxtest.cpp
+@@ -28,10 +28,14 @@
+ #include <vector>
+ #include <stdint.h>
+ #include <string.h>
+ #include <stdarg.h>
+
++#ifdef MOZ_WAYLAND
++# include <gdk/gdk.h>
++#endif
++
+ #if defined(MOZ_ASAN) || defined(FUZZING)
+ # include <signal.h>
+ #endif
+
+ #ifdef __SUNPRO_CC
+@@ -45,10 +49,11 @@
+ #endif
+
+ #include <vector>
+ #include <sys/wait.h>
+ #include "mozilla/ScopeExit.h"
++#include "mozilla/Types.h"
+
+ #ifdef MOZ_X11
+ // stuff from glx.h
+ typedef struct __GLXcontextRec* GLXContext;
+ typedef XID GLXPixmap;
+@@ -1097,10 +1102,16 @@
+ break;
+ case 'f':
+ glxtest_out_pipe = atoi(optarg);
+ break;
+ case 'h':
++#ifdef MOZ_WAYLAND
++ // Dummy call to mozgtk to prevent the linker from removing
++ // the dependency with --as-needed.
++ // see toolkit/library/moz.build for details.
++ gdk_display_get_default();
++#endif
+ PrintUsage();
+ return 0;
+ default:
+ break;
+ }
+
diff --git a/PKGBUILD b/PKGBUILD
index 56fbd816be76..578852c6092f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox-nightly
-pkgver=114.0a1+20230416.1+hc061ec6c908e
+pkgver=114.0a1+20230418.1+hdccf044ce33a
pkgrel=1
pkgdesc="Development version of the popular Firefox web browser"
url="https://www.mozilla.org/firefox/channel/#nightly"
@@ -69,6 +69,7 @@ source=(
$pkgname.desktop
identity-icons-brand.svg
firefox-install-dir.patch
+ D175709.diff
)
validpgpkeys=(
'14F26682D0916CDD81E37B6D61B7B526D98F0353' # Mozilla Software Releases <release@mozilla.com>
@@ -76,11 +77,13 @@ validpgpkeys=(
sha256sums=('SKIP'
'7d90a9abacb5cc9870a31323ef31e361f620538c56609001d6d9e789b99b5e97'
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9'
- 'c80937969086550237b0e89a02330d438ce17c3764e43cc5d030cb21c2abce5f')
+ 'c80937969086550237b0e89a02330d438ce17c3764e43cc5d030cb21c2abce5f'
+ 'b5e899806b36fbc9c3667d4b73680306f88d33db2c9ad88af028da182f961901')
b2sums=('SKIP'
'3a7c8c5123349ea777ddb8f2f219f6048ce1f213b0a65edaad1fab42380be4e7b5cd27e4667f43786efeb13be827174936c3282607276f167b6eee0fd530af2a'
'63a8dd9d8910f9efb353bed452d8b4b2a2da435857ccee083fc0c557f8c4c1339ca593b463db320f70387a1b63f1a79e709e9d12c69520993e26d85a3d742e34'
- 'f76eb72c326f347991133c004b252ed2e037e72a7a436012fb1495668d2b9194d836765b58b01ba0bd9f5c4b888ee5ee715bdb458823a2a7822f1b299f4d1948')
+ 'f76eb72c326f347991133c004b252ed2e037e72a7a436012fb1495668d2b9194d836765b58b01ba0bd9f5c4b888ee5ee715bdb458823a2a7822f1b299f4d1948'
+ 'e7efe39b80383f9d3bc7e81c2bebc0b9c8d3c965465a30bf109c360f205e08a4da7b987d10764ec011d3fa3408fd0a1e0703ecf7ca33c662af29ded7a1245836')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -122,6 +125,9 @@ prepare() {
# Change install dir from 'firefox' to 'firefox-nightly'
patch -Np1 -i ../firefox-install-dir.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1828315
+ patch -Np1 -i ../D175709.diff
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -171,10 +177,6 @@ build() {
export MOZ_ENABLE_FULL_SYMBOLS=1
export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=pip
- # --as-needed causes glxtest to be underlinked
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1828315
- export LDFLAGS="${LDFLAGS/,--as-needed/}"
-
# LTO needs more open files
ulimit -n 4096