summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matias2022-03-31 14:35:21 -0300
committerPaulo Matias2022-03-31 14:35:21 -0300
commit577050b22552795be4cb271561eb7b6b26227b66 (patch)
treecc1b0437a9e5c599e5c3f74d1ff67c6a4b48b646
parent0f35f34cd7fb2cc93e1f3d86381fc1ebbfe4ff9a (diff)
downloadaur-577050b22552795be4cb271561eb7b6b26227b66.tar.gz
update patch for bug 1762050
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--bug1762050.diff13
3 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60032e2dc1c4..a2c8c208248d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -62,6 +62,6 @@ pkgbase = firefox-wayland-hg
sha256sums = SKIP
sha256sums = a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33
sha256sums = 9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797
- sha256sums = c5f8e7dd7197f3f505875a256d80aefa632f8cfb1f38e6b7748db89eaf3eabd7
+ sha256sums = 0bbfdc3765d8495d0dae918cf1d3a532346ff63f8b8d127b74ff075be87594ca
pkgname = firefox-wayland-hg
diff --git a/PKGBUILD b/PKGBUILD
index 77fdf99db952..2654631721da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,7 @@ source=("hg+$_repo#revision=autoland"
sha256sums=('SKIP'
'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- 'c5f8e7dd7197f3f505875a256d80aefa632f8cfb1f38e6b7748db89eaf3eabd7')
+ '0bbfdc3765d8495d0dae918cf1d3a532346ff63f8b8d127b74ff075be87594ca')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
diff --git a/bug1762050.diff b/bug1762050.diff
index 91c45c5d1b8a..721d11d52308 100644
--- a/bug1762050.diff
+++ b/bug1762050.diff
@@ -13,6 +13,19 @@ diff --git a/python/mozbuild/mozbuild/build_commands.py b/python/mozbuild/mozbui
return status
# Packaging the instrumented build is required to get the jarlog
+@@ -206,11 +207,11 @@
+ pgo_env["LLVM_PROFDATA"] = instr.config_environment.substs.get(
+ "LLVM_PROFDATA"
+ )
+ pgo_env["JARLOG_FILE"] = mozpath.join(orig_topobjdir, "jarlog/en-US.log")
+ pgo_cmd = [
+- instr.virtualenv_manager.python_path,
++ command_context.virtualenv_manager.python_path,
+ mozpath.join(command_context.topsrcdir, "build/pgo/profileserver.py"),
+ ]
+ subprocess.check_call(pgo_cmd, cwd=instr.topobjdir, env=pgo_env)
+
+ # Set the default build to MOZ_PROFILE_USE
diff --git a/python/mozbuild/mozbuild/controller/building.py b/python/mozbuild/mozbuild/controller/building.py
--- a/python/mozbuild/mozbuild/controller/building.py
+++ b/python/mozbuild/mozbuild/controller/building.py