summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Cofer2019-04-23 11:46:51 -0400
committerDevin Cofer2019-04-23 11:46:51 -0400
commit5d653c6e11c5515a14a07ab5bc080e99205e1fb5 (patch)
tree2a8bdf00e882a3d5eaf2532d7e0dcdf59bf0f075
parentaf6e055642d61e9b8478a79f01b1b935283b2207 (diff)
downloadaur-5d653c6e11c5515a14a07ab5bc080e99205e1fb5.tar.gz
Cosmetic, upload-symbol-archive from [extra]
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--upload-symbol-archive24
3 files changed, 26 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3afd64d3a2e7..ad951339741b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-wayland-hg
pkgdesc = Standalone web browser from mozilla.org - Wayland build of mozilla-unified hg
- pkgver = r525597.b21620648d31
+ pkgver = r525913.43a6ba47356a
pkgrel = 1
url = https://www.mozilla.org/firefox/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ee67cc4df7ab..fa7d91fc837c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=firefox-wayland-hg
_pkgname=firefox
-pkgver=r525597.b21620648d31
+pkgver=r525913.43a6ba47356a
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org - Wayland build of mozilla-unified hg"
arch=(x86_64)
@@ -72,7 +72,6 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
-
ac_add_options --enable-lto
export MOZ_PGO=1
export CC=clang
diff --git a/upload-symbol-archive b/upload-symbol-archive
new file mode 100644
index 000000000000..5b61750d2e9d
--- /dev/null
+++ b/upload-symbol-archive
@@ -0,0 +1,24 @@
+#!/bin/bash -e
+
+die() {
+ echo >&2 "$@"
+ exit 1
+}
+
+(( $# >= 2 )) || die "Usage: $0 TOKEN-FILE SYMBOL-ARCHIVE..."
+token="$1"
+shift
+
+[[ -f $token && -s $token ]] || die "Invalid TOKEN-FILE ${token@Q}"
+
+for zip; do
+ [[ $(file -Ebi "$zip") == application/zip* ]] || die "Invalid SYMBOL-ARCHIVE ${zip@Q}"
+done
+
+for zip; do
+ echo >&2 "Uploading ${zip@Q} ..."
+ curl -X POST -H "Auth-Token: $(<"$token")" -F "${zip##*/}=@$zip" \
+ --retry 4 --retry-connrefused --connect-timeout 120 \
+ https://symbols.mozilla.org/upload/
+ echo
+done