summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-29 09:13:27 -0800
committerGitHub2023-12-29 09:13:27 -0800
commite1e27df0764cb180b72990baa3da926e1be8e6d5 (patch)
tree02c3713f6ad5fd72a9dd4f9ac5ed9fcff9286322
parent50530278f44947b8353de3574d229d8c1b60f26a (diff)
downloadaur-e1e27df0764cb180b72990baa3da926e1be8e6d5.tar.gz
Update upload script, modify config, enable PGO (#10)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
-rwxr-xr-x[-rw-r--r--]upload-symbol-archive12
3 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e5b5a7e0954..cded0b1ddd6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-wayland-hg
pkgdesc = Standalone web browser from mozilla.org - mozilla-unified hg, nightly branding, targeting wayland
- pkgver = 123.0a1+20231222.2+h8481bdfea5c4
+ pkgver = 123.0a1+20231228.1+ha0075cc44476
pkgrel = 1
url = https://www.mozilla.org/firefox/channel/#nightly
arch = x86_64
@@ -27,6 +27,8 @@ pkgbase = firefox-wayland-hg
makedepends = wasi-libc++abi
makedepends = yasm
makedepends = zip
+ makedepends = weston
+ makedepends = xwayland-run
depends = dbus
depends = ffmpeg
depends = gtk3
@@ -41,10 +43,9 @@ pkgbase = firefox-wayland-hg
depends = pipewire
depends = ttf-font
depends = zlib
- optdepends = hunspell-en_US: Spell checking, American English
+ optdepends = hunspell-dictionary: Spell checking
optdepends = libnotify: Notification integration
optdepends = networkmanager: Location detection via available WiFi networks
- optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
optdepends = xdg-desktop-portal: Screensharing with Wayland
provides = firefox-nightly
diff --git a/PKGBUILD b/PKGBUILD
index db9b01dd34af..84c7117dc09b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
## options
# three-stage profile-guided optimization
-: ${_build_pgo:=false}
+: ${_build_pgo:=true}
# use mozilla-central repo, instead of mozilla-unified
: ${_build_nightly:=false}
@@ -20,15 +20,14 @@
# modify package name
: ${_build_hg:=true}
-# -----
[[ "${_build_nightly::1}" == "t" ]] && _pkgtype+="-nightly"
[[ "${_build_wayland::1}" == "t" ]] && _pkgtype+="-wayland"
[[ "${_build_hg::1}" == "t" ]] && _pkgtype+="-hg"
-## -----
+## basic info
pkgname="firefox${_pkgtype:-}"
_pkgname=firefox-nightly
-pkgver=123.0a1+20231222.2+h8481bdfea5c4
+pkgver=123.0a1+20231228.1+ha0075cc44476
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
url="https://www.mozilla.org/firefox/channel/#nightly"
@@ -76,10 +75,9 @@ makedepends=(
zip
)
optdepends=(
- 'hunspell-en_US: Spell checking, American English'
+ 'hunspell-dictionary: Spell checking'
'libnotify: Notification integration'
'networkmanager: Location detection via available WiFi networks'
- 'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech'
'xdg-desktop-portal: Screensharing with Wayland'
)
@@ -192,7 +190,10 @@ mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
ac_add_options --prefix=/usr
ac_add_options --enable-release
ac_add_options --enable-hardening
+ac_add_options --enable-optimize=-O3
+ac_add_options --enable-lto=cross,full
ac_add_options --enable-rust-simd
+ac_add_options --enable-wasm-simd
ac_add_options --enable-linker=lld
ac_add_options --disable-elf-hack
ac_add_options --disable-bootstrap
@@ -281,10 +282,7 @@ END
./mach clobber
echo "Building optimized browser..."
- cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-optimize=-O3
-ac_add_options --enable-lto=cross
-END
+ cat >.mozconfig ../mozconfig
if [[ -s merged.profdata ]] ; then
stat -c "Profile data found (%s bytes)" merged.profdata
@@ -304,10 +302,7 @@ END
./mach build
else
echo "Building browser..."
- cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-optimize=-O3
-ac_add_options --enable-lto=cross
-END
+ cat >.mozconfig ../mozconfig
./mach build
fi
@@ -338,6 +333,12 @@ pref("browser.gnome-search-provider.enabled", true);
// Enable JPEG XL images
pref("image.jxl.enabled", true);
+
+// Prevent about:config warning
+pref("browser.aboutConfig.showWarning", false);
+
+// Prevent telemetry notification
+pref("services.settings.main.search-telemetry-v2.last_check", $(date +%s));
END
local distini="$pkgdir/usr/lib/$_pkgname/distribution/distribution.ini"
@@ -378,7 +379,7 @@ END
# Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/lib/$_pkgname/firefox-bin"
+ ln -srfv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/lib/$_pkgname/${_pkgname%-*}-bin"
# Use system certificates
local nssckbi="$pkgdir/usr/lib/$_pkgname/libnssckbi.so"
diff --git a/upload-symbol-archive b/upload-symbol-archive
index a31f382bb89e..0402c7cf61d0 100644..100755
--- a/upload-symbol-archive
+++ b/upload-symbol-archive
@@ -11,15 +11,15 @@ shift
[[ -f $token && -s $token ]] || die "Invalid TOKEN-FILE ${token@Q}"
-for zip; do
- [[ $(file -Ebi "$zip") == application/zip* ]] || die "Invalid SYMBOL-ARCHIVE ${zip@Q}"
+for archive; do
+ [[ $(file -Ebi "$archive") == application/zstd* ]] || die "Invalid SYMBOL-ARCHIVE ${archive@Q}"
done
-for zip; do
- echo >&2 "Uploading ${zip@Q} ..."
- curl -X POST -H "Auth-Token: $(<"$token")" -F "${zip##*/}=@$zip" \
+for archive; do
+ echo >&2 "Uploading ${archive@Q} ..."
+ curl -X POST -H "Auth-Token: $(<"$token")" -F "${archive##*/}=@$archive" \
--retry 4 --retry-connrefused --connect-timeout 120 \
https://symbols.mozilla.org/upload/
echo
- mv -v "$zip" "$zip.uploaded"
+ mv -v "$archive" "$archive.uploaded"
done