summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Cofer2019-07-31 00:12:17 -0400
committerDevin Cofer2019-07-31 00:12:17 -0400
commitf2304f0369b2d8494e4d033ab6cb1324f00f4d77 (patch)
tree638a6d96f4a8fb84cc043132b91549bdbae07f48
parentf2636378a162aa2fd5bb031b46a1b4e5a18990c7 (diff)
downloadaur-f2304f0369b2d8494e4d033ab6cb1324f00f4d77.tar.gz
Updates to match [extra]
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch56
-rw-r--r--PKGBUILD10
-rw-r--r--firefox.desktop2
4 files changed, 69 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b15c94fc9d..bfcfffaeaf1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-wayland-hg
pkgdesc = Standalone web browser from mozilla.org - Wayland build of mozilla-unified hg
- pkgver = r530539.fe795231a4af
+ pkgver = r542876+.4d8cee124c4e+
pkgrel = 1
url = https://www.mozilla.org/firefox/
arch = x86_64
@@ -50,10 +50,12 @@ pkgbase = firefox-wayland-hg
options = !makeflags
options = !strip
source = hg+https://hg.mozilla.org/mozilla-unified
+ source = 0001-Use-remoting-name-for-GDK-application-names.patch
source = firefox.desktop
source = firefox-symbolic.svg
sha256sums = SKIP
- sha256sums = 4a783dca1f88e003c72f32d22719a0915f3fa576adbc492240e7cc250246ce10
+ sha256sums = ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894
+ sha256sums = a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33
sha256sums = 9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797
pkgname = firefox-wayland-hg
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
new file mode 100644
index 000000000000..8cc378636c19
--- /dev/null
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -0,0 +1,56 @@
+From 1cab10b39cfda068100cab8c598f1ca0f50e4131 Mon Sep 17 00:00:00 2001
+Message-Id: <1cab10b39cfda068100cab8c598f1ca0f50e4131.1553597287.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Mon, 25 Mar 2019 20:30:11 +0100
+Subject: [PATCH] Use remoting name for GDK application names
+
+---
+ toolkit/xre/nsAppRunner.cpp | 6 +-----
+ widget/gtk/nsAppShell.cpp | 7 +++----
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+index 0b808ef215f06..28911c0ffeaec 100644
+--- a/toolkit/xre/nsAppRunner.cpp
++++ b/toolkit/xre/nsAppRunner.cpp
+@@ -3728,11 +3728,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+ // consistently.
+
+ // Set program name to the one defined in application.ini.
+- {
+- nsAutoCString program(gAppData->name);
+- ToLowerCase(program);
+- g_set_prgname(program.get());
+- }
++ g_set_prgname(gAppData->remotingName);
+
+ // Initialize GTK here for splash.
+
+diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
+index 0686ff814916b..ae4a4ea55f420 100644
+--- a/widget/gtk/nsAppShell.cpp
++++ b/widget/gtk/nsAppShell.cpp
+@@ -24,6 +24,7 @@
+ # include "WakeLockListener.h"
+ #endif
+ #include "gfxPlatform.h"
++#include "nsAppRunner.h"
+ #include "ScreenHelperGTK.h"
+ #include "HeadlessScreenHelper.h"
+ #include "mozilla/widget/ScreenManager.h"
+@@ -171,10 +172,8 @@ nsresult nsAppShell::Init() {
+ // option when program uses gdk_set_program_class().
+ //
+ // See https://bugzilla.gnome.org/show_bug.cgi?id=747634
+- nsAutoString brandName;
+- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
+- if (!brandName.IsEmpty()) {
+- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
++ if (gAppData) {
++ gdk_set_program_class(gAppData->remotingName);
+ }
+ }
+
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 44020e102010..1dc980f48011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=firefox-wayland-hg
_pkgname=firefox
-pkgver=r530539.fe795231a4af
+pkgver=r542876+.4d8cee124c4e+
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org - Wayland build of mozilla-unified hg"
arch=(x86_64)
@@ -29,9 +29,11 @@ _repo=https://hg.mozilla.org/mozilla-unified
conflicts=('firefox')
provides=('firefox')
source=("hg+$_repo"
+ 0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop $_pkgname-symbolic.svg)
sha256sums=('SKIP'
- '4a783dca1f88e003c72f32d22719a0915f3fa576adbc492240e7cc250246ce10'
+ 'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
+ 'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -55,6 +57,9 @@ prepare() {
mkdir mozbuild
cd mozilla-unified
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -84,6 +89,7 @@ export RANLIB=llvm-ranlib
ac_add_options --enable-official-branding
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
+ac_add_options --with-unsigned-addon-scopes=app,system
export MOZILLA_OFFICIAL=1
export MOZ_APP_REMOTINGNAME=${_pkgname//-/}
export MOZ_TELEMETRY_REPORTING=1
diff --git a/firefox.desktop b/firefox.desktop
index 8775094b0224..da9c3a843bf3 100644
--- a/firefox.desktop
+++ b/firefox.desktop
@@ -119,7 +119,7 @@ X-MultipleArgs=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;
StartupNotify=true
-StartupWMClass=Firefox
+StartupWMClass=firefox
Categories=Network;WebBrowser;
Actions=new-window;new-private-window;