summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-03-13 13:32:02 -0700
committerMike Swanson2014-03-13 13:32:02 -0700
commitff6adaad3d357f0b9b1d9c43a25f9450f9719b44 (patch)
tree120ecf3e406a4a458019601b87413e3cd643196b
parent708d5daa7f993ce0062fe4180384df671fd49662 (diff)
downloadaur-ff6adaad3d357f0b9b1d9c43a25f9450f9719b44.tar.gz
Update Firestorm to 4.6.1.40478-1
Fairly significant semi-rewrite of the PKGBUILD. Firestorm upstream now officially supports 64-bit and hopefully this PKGBUILD is less cobbled together than previously.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD86
-rwxr-xr-x[-rw-r--r--]firestorm.launcher0
3 files changed, 73 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c38e8a3c89b4..81de13343e53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firestorm-bin
- pkgdesc = Second Life is a 3-D virtual world entirely built and owned by its residents. Firestorm is alternative viewer for secondlife (native 32bit)
- pkgver = 4.5.1.38838
+ pkgdesc = Firestorm is a feature-packed third-party viewer for Second Life.
+ pkgver = 4.6.1.40478
pkgrel = 1
url = http://www.firestormviewer.org/
install = firestorm.install
@@ -11,20 +11,24 @@ pkgbase = firestorm-bin
depends = gnome-vfs
depends = gtk2
depends = libpng
+ depends = libxml2
depends = dbus-glib
depends = libidn
depends = sdl
depends = mesa
+ depends = apr-util
+ depends = libgl
+ depends = libjpeg-turbo
+ depends = nss
+ depends = glu
+ depends = pangox-compat
+ optdepends = libpulse: for PulseAudio support
+ optdepends = alsa-lib: for ALSA support
+ optdepends = nvidia-utils: for NVIDIA support
+ optdepends = flashplugin: for inworld Flash support
optdepends = gstreamer0.10: For video support - may need good, bad and ugly plugins
+ optdepends = freealut: for OpenAL support
options = !strip
- source = http://downloads.phoenixviewer.com/Linux/Phoenix_Firestorm-Beta_i686_4.5.1.38838SL.tar.bz2
- source = firestorm.install
- source = firestorm.desktop
- source = firestorm.launcher
- sha256sums = 78d2d08e16a4ebcef23120d12130ccc12030b6cb0971dbdd517f34a7bab6b84e
- sha256sums = cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3
- sha256sums = 6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1
- sha256sums = b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530
pkgname = firestorm-bin
diff --git a/PKGBUILD b/PKGBUILD
index 30eeea243dc1..4eed3199696b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,87 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=firestorm-bin
-pkgver=4.5.1.38838
+pkgver=4.6.1.40478
pkgrel=1
-pkgdesc="Second Life is a 3-D virtual world entirely built and owned by its residents. Firestorm is alternative viewer for secondlife (native 32bit)"
+pkgdesc="Firestorm is a feature-packed third-party viewer for Second Life."
url="http://www.firestormviewer.org/"
license=('GPL')
-depends=('openal' 'gnome-vfs' 'gtk2' 'libpng' 'dbus-glib' 'libidn' 'sdl' 'mesa')
-optdepends=('gstreamer0.10: For video support - may need good, bad and ugly plugins')
-[ "$CARCH" = "x86_64" ] && depends=('lib32-gtk2' 'lib32-libpng' 'lib32-openal' 'lib32-dbus-glib' 'lib32-libidn' 'lib32-sdl' 'lib32-mesa')
-[ "$CARCH" = "x86_64" ] && optdepends=('lib32-gstreamer0.10: For video support - may need good, bad and ugly plugins' 'lib32-nvidia-utils: GL support for NVIDIA drivers')
+depends=(
+ 'openal' 'gnome-vfs' 'gtk2' 'libpng' 'libxml2' 'dbus-glib'
+ 'libidn' 'sdl' 'mesa' 'apr-util' 'libgl' 'libjpeg-turbo'
+ 'nss' 'glu' 'pangox-compat'
+)
+optdepends=(
+ 'libpulse: for PulseAudio support'
+ 'alsa-lib: for ALSA support'
+ 'nvidia-utils: for NVIDIA support'
+ 'flashplugin: for inworld Flash support'
+ 'gstreamer0.10: For video support - may need good, bad and ugly plugins'
+ 'freealut: for OpenAL support'
+)
arch=('i686' 'x86_64')
install=firestorm.install
options=(!strip)
-source=("http://downloads.phoenixviewer.com/Linux/Phoenix_Firestorm-Beta_i686_${pkgver}SL.tar.bz2"
- 'firestorm.install'
- 'firestorm.desktop'
- 'firestorm.launcher')
-sha256sums=('78d2d08e16a4ebcef23120d12130ccc12030b6cb0971dbdd517f34a7bab6b84e'
- 'cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3'
- '6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1'
- 'b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530')
+if [ "$CARCH" = "i686" ]; then
+ source=(
+ "http://downloads.firestormviewer.org/linux/Phoenix_Firestorm-Release_${CARCH}_$pkgver.tar.bz2"
+ "firestorm.instasll"
+ "firestorm.desktop"
+ "firestorm.launcher"
+ )
+ sha256sums=(
+ 'ea91ef1b8d8f9f9f095b45d947c881a04593a4961aa43db9e4b38ffccc316b34'
+ 'cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3'
+ '6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1'
+ 'b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530'
+ )
+elif [ "$CARCH" = "x86_64" ]; then
+ source=(
+ "http://downloads.firestormviewer.org/linux/Phoenix_FirestormOS-Beta_${CARCH}_$pkgver.tar.bz2"
+ 'firestorm.install'
+ 'firestorm.desktop'
+ 'firestorm.launcher'
+ )
+ sha256sums=(
+ 'bdd60d6fc27dbb70b95efdb0809e1afa0545759aa5e149bb40fd4102becc9e0b'
+ 'cd919be5e2d28ff86e9b51ffe1076ba8c13acf9c0953fc2f4bb78fe7e79cdbb3'
+ '6dffebc474fd98d23bf8d9f4a7592795642dbddf3a0b585f89d25ff11ae15cc1'
+ 'b2ce32d268f76f4324807d50c4098a3480b489ec447133ce8d9b9c4a7bc05530'
+ )
+fi
package() {
- cd "${srcdir}"
+ cd "$srcdir"
# Rename Data Directory
- mv Phoenix_Firestorm-Beta_i686_${pkgver}/ firestorm
+ if [ "$CARCH" = "i686" ]; then
+ mv Phoenix_Firestorm-Release_${CARCH}_$pkgver firestorm
+ elif [ "$CARCH" = "x86_64" ]; then
+ mv Phoenix_FirestormOS-Beta_${CARCH}_$pkgver firestorm
+ fi
# Fix fontconfig >= 2.9.0 issue
ln -si libfontconfig.so.1.4.4 firestorm/lib/libfontconfig.so.1
# Install Desktop File
- install -D -m644 "${srcdir}"/firestorm.desktop \
- "${pkgdir}"/usr/share/applications/firestorm.desktop
+ install -D -m644 "$srcdir"/firestorm.desktop \
+ "$pkgdir"/usr/share/applications/firestorm.desktop
# Install Icon File
- install -D -m644 "${srcdir}"/firestorm/firestorm_icon.png \
- "${pkgdir}"/usr/share/pixmaps/firestorm_icon.png
+ install -D -m644 "$srcdir"/firestorm/firestorm_icon.png \
+ "$pkgdir"/usr/share/pixmaps/firestorm_icon.png
# Install Launcher
- install -D -m755 "${srcdir}"/firestorm.launcher \
- "${pkgdir}"/usr/bin/firestorm
+ install -D -m755 "$srcdir"/firestorm.launcher \
+ "$pkgdir"/usr/bin/firestorm
# Move Data to Destination Directory
- install -d "${pkgdir}"/opt/
- mv firestorm/ "${pkgdir}"/opt/
+ install -d "$pkgdir"/opt/
+ mv firestorm/ "$pkgdir"/opt/
# Change Permissions of files to root:games
- chown -R root:games "${pkgdir}"/opt/firestorm
- chmod -R g+r "${pkgdir}"/opt/firestorm
+ chown -R root:games "$pkgdir"/opt/firestorm
+ chmod -R g+r "$pkgdir"/opt/firestorm
# Make Binary Group-Executable
- chmod g+x "${pkgdir}"/opt/firestorm/firestorm
+ chmod g+x "$pkgdir"/opt/firestorm/firestorm
}
diff --git a/firestorm.launcher b/firestorm.launcher
index 94987c07abd9..94987c07abd9 100644..100755
--- a/firestorm.launcher
+++ b/firestorm.launcher