summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormasutu2015-06-24 00:27:34 +0200
committermasutu2015-06-24 00:27:34 +0200
commit6b16996bee1318a2df0dbc3e2bf4f70f811d6bfc (patch)
tree1ff3d45357890e368f8aceed6f6310ce7bb4c597
downloadaur-6b16996bee1318a2df0dbc3e2bf4f70f811d6bfc.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--fityk.install12
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fdc789676a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = fityk
+ pkgdesc = A program for nonlinear fitting of analytical functions to data.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://fityk.nieto.pl/
+ install = fityk.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = python2-sphinx
+ makedepends = swig
+ depends = lua
+ depends = wxgtk
+ depends = xylib>=1.4
+ options = !libtool
+ source = https://github.com/wojdyr/fityk/releases/download/v1.3.0/fityk-1.3.0.tar.bz2
+ md5sums = d533e0ae646d9066c46b6d90885dc4b5
+
+pkgname = fityk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce4307d66af6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: masutu < masutu dot arch at gmail dot com >
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Cuneyt Unlu <unlucu AT gmail.com>
+
+pkgname=fityk
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A program for nonlinear fitting of analytical functions to data."
+arch=(i686 x86_64)
+url="http://fityk.nieto.pl/"
+license=('GPL')
+depends=('lua' 'wxgtk' 'xylib>=1.4')
+makedepends=('boost' 'python2-sphinx' 'swig')
+options=(!libtool)
+install=fityk.install
+source="https://github.com/wojdyr/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
+md5sums=('d533e0ae646d9066c46b6d90885dc4b5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's#sphinx-build#sphinx-build2#' doc/Makefile
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/fityk.install b/fityk.install
new file mode 100644
index 000000000000..3bfc751b64fe
--- /dev/null
+++ b/fityk.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}