summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFGHNBB2023-09-03 02:35:03 +0800
committerFGHNBB2023-09-03 02:35:03 +0800
commit22f2b75b0e9fa75e96d9eae4c263a5d42fd32c1b (patch)
tree82b81782f3932e8776db18be4da9de4b990ae108
downloadaur-fix-gs-keyboard-function-key.tar.gz
Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ec4063b987f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fix-gs-keyboard-function-key
+ pkgdesc = 修复高斯键盘在Arch下Function键输入的问题 (Fixed the problem that Gaosi keyboard entered the Function key under Arch)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/FGHNBB/fix-gs-keyboard-function-key
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ source = git+https://github.com/FGHNBB/fix-gs-keyboard-function-key.git
+ sha256sums = SKIP
+
+pkgname = fix-gs-keyboard-function-key
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce8b0e824299
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: slot_FGHNBB <Hidden>
+pkgname=fix-gs-keyboard-function-key
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="修复高斯键盘在Arch下Function键输入的问题 (Fixed the problem that Gaosi keyboard entered the Function key under Arch)"
+arch=("x86_64")
+url="https://github.com/FGHNBB/fix-gs-keyboard-function-key"
+license=("GPL")
+makedepends=("git" "cmake")
+source=("git+https://github.com/FGHNBB/fix-gs-keyboard-function-key.git")
+sha256sums=("SKIP")
+
+build() {
+ mkdir -p "$srcdir/fix-gs-keyboard-function-key/build"
+ cd "$srcdir/fix-gs-keyboard-function-key/build"
+ msg2 "Using Cmake to Build"
+ cmake ..
+ make
+ msg2 "Build Done"
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/fix-gs-keyboard-function-key/build/fix-gs-keyboard-function-key $pkgdir/usr/bin/fix-gs-keyboard-function-key
+ chmod +x $pkgdir/usr/bin/fix-gs-keyboard-function-key
+ msg2 "Installation Done! Please use 'sudo fix-gs-keyboard-function-key install' to install the patch"
+}