summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMehrad Mahmoudian2023-11-10 16:16:21 +0200
committerMehrad Mahmoudian2023-11-10 16:16:21 +0200
commitee394198973f2d1a2e1bed6cdbc07ffbfeefafbc (patch)
tree46f322f823ac8241e723e6d0c731242e26572a4d
parentac14204f9fe925fe720a597800133c2e9b29bfbe (diff)
downloadaur-flameshot-git.tar.gz
[update] instructions are improved
-rwxr-xr-xMakefile21
-rw-r--r--PKGBUILD2
2 files changed, 16 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 0f7afdf9f3e1..e2f3fea4992b 100755
--- a/Makefile
+++ b/Makefile
@@ -39,15 +39,24 @@ endif
all help:
$(info --------------------------------------------------------------------------------)
$(info Available arguments:)
- $(info - "make test" to test the PKGBUILD file)
- $(info - "make build" to build the PKGBUILD file just to see if it compiled fine)
- $(info - "make deps" to check if dependencies are installed)
- $(info - "make clean" to clean the left-over files)
- $(info - "make patch" to create a patch to be submitted as contribution)
- $(info - "make help" to show this help)
+ $(info - $(COLOR_MESSAGE)"make test"$(COLOR_RESET) to test the PKGBUILD file)
+ $(info - $(COLOR_MESSAGE)"make build"$(COLOR_RESET) to build the PKGBUILD file just to see if it compiled fine)
+ $(info - $(COLOR_MESSAGE)"make deps"$(COLOR_RESET) to check if dependencies are installed)
+ $(info - $(COLOR_MESSAGE)"make clean"$(COLOR_RESET) to clean the left-over files)
+ $(info - $(COLOR_MESSAGE)"make patch"$(COLOR_RESET) to create a patch to be submitted as contribution)
+ $(info - $(COLOR_MESSAGE)"make help"$(COLOR_RESET) to show this help)
$(info )
$(info You can turn off colorizing the make output by $(COLOR_MESSAGE)"COLOR=FALSE"$(COLOR_RESET))
$(info --------------------------------------------------------------------------------)
+ $(info The order of use:)
+ $(info 1. $(COLOR_MESSAGE)"make deps"$(COLOR_RESET))
+ $(info 2. apply the changes you think necessary)
+ $(info 3. $(COLOR_MESSAGE)"make build"$(COLOR_RESET))
+ $(info 4. fix possible errors and repleat step 3 and 4 until there is no error)
+ $(info 5. $(COLOR_MESSAGE)"make test"$(COLOR_RESET))
+ $(info 6. fix possible errors and repleat step 5 and 6 until there is no error)
+ $(info 7. $(COLOR_MESSAGE)"make patch"$(COLOR_RESET) to create the patch, and then submit it for maintainers)
+ $(info --------------------------------------------------------------------------------)
@:
deps:
diff --git a/PKGBUILD b/PKGBUILD
index 30b0b97ed818..b2700b16638d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,7 +71,7 @@ md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- # Get the version number.
+ # Get the version number. Suggested in https://gitlab.archlinux.org/pacman/pacman/blob/master/proto/PKGBUILD-vcs.proto#L49
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}