summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Berry2019-11-13 00:35:14 +0000
committerColin Berry2019-11-13 00:35:14 +0000
commit910f357be6e17a12cbee8bdf1750183311d5ed8a (patch)
tree8c94e262ff4e0ad6754194b2ea28e0dd5081d7e3
downloadaur-910f357be6e17a12cbee8bdf1750183311d5ed8a.tar.gz
Flashpoint Infinity 6.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..967306d56357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = flashpoint-bin
+ pkgdesc = Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only.
+ pkgver = 6.3
+ pkgrel = 1.0
+ url = http://bluemaxima.org/flashpoint/
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ depends = nss>=3.0
+ depends = gtk3
+ source = https://bluepload.unstable.life/selif/flashpoint-linux-x64-20191112.tar.gz
+ md5sums = 313d585f60cb4d7a0c834e0ff693729c
+
+pkgname = flashpoint-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b88a556cfd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : Colin Berry <colinb969@gmail.com>
+pkgname=flashpoint-bin
+pkgver=6.3
+pkgrel=1.0
+pkgdesc="Launcher for BlueMaxima's Flashpoint - Does not include data files! - Launcher software only."
+arch=('x86_64')
+url="http://bluemaxima.org/flashpoint/"
+license=('MIT')
+depends=('nss>=3.0'
+ 'gtk3')
+makedepends=('npm')
+source=('https://bluepload.unstable.life/selif/flashpoint-linux-x64-20191112.tar.gz')
+md5sums=('313d585f60cb4d7a0c834e0ff693729c')
+
+package(){
+ # Extract package data
+ tar xf flashpoint-linux-x64-20191112.tar.gz -C "${pkgdir}"
+
+ # Symlink exec
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/flashpoint/FlashpointLauncher" "${pkgdir}/usr/bin/flashpoint"
+
+ # License
+ install -Dm644 $pkgdir/opt/flashpoint/licenses/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file