summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052025-04-06 07:16:26 +0800
committerzxp198210052025-04-06 07:16:26 +0800
commitd486bf7aa43a5317d23ead42315cfaa3321e6a02 (patch)
tree1210830fa2c4157aabbf09d6497a1f3ce3101296
parent7c7ca7a26490d5e2d26664dcc16f81785564d381 (diff)
downloadaur-d486bf7aa43a5317d23ead42315cfaa3321e6a02.tar.gz
update to fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--flashpoint.desktop12
3 files changed, 32 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc4e7cfb7468..0f681918032e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = flashpoint-bin
pkgdesc = Launcher for BlueMaxima's Flashpoint - Infinity Edition.(Prebuilt version)
pkgver = 14.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://flashpointarchive.org
arch = x86_64
license = LicenseRef-freeware
- makedepends = gendesk
- makedepends = p7zip
+ makedepends = 7zip
depends = nss>=3.0
depends = openssl-1.1
depends = php
depends = gtk3
- depends = wine
depends = xorg-server
depends = sdl2
depends = java-runtime
+ depends = electron19
optdepends = flashplayer-standalone: native Flash support
optdepends = gtk2
optdepends = libxt
@@ -22,8 +21,8 @@ pkgbase = flashpoint-bin
options = !strip
options = !emptydirs
source = flashpoint-14.0.1.7z::https://download.unstable.life/upload/fp14.0.1_lin_main_20250222.7z
- source = flashpoint.png::https://flashpointarchive.org/w/resources/assets/path18-mw.png
+ source = flashpoint.desktop
sha256sums = bab843b8422da500056698819aa6752804eedb8ba130380403e4f49532d8537e
- sha256sums = cd1d182eb10cb346ec30fe730d3b42fe8ed66bd537c7ac835ccdab312f4e6260
+ sha256sums = 8784a3536919f917c9848fc577a9ea7649fdd709cd543f4b127a7057fc3f2e41
pkgname = flashpoint-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1d58396f50c1..fe768643858e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@
pkgname=flashpoint-bin
_pkgname=Flashpoint
pkgver=14.0.1
-pkgrel=1
+_electronversion=19
+pkgrel=2
pkgdesc="Launcher for BlueMaxima's Flashpoint - Infinity Edition.(Prebuilt version)"
arch=('x86_64')
url="https://flashpointarchive.org"
@@ -15,14 +16,14 @@ depends=(
'openssl-1.1'
'php'
'gtk3'
- 'wine'
+ #'wine'
'xorg-server'
'sdl2'
'java-runtime'
+ "electron${_electronversion}"
)
makedepends=(
- 'gendesk'
- 'p7zip'
+ '7zip'
)
optdepends=(
'flashplayer-standalone: native Flash support'
@@ -36,19 +37,24 @@ options=(
noextract=("${pkgname%-bin}-${pkgver}.7z")
source=(
"${pkgname%-bin}-${pkgver}.7z::https://download.unstable.life/upload/fp${pkgver}_lin_main_20250222.7z"
- "${pkgname%-bin}.png::${url}/w/resources/assets/path18-mw.png"
+ "${pkgname%-bin}.desktop"
)
sha256sums=('bab843b8422da500056698819aa6752804eedb8ba130380403e4f49532d8537e'
- 'cd1d182eb10cb346ec30fe730d3b42fe8ed66bd537c7ac835ccdab312f4e6260')
+ '8784a3536919f917c9848fc577a9ea7649fdd709cd543f4b127a7057fc3f2e41')
prepare(){
install -Dm755 -d "${srcdir}/opt/${pkgname%-bin}"
- 7zr x "${srcdir}/${pkgname%-bin}-${pkgver}.7z" -o"${srcdir}/opt/${pkgname%-bin}"
- gendesk -f -n -q --pkgname="${pkgname%-bin}" --pkgdesc="${pkgdesc}" --categories="Game" --name="${_pkgname}" --exec="${pkgname%-bin}"
+ #7zr x "${srcdir}/${pkgname%-bin}-${pkgver}.7z" -o"${srcdir}/opt/${pkgname%-bin}"
+ _file_list=(chrome_100_percent.pak chrome_200_percent.pak chrome_crashpad_handler chrome-sandbox icudtl.dat libEGL.so libffmpeg.so \
+ libGLESv2.so libvk_swiftshader.so libvulkan.so.1 resources.pak vk_swiftshader_icd.json)
+ for _files in "${_file_list[@]}";do
+ rm -rf "${srcdir}/opt/${pkgname%-bin}/Launcher/${_files}"
+ ln -sf "/usr/lib/electron${_electronversion}/${_files}" "${srcdir}/opt/${pkgname%-bin}/Launcher/${_files}"
+ done
}
package(){
cp -Pr --no-preserve=ownership "${srcdir}/opt" "${pkgdir}"
install -Dm755 -d "${pkgdir}/usr/bin"
- ln -sf "/opt/${pkgname%-bin}/start-${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
chown -R "${USER}" "${pkgdir}/opt/${pkgname%-bin}"
} \ No newline at end of file
diff --git a/flashpoint.desktop b/flashpoint.desktop
new file mode 100644
index 000000000000..1fdd7948a3ee
--- /dev/null
+++ b/flashpoint.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=14.0.20250222
+Name=Flashpoint Archive
+GenericName=Flashpoint
+Comment=An archive for games and animations from the web.
+Icon=/opt/flashpoint/Launcher/icon.svgz
+Exec=/usr/bin/env -S WINEPREFIX="/opt/flashpoint/FPSoftware/Wine" /opt/flashpoint/Launcher/flashpoint-launcher --js-flags=--lite_mode --ozone-platform-hint=auto --process-per-tab
+Path=/opt/flashpoint/Launcher
+Terminal=false
+Categories=Archiving;Game
+SingleMainWindow=true \ No newline at end of file