summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2017-05-21 11:33:48 +0200
committerSébastien Leduc2017-05-21 11:33:48 +0200
commita484379e161b452f741b3e765174178af0798c52 (patch)
tree1639a3280f02a3545ab4731b35a0c2b4e50beaf3
parent8f30ad93c8b758a5aaf78536d7c97e0c24d20ba5 (diff)
downloadaur-a484379e161b452f741b3e765174178af0798c52.tar.gz
Bump to 2.10.48 + fix dependency to guessit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--fix_beautifulsoup_4_4_0.patch11
-rw-r--r--fix_guessit_2.1.2.patch11
4 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acdcbb5d1afc..3d23e3ac948e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# mar. mars 14 18:28:46 UTC 2017
+# dim. mai 21 09:30:55 UTC 2017
pkgbase = flexget
pkgdesc = Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
- pkgver = 2.10.14
+ pkgver = 2.10.48
pkgrel = 1
url = http://flexget.com/
changelog = ChangeLog
@@ -24,7 +24,7 @@ pkgbase = flexget
depends = python2-dateutil
depends = python2-jsonschema
depends = python2-path
- depends = python2-guessit<=2.0.4
+ depends = python2-guessit>=2.1.2
depends = python2-apscheduler>=3.2.0
depends = python2-terminaltables
depends = python2-colorclass
@@ -43,12 +43,14 @@ pkgbase = flexget
optdepends = python2-guppy: for memusage plugin
optdepends = python2-transmissionrpc: Transmission support
optdepends = python2-rarfile: decompress plugin
- source = https://github.com/Flexget/Flexget/archive/2.10.14.tar.gz
+ source = https://github.com/Flexget/Flexget/archive/2.10.48.tar.gz
source = flexget.service
source = http://download.flexget.com/ChangeLog
- sha256sums = 2ff30ea9ca68b51bcfb16c943603daed3aa23e9fa350724419d50925d946e236
+ source = fix_guessit_2.1.2.patch
+ sha256sums = fe7024b516030f869189ff87afcaee09b31c34516c44346514715bf41e988f6f
sha256sums = e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa
sha256sums = dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6
+ sha256sums = 8246a4cbdb902d41379c8c4e6045da349c98428adefaf682aff0413b8b8969f7
pkgname = flexget
diff --git a/PKGBUILD b/PKGBUILD
index 6f3aafd1a748..6c31358eaece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=flexget
_pkgname=Flexget
-pkgver=2.10.14
+pkgver=2.10.48
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -29,7 +29,7 @@ depends=('python2'
'python2-dateutil'
'python2-jsonschema'
'python2-path' #AUR#
- 'python2-guessit<=2.0.4'
+ 'python2-guessit>=2.1.2'
'python2-apscheduler>=3.2.0' #AUR#
'python2-terminaltables'
'python2-colorclass'
@@ -57,13 +57,15 @@ makedepends=('python2-paver'
source=("https://github.com/Flexget/Flexget/archive/${pkgver}.tar.gz"
'flexget.service'
"http://download.flexget.com/ChangeLog"
+ "fix_guessit_2.1.2.patch"
)
changelog=ChangeLog
-sha256sums=('2ff30ea9ca68b51bcfb16c943603daed3aa23e9fa350724419d50925d946e236'
+sha256sums=('fe7024b516030f869189ff87afcaee09b31c34516c44346514715bf41e988f6f'
'e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa'
- 'dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6')
+ 'dcc1bc676b8c2b798fa9a7e0ed2b6853323e9e9d8ff696696dddeaf29cbc13d6'
+ '8246a4cbdb902d41379c8c4e6045da349c98428adefaf682aff0413b8b8969f7')
prepare() {
cd "${_pkgname}"-"${pkgver}"
@@ -71,6 +73,8 @@ prepare() {
msg "Patching shebangs to point to python2"
sed -i 's/\(python\)/\12/' flexget{,/ui}/__init__.py
+ patch -p0 < ${srcdir}/fix_guessit_2.1.2.patch
+
}
package() {
diff --git a/fix_beautifulsoup_4_4_0.patch b/fix_beautifulsoup_4_4_0.patch
deleted file mode 100644
index 53edcbaeeff2..000000000000
--- a/fix_beautifulsoup_4_4_0.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pavement.py 2015-10-31 07:12:14.000000000 +0100
-+++ pavement.py.new 2015-11-01 17:25:00.358181330 +0100
-@@ -28,7 +28,7 @@
- # There is a bug in requests 2.4.0 where it leaks urllib3 exceptions
- install_requires = [
- 'FeedParser>=5.2.1', 'SQLAlchemy >=0.7.5, !=0.9.0, <1.999', 'PyYAML',
-- 'beautifulsoup4>=4.1, !=4.2.0, <4.4', 'html5lib>=0.11', 'PyRSS2Gen', 'pynzb', 'progressbar', 'rpyc',
-+ 'beautifulsoup4>=4.1, !=4.2.0', 'html5lib>=0.11', 'PyRSS2Gen', 'pynzb', 'progressbar', 'rpyc',
- 'jinja2', 'requests>=1.0, !=2.4.0, <2.99', 'python-dateutil!=2.0, !=2.2', 'jsonschema>=2.0',
- 'python-tvrage', 'tmdb3', 'path.py', 'guessit>=0.9.3, <0.10.4', 'apscheduler',
- 'flask>=0.7', 'flask-restful>=0.3.3', 'ordereddict>=1.1', 'flask-restplus==0.7.2', 'cherrypy>=3.7.0',
diff --git a/fix_guessit_2.1.2.patch b/fix_guessit_2.1.2.patch
new file mode 100644
index 000000000000..52b4aa612144
--- /dev/null
+++ b/fix_guessit_2.1.2.patch
@@ -0,0 +1,11 @@
+--- requirements.txt 2016-06-14 08:12:16.000000000 +0200
++++ requirements.txt.new 2017-05-21 11:24:39.718303562 +0200
+@@ -17,7 +17,7 @@
+ jsonschema>=2.0
+ path.py>=8.1.1
+ pathlib>=1.0
+-guessit<=2.0.4
++guessit>=2.1.2
+ apscheduler>=3.2.0
+ # WebUI Requirements
+ cherrypy>=3.7.0