summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2018-08-29 14:58:46 +0200
committerCedric Girard2018-08-29 14:58:46 +0200
commitbee5bc8cdcba8b146a157d23023a7a9f0060317e (patch)
tree44caef98d4893cf6f57f638edfced4416a9e69b3
parent1812d520fefcae123b5a08d5fcab97f1d7d48f64 (diff)
downloadaur-bee5bc8cdcba8b146a157d23023a7a9f0060317e.tar.gz
fix for Python 3.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7f5493a7041..d3f005d9ee43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flexget-git
pkgdesc = Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
- pkgver = 2.14.2.r13156.1f8badaec
+ pkgver = 2.14.20.r13224.81a7c7ae2
pkgrel = 1
url = http://flexget.com/
arch = any
@@ -19,7 +19,7 @@ pkgbase = flexget-git
depends = python-html5lib>=0.11
depends = python-pyrss2gen
depends = python-pynzb
- depends = python-rpyc=3.3.0
+ depends = python-rpyc>=4.0
depends = python-jinja
depends = python-requests>=2.16.3
depends = python-dateutil>=2.5.3
@@ -32,7 +32,6 @@ pkgbase = flexget-git
depends = python-terminaltables>=3.1.0
depends = python-colorclass>=2.2.0
depends = python-cherrypy>=3.7.0
- depends = python-cherrypy<12
depends = python-flask>=0.7
depends = python-flask-restful>=0.3.3
depends = python-flask-restplus=0.10.1
@@ -51,9 +50,13 @@ pkgbase = flexget-git
source = git+https://github.com/Flexget/Flexget
source = flexget.service
source = flexget@.service
+ source = https://patch-diff.githubusercontent.com/raw/Flexget/Flexget/pull/2162.diff
+ source = https://patch-diff.githubusercontent.com/raw/Flexget/Flexget/pull/2193.diff
sha256sums = SKIP
sha256sums = e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa
sha256sums = 5fca3a1b6be282c0914754bbfdeef21005d936fba3d2698801bba18369e1321a
+ sha256sums = 9f69f4ea23aea830ceef992b444d73088ccf4c38f243df5105eb0f676b8b8d6d
+ sha256sums = 9d1c4847888c997881451252fd3660c547ae08108100c3f1f3b18dd52c265254
pkgname = flexget-git
diff --git a/PKGBUILD b/PKGBUILD
index 90fea0f4236c..b6313900476d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=flexget-git
_pkgname=Flexget
-pkgver=2.14.2.r13156.1f8badaec
+pkgver=2.14.20.r13224.81a7c7ae2
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more."
@@ -24,7 +24,7 @@ depends=('python'
'python-html5lib>=0.11'
'python-pyrss2gen'
'python-pynzb'
- 'python-rpyc=3.3.0'
+ 'python-rpyc>=4.0'
'python-jinja'
'python-requests>=2.16.3'
'python-dateutil>=2.5.3'
@@ -36,9 +36,7 @@ depends=('python'
'python-apscheduler>=3.2.0'
'python-terminaltables>=3.1.0'
'python-colorclass>=2.2.0'
- # https://archive.archlinux.org/packages/p/python-cherrypy/python-cherrypy-11.0.0-5-any.pkg.tar.xz
'python-cherrypy>=3.7.0'
- 'python-cherrypy<12'
'python-flask>=0.7'
'python-flask-restful>=0.3.3'
'python-flask-restplus=0.10.1'
@@ -69,11 +67,15 @@ conflicts=('flexget')
source=('git+https://github.com/Flexget/Flexget'
'flexget.service'
'flexget@.service'
+ 'https://patch-diff.githubusercontent.com/raw/Flexget/Flexget/pull/2162.diff'
+ 'https://patch-diff.githubusercontent.com/raw/Flexget/Flexget/pull/2193.diff'
)
sha256sums=('SKIP'
'e2c3a958ed0c286337cd37fba1d6cbdf4306c57fcddf2b9cc43615ce80ae83aa'
- '5fca3a1b6be282c0914754bbfdeef21005d936fba3d2698801bba18369e1321a')
+ '5fca3a1b6be282c0914754bbfdeef21005d936fba3d2698801bba18369e1321a'
+ '9f69f4ea23aea830ceef992b444d73088ccf4c38f243df5105eb0f676b8b8d6d'
+ '9d1c4847888c997881451252fd3660c547ae08108100c3f1f3b18dd52c265254')
pkgver() {
cd Flexget
@@ -83,7 +85,8 @@ pkgver() {
prepare() {
cd "${_pkgname}"
-
+ patch -p1 < ../2162.diff
+ patch -p1 < ../2193.diff
#pip-compile --output-file requirements.txt requirements.in
#pip-compile give too stricts requirements...
cp requirements.in requirements.txt
@@ -117,7 +120,7 @@ package() {
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
# Make sure the perms allow reading by all
- chmod ugo+r ${pkgdir}/usr/lib/python3.6/site-packages/FlexGet-2.14.*.dev0-py3.6.egg-info/*
+ chmod ugo+r ${pkgdir}/usr/lib/python3.7/site-packages/FlexGet-2.14.*.dev0-py3.7.egg-info/*
# install systemd user unit
install -Dm644 ../flexget.service "${pkgdir}"/usr/lib/systemd/user/flexget.service