summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author2xsaiko2020-05-07 11:36:18 +0200
committer2xsaiko2020-05-07 11:36:18 +0200
commit2f9c753717ff9a50c4c32d2a3e91530271d50d94 (patch)
tree4f6993a908262cc0f1f02af8aa3d68941aa85bda
parent6a05c755e9503c3904032fab9c7cc11e19907d39 (diff)
downloadaur-flora-git.tar.gz
upgpkg: flora-git r11.9571e40-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rwxr-xr-xflora.sh12
3 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 563891dbf078..d2a8c9bbd071 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flora-git
pkgdesc = Fabric Lightweight Obfuscation Remapping Assistant
- pkgver = r10.63aa99e
- pkgrel = 1
+ pkgver = r11.9571e40
+ pkgrel = 2
url = https://github.com/Parzivail-Modding-Team/FLORA
arch = any
license = MIT
@@ -10,7 +10,9 @@ pkgbase = flora-git
provides = flora
conflicts = flora
source = flora::git+https://github.com/Parzivail-Modding-Team/FLORA.git
+ source = flora.sh
sha512sums = SKIP
+ sha512sums = a1949d20f6224cce775ada96f7de63cb8e503c977cd1bae7b5192fcd3ba19f83e22ce947235a73b1188ce42043c85140abe149043ef4b3e4b93b4d971576150c
pkgname = flora-git
diff --git a/PKGBUILD b/PKGBUILD
index 2e31a1884b62..4bd9eb48547f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=flora-git
_pkgname=${pkgname%-git}
-pkgver=r10.63aa99e
-pkgrel=1
+pkgver=r11.9571e40
+pkgrel=2
pkgdesc="Fabric Lightweight Obfuscation Remapping Assistant"
arch=("any")
url="https://github.com/Parzivail-Modding-Team/FLORA"
@@ -10,8 +10,14 @@ provides=("${_pkgname}")
conflicts=("${_pkgname}")
depends=("dotnet-runtime")
makedepends=("dotnet-sdk")
-source=("${_pkgname}::git+https://github.com/Parzivail-Modding-Team/FLORA.git")
-sha512sums=("SKIP")
+source=(
+ "${_pkgname}::git+https://github.com/Parzivail-Modding-Team/FLORA.git"
+ 'flora.sh'
+)
+sha512sums=(
+ 'SKIP'
+ 'a1949d20f6224cce775ada96f7de63cb8e503c977cd1bae7b5192fcd3ba19f83e22ce947235a73b1188ce42043c85140abe149043ef4b3e4b93b4d971576150c'
+)
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -27,12 +33,11 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}"
-
install -dm755 "${pkgdir}/usr/bin/"
install -dm755 "${pkgdir}/usr/lib/flora/"
- cp -r build/* "${pkgdir}/usr/lib/flora/"
+ cp -r "${srcdir}/${_pkgname}/build"/* "${pkgdir}/usr/lib/flora/"
+ install -m755 "${srcdir}/flora.sh" "${pkgdir}/usr/bin/flora"
ln -s "/usr/lib/flora/FLORA" "${pkgdir}/usr/bin/FLORA"
install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
diff --git a/flora.sh b/flora.sh
new file mode 100755
index 000000000000..929697593706
--- /dev/null
+++ b/flora.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+CONF_DIR="$HOME/.config/FLORA"
+
+mkdir -p ${CONF_DIR}
+
+# if args contains -c then don't append default conf path
+if [[ " ${@} " =~ " -c " ]]; then
+ /usr/lib/flora/FLORA ${@}
+else
+ /usr/lib/flora/FLORA -c ${CONF_DIR} ${@}
+fi