summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcd19922020-02-25 21:38:36 -0600
committermcd19922020-02-25 21:38:36 -0600
commit679cac661f7efaa812c4e6d12877440f9dee0e8f (patch)
treef2a6a5958f26f27e66e9762809ab3209af880840
downloadaur-fluent-bit-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..308cbe69213a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fluent-bit-git
+ pkgdesc = Collect data/logs from different sources, unify and send them to multiple destinations
+ pkgver = 1.3.0.r432.g66837f34
+ pkgrel = 1
+ url = https://fluentbit.io/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ backup = etc/fluent-bit/fluent-bit.conf
+ backup = etc/fluent-bit/parsers.conf
+ backup = etc/fluent-bit/plugins.conf
+ source = fluent-bit-git::git+https://github.com/fluent/fluent-bit.git
+ md5sums = SKIP
+
+pkgname = fluent-bit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c547e23e1e4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignored folders
+src/
+fluent-bit-git/
+
+# Ignored files
+*.pkg.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a608fbb5db10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
+
+pkgname=fluent-bit-git
+pkgver=1.3.0.r432.g66837f34
+pkgrel=1
+pkgdesc="Collect data/logs from different sources, unify and send them to multiple destinations"
+url="https://fluentbit.io/"
+arch=('i686' 'x86_64')
+license=('Apache')
+makedepends=('git' 'cmake' 'make' 'gcc')
+depends=()
+optdepends=()
+backup=('etc/fluent-bit/fluent-bit.conf' 'etc/fluent-bit/parsers.conf' 'etc/fluent-bit/plugins.conf')
+source=("${pkgname}::git+https://github.com/fluent/fluent-bit.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ # Remove 'v' prefix on tags; prefix revision with 'r'; replace all '-' with '.'
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DFLB_TLS=1 ..
+ make
+}
+
+package() {
+ cd ${pkgname}/build
+
+ make DESTDIR="$pkgdir/" install
+
+ # move /lib/* to /usr/lib
+ mv ${pkgdir}/lib/* ${pkgdir}/usr/lib
+ rmdir $pkgdir/lib
+
+ install -DTm644 ../LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}