summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Gausmann2018-01-08 22:50:52 -0700
committerAdam Gausmann2018-01-08 22:52:35 -0700
commitaf6cb305e8c784f72c98616f48e7ac0366e6ab5a (patch)
treee5ebf94ccc92cc7c8d9b8b39e6818af1e4ab8ef7
downloadaur-fluffy-git.tar.gz
r1 Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE12
-rw-r--r--PKGBUILD49
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abfd52fbe6a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fluffy-git
+ pkgdesc = Tools for Network Archaeology (internet protocol analysis)
+ pkgver = r60.69ee969
+ pkgrel = 1
+ url = https://github.com/dirtbags/fluffy
+ arch = any
+ license = custom
+ makedepends = git
+ provides = fluffy
+ conflicts = fluffy
+ source = git+https://github.com/dirtbags/fluffy#branch=master
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 19eef14ffb7f4fc3c0eb4febc4989311
+
+pkgname = fluffy-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..509222586f34
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,12 @@
+This software has been authored by an employee or employees of Los Alamos
+National Security, LLC, operator of the Los Alamos National Laboratory (LANL)
+under Contract No. DE-AC52-06NA25396 with the U.S. Department of Energy. The
+U.S. Government has rights to use, reproduce, and distribute this software.
+The public may copy, distribute, prepare derivative works and publicly display
+this software without charge, provided that this Notice and any statement of
+authorship are reproduced on all copies. Neither the Government nor LANS makes
+any warranty, express or implied, or assumes any liability or responsibility
+for the use of this software. If software is modified to produce derivative
+works, such modified software should be clearly marked, so as not to confuse
+it with the version available from LANL.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d06f61040770
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Adam Gausmann <agausmann@fastmail.com>
+# Repository Maintainer: Neale Pickett <neale@woozle.org>
+
+_pkgname="fluffy"
+pkgname="${_pkgname}-git"
+pkgver=r60.69ee969
+pkgrel=1
+pkgdesc="Tools for Network Archaeology (internet protocol analysis)"
+arch=('any')
+url="https://github.com/dirtbags/fluffy"
+license=('custom')
+groups=()
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("git+https://github.com/dirtbags/${_pkgname}#branch=master" 'LICENSE')
+noextract=()
+md5sums=('SKIP' '19eef14ffb7f4fc3c0eb4febc4989311')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${_pkgname}"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+}
+
+check() {
+ cd "$srcdir/${_pkgname}"
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ cd "$srcdir/${_pkgname}"
+ export CPPFLAGS="$CPPFLAGS -O"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}