summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Korpel2015-06-10 15:01:33 +0200
committerMarcel Korpel2015-06-10 15:01:33 +0200
commit4829c91756ce841c601be59df3a430affa2c71b5 (patch)
tree94c69e1d5b809ee75a61a2f1f575b40e9a36320e
downloadaur-fondu.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--makefile.patch15
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fae637471a28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fondu
+ pkgdesc = Mac font conversion utility
+ pkgver = 060102
+ pkgrel = 4
+ url = http://fondu.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ source = http://fondu.sourceforge.net/fondu_src-060102.tgz
+ source = makefile.patch
+ sha256sums = 22bb535d670ebc1766b602d804bebe7e84f907c219734e6a955fcbd414ce5794
+ sha256sums = c6390af3ba4daecf7d548d0f0c46e691444fa31ba67f530e5354720288314f6b
+
+pkgname = fondu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4f6140baa56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+# Contributor: Kwpolska <kwpolska@kwpolska.tk>
+# Contributor: Eric Mertens <emertens@gmail.com>
+
+pkgname=fondu
+pkgver=060102
+pkgrel=4
+arch=('i686' 'x86_64')
+pkgdesc="Mac font conversion utility"
+url="http://fondu.sourceforge.net/"
+license=('BSD')
+source=("http://fondu.sourceforge.net/fondu_src-$pkgver.tgz"
+ "makefile.patch")
+sha256sums=('22bb535d670ebc1766b602d804bebe7e84f907c219734e6a955fcbd414ce5794'
+ 'c6390af3ba4daecf7d548d0f0c46e691444fa31ba67f530e5354720288314f6b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ chmod +w Makefile
+ patch Makefile ../makefile.patch
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ # move everything in /bin to /usr/bin
+ cd "${pkgdir}"
+ mv bin usr
+}
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..3ac2e52b4d11
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile b/Makefile
+index a3b87ff..ba33431 100644
+--- a/Makefile
++++ b/Makefile
+@@ -57,8 +57,8 @@ distclean: clean
+ -rm Makefile
+
+ install: all
+- mkdir -p $(DESTDIR)$(bindir)
+- cp fondu ufond showfond dfont2res tobin frombin lumper setfondname $(DESTDIR)$(bindir)
++ mkdir -p "$(DESTDIR)"$(bindir)
++ cp fondu ufond showfond dfont2res tobin frombin lumper setfondname "$(DESTDIR)"$(bindir)
+
+
+ VERSION:=$(shell date +"%y%d%m")